We cant connect to the server at www.google.com

I have tried almost everythinng on the Linux terminal please help just please help. I cant connect to the internet yet i have a networkProcessing: 16784745401737694488392682747350.jpg…

Hi @olwethu, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.



Sounds like a DNS issue. Cab you ping an IP?

ping -c 4

Edit #2:

Can you provide the output of:

cat /etc/resolv.conf

For example, what have you tried?

it says cat: /etc/resolv.conf: No such file or directory

forgive please I am still new at Linux ,i tried almost everything on youtube ,i even re-booted kali in my laptop

I will try to provide screenshots hence i am using a friends laptop

… and Kali works?

cat /etc/resolv.conf

This file not being present is rather impossible - points to a flaw in your installation.
(or in the integrity of your installation medium)

If NetworkManager is running - this file will be there.

no images, please!
at least not posted here on the forum - post them to some external site and give the link to them here

Can you explain WHY you deleted that file, because it should be there by default.
It should either be a symbolic link to some specific other file or a static file with some content, but always present…

If you are unable to provide command output from your system because you can’t connect to the internet, you should boot from a Live-ISO and get the info that way.
Never post images, unless there is absolutely no other way (which is not the case here)

That is probably why you can’t access google.com, or any other website for that matter. That file is extremely important, especially for networking, more specifically domain name resolution, as it contains the location of the “phone book” to use to look up those domains’ addresses.

It won’t be missing for no reason, so the question is, why did you remove it? And how?