Sleep not working properly on laptop

I had recently bought a HP Victus 15 (model: MT7921) And have installed Manjaro on it because Windows 11 is too bloaty for me. I had a different laptop with Manjaro also, and the sleep worked fine on that (it was an Acer Aspire iirc, don’t remember exact model though), however whenever I put the laptop to sleep, hibernate or even put the screen down, the screen is stuck on a black screen or only periodically flashes parts of the log-in page.

My syatem is completely up-to-date, no package updates needed, and I’m running Linux64.


  Kernel: 6.4.3-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.4-x86_64
    root=UUID=d68c0860-e754-4d64-8ae9-c97ecd51d9bb rw quiet splash
    resume=UUID=8f803748-e945-451c-a788-6c6929a68f7a udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: Victus by HP Gaming Laptop 15-fa0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8A50 v: 37.52 serial: <superuser required> UEFI: AMI
    v: F.12 date: 11/11/2022
  ID-1: BAT0 charge: 51.0 Wh (100.0%) condition: 51.0/52.6 Wh (97.1%)
    volts: 13.1 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: full cycles: 2
  Info: model: 12th Gen Intel Core i5-12450H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x42A
  Topology: cpus: 1x cores: 8 mt: 4 tpc: 2 st: 4 threads: 12 smt: enabled
    cache: L1: 704 KiB desc: d-4x32 KiB, 4x48 KiB; i-4x32 KiB, 4x64 KiB L2: 7 MiB
    desc: 4x1.2 MiB, 1x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1159 high: 2500 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 595 2: 785 3: 966 4: 2500
    5: 1005 6: 1025 7: 400 8: 2500 9: 1003 10: 995 11: 1166 12: 971
    bogomips: 59916
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
    chip-ID: 8086:46a3 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
    vendor: Hewlett-Packard driver: nvidia v: 535.54.03
    alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony HP Wide Vision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:3 chip-ID: 04f2:b766
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa dri: iris
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x094d built: 2020 res: 1920x1080
    hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10fa class-ID: 0403
  API: ALSA v: k6.4.3-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.74 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:4 chip-ID: 13d3:3567
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 20.23 GiB (8.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL2256HCHQ-00BH1
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS3NGXH temp: 34.9 C
    scheme: GPT
  ID-1: / raw-size: 229.37 GiB size: 224.71 GiB (97.97%) used: 20.2 GiB (9.0%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 26.8 MiB (0.3%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 34.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2211 fan-2: 1987
  Processes: 287 Uptime: 13m wakeups: 53347 Memory: total: 8 GiB note: est.
  available: 7.43 GiB used: 4.96 GiB (66.7%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1217 libs: 378 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28

Any help is appreciated, let me know if any more info is required. Thanks.

Hi @czmc, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Please also note and heed: Forum Rules - Manjaro

Please also provide the output of:

sudo systemctl status

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

1 Like

Thanks for the info, I’m quite new to the forums so I don’t know posting etiquette, just updated OP with the system output of inxi command, hope that helps and if the post needs anything else, please let me know.

Here’s the output of the command you provided:

○ - Suspend
     Loaded: loaded (/usr/lib/systemd/system/; static)
     Active: inactive (dead)
       Docs: man:systemd.special(7)

○ - Sleep
     Loaded: loaded (/usr/lib/systemd/system/; static)
     Active: inactive (dead)
       Docs: man:systemd.special(7)

○ - System Hibernation
     Loaded: loaded (/usr/lib/systemd/system/; static)
     Active: inactive (dead)
       Docs: man:systemd.special(7)

Thanks for replying!

Hi there & welcome. Is there a specific reason why you need the 6.4 kernel? Using a non-LTS/non-recommended kernel opens users up to all sorts of potential issues. Unless you have a specific use case, I would suggest you run 6.1. That may or may not sort out this specific problem but either way, it’s a more stable option. Go well meantime. R

Have you tried changing the suspend method?

You’re welcome, that’s why I gave it to you.

What happens when you run:

systemctl suspend


systemctl hibernate

Also, like @ruziel said, it might just be cause you’re using kernel 6.4, while I recommend the latest LTS one, unless you have a specific reason to use the latest.

1 Like

I was using Linux61, and when I first came across this issue I thought I might just need to update the kernel, so I went to Linux64 because that’s the latest, non-experimental kernel that’s out and hoped that might fix the issue… needless to say, it didn’t.

The same issues occur when I use both systemctl suspend and systemctl hibernate or the buttons in the start menu. The screen immediately goes to black, which is normal, but whenever I try to reactivate the laptop by either pressing the keyboard, trackpad or power button, nothing happens, sometimes the screen brightens to a lighter grey for a few seconds before going back to pure black.

I’ll be switching back to Linux61, because as you both you and @ruziel say, it’s just better compatibility and easier to service. But that’s definitely not the cause of this issue because it happens on both Linux61 and linux64

It seems when I use:

cat /sys/power/mem_sleep

The only output is [s2idle]… Maybe this laptop doesn’t have s3 sleep and is reliant on Windows s0 sleep?

And if you just run:


…in the terminal?

Absolutely nothing, nothing happened.

I don’t think my system is even capable of doing any sleep mode other than S0 sleep. There’s no option for it in BIOS apart from “S3/S4/S5 Wake on LAN”, whatever that means.


I have absolutely no idea then. All I can do is suggest you work through the article @Teo gave you, and see what you can see there…sorry.


Btw, try moving mouse/touchpad when the screen is black.

Well if s2idle is the only entry then there is nothing to change… i had pretty much the exact same issue but in my case “[deep]” was “wrongly” detected and selected, so i changed it and that fixed it. You can still try, on next boot, to interrupt GRUB (show the menu with ESC) and temporarily edit the boot entry (press E) and append mem_sleep_default=s2idle at the line kernel boot line, but i doubt it will do anything if it is already selected, theoretically.

Also, look at the bios/uefi setting. Maybe you can control the sleep states somewhere. S2idle is S0. If somewhere in the bios is selected S3 or S4 that can be the cause - change it to S0.

And look here - Laptop/HP - ArchWiki
I cannot find your model, but other HP models have notes for other possible kernel parameters like acpi.ec_no_wakeup, iommu, etc. You can test a couple.

Well, as I was looking through my laptop’s BIOS and on other forums to see if others have had this issue, I found that the HP BIOS the laptop is currently running (F.12) doesn’t enable any other type of sleep option other than S0 because HP expects users to use only Windows and doesn’t cater to Linux users at all! Hooray!

I would just update the BIOS, but of course the update file is a .exe and I don’t really wanna go through the whole process of updating through USB because I know I’ll somehow screw up and brick my laptop :).

For anyone in the future who also may have a similar issue but not my exact one. Please go through the checklist posted by @Teo, while it didn’t help me it’s still very useful for troubleshooting.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.