/boot/vmlinuz-6.1-x86_64' not found. error: you need to load the kernel first

I’ve solved two previous problems, but a new error appears
/lib/modules/6.1.23-1-MANJARO/modules.devname not found – ignoring
And stuck at boot logo but the word Manjaro appears before it



Plymouth is a boot screen intended to cover up onscreen text during boot; to make it prettier.
Unfortunately, Plymouth can sometimes cause more problems than it’s worth.

I suggest you uninstall Plymouth, completely.

The correct procedure to uninstall Plymouth can be found in Plymouth (Manjaro Wiki) under the heading of REMOVAL.

You should follow the procedure exactly. It’s not as simple as a normal uninstall. Once finished, reboot and hopefully the issue will be resolved. If not, or if another error occurs, be sure to report back.

I hope this helps. Cheers.

Okay. Do the following. Run command (from your USB installer):-

sudo mount /dev/nvme0n1p2 /mnt


ls /mnt/boot

Can you produce output of the ls command? Also check the output for

ls /mnt/usr/lib/modules

Do you see your kernel version listed in there? It should be of the form 6.1.xx-yy-MANJARO. Can you give us the full version, ie, including whatever xx and yy are showing?

Concerning your partitions, I’m not sure what type of disk sdb is. It appears to be a multimedia card, but it’s formatted as an MBR drive, as opposed to your Nvme disk being foematted as GPT. Strictly speaking with UEFI mode it’s best practice to have multi-disks all configured as GPT, altthough your particular boot issue is unaffected as the error message indicates you successfully got as far as grub stage. I’m also confused by disk sda. I thought it might be your USB installer, but partition shows that doesn’t appear to be the case.

Currently running Linux 61

Are you ignoring this suggestion because it seems too complicated?
Or, do you somehow believe it’s irrelevant?

Note that if this fails to solve the issue, you can always reinstall it later; that is, if you simply must have a pretty boot screen.

I have previously brought attention to the drives, however, the OP has failed to even acknowledge the post, let alone give any meaningful response.

Perhaps some Moderator Magic may help.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

Strange, because ls commands show your latest kernel is definitely present, as are its modules. However I see the initramfs image for the previous kernel515 is missing (unless I’m missing something), although that won’t affect your booting to current kernel. So need to investigate further.

Boot to USB installer. Then as previoualy, run:-

sudo mount /dev/nvme0n1p2 /mnt

Then run:-

grep -i -A13 "menuentry 'Manjaro " /mnt/boot/grub/grub.cfg | head -14

Post up that output. Rather than do it by a photo, just paste output here, then highlight the whole output and hit the " blockquote button, above.

[manjaro@manjaro ~]$ sudo mount /dev/nvme0n1p2 /mnt
[manjaro@manjaro ~]$ grep -i -A13 "menuentry 'Manjaro " /mnt/boot/grub/grub.cfg | head -14
grep: /mnt/boot/grub/grub.cfg: Permission denied
[manjaro@manjaro ~]$ sudo grep -i -A13 "menuentry 'Manjaro " /mnt/boot/grub/grub.cfg | head -14
menuentry ‘Manjaro Linux’ --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-simple-074b2a58-0d75-4160-b39d-e0f7b4a3ef70’ {
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
search --no-floppy --fs-uuid --set=root 074b2a58-0d75-4160-b39d-e0f7b4a3ef70
linux /boot/vmlinuz-6.1-x86_64 root=UUID=074b2a58-0d75-4160-b39d-e0f7b4a3ef70 rw quiet splash apparmor=1 security=apparmor udev.log_priority=3
initrd /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
submenu ‘Advanced options for Manjaro Linux’ $menuentry_id_option ‘gnulinux-advanced-074b2a58-0d75-4160-b39d-e0f7b4a3ef70’ {
menuentry ‘Manjaro Linux (Kernel: 6.1.23-1-MANJARO x64)’ --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-6.1.23-1-MANJARO x64-advanced-074b2a58-0d75-4160-b39d-e0f7b4a3ef70’ {

What is your native language?
I suspect this whole process may be smoother using a Translator.

English is fine for me

You don’t seem to be using much of that English.

Perhaps you could address the many helpful posts and suggestions previously offered, that you seem to have ignored completely.

I’m certain that would be greatly appreciated by all.


Sorry, I tried your last suggestion before ,but I forget to reply you :pensive:

See. This is the problem…

It’s nice to know you tried a suggestion.

What forum members expect is that you report back with the results of having tried a suggestion, to know whether or not a suggestion was successful. And, please, try to make it more detail than simply saying something like it doesn’t work.

We’re happy to help where we can, but without sufficient feedback from you, it’s next to impossible. This is why some members might become quite irate about your lack of useful responses (and rightfully so).

Afterall, we’re only trying to help.

Well, most of us, anyway. Some are just grumpy by nature.


I usually press the “tracking” button and change it to “normal” or sometimes even “muted” so I don’t have to be bothered with it any more.
I’m all for helping people, but if the receiver does not return with enough respect to even keep me updated, I walk away.

It’s good that you take these things up in threads that are not going “very well”.
Depending on the response after such a message is when I might leave or get further involved if I haven’t already done so. :slight_smile:

1 Like

I have good news, my computer can boot normally☺️,


What did you do to make your computer boot normally?
Please tell us. We can’t possibly go on, without knowing!


boot into manjaro live usb and:

sudo su -
sudo manjaro-chroot-a
sudo mkinitcpio -P
sudo reboot

Excellent, you solved it yourself.
Let’s give you a little tick for that.

Thank you for choosing Manjaro.


I sincerely appreciate everyone’s assistance and support. Thank you.

1 Like

Almost correct.
Do you understand what those commands do?

Let me give you a short lesson, let me just put on my professor glasses.

sudo su - means you switch to the root user. ALWAYS be careful when doing operations after this, YOU ARE ROOT!!!

Since you are now root, DO NOT USE SUDO!
sudo = super user do, NOT = root (just keep this in mind, usually no problems but CAN be a problem) but all interactions will kinda be like done by root. So if you are root, do not use sudo.

manjaro-chroot -a = the -a tag instructs the script manjaro-chroot to mount the partitions that is needed for you to enter chroot, ie you change to the system you have installed even though you booted with a usb stick.

Should be without sudo

Instead of rebooting from inside the chroot (and again, do not use sudo if you are root) but rather type exit first to exit chroot env THEN reboot. In this case you would still be root so you can just type reboot now or type exit one more time to go back to the “normal” user and THEN sudo reboot now.

A little example of how root and sudo is not the same.

Do this as your user:

sudo su
sudo cd

pwd shows what directory you are currently in the shell.
cd brings you to your home directory, as your user it would be /home/username.
For root home is /root.
So if you type sudo cd it should bring you to /root just like it did while in sudo su right? :slight_smile: