Speakers not working on Laptop HP Envy x360 2-in-1 Laptop 15-fe0xxx

Hi all,

I’ve been a silent manjaro Gnome user for 5 years now, and i recently installed Manjaro KDE on a new laptop (HP Envy x360 2-in-1 Laptop 15-fe0xxx) and i just realized the speakers don’t work, which is a problem. Here is what’s happening :

  • If i plug in 3.5mm jack earbuds, i can ear the sound from the laptop, but it is faint (even at 150%).

  • With the earbuds plugged, i can see both the earbuds microphone and the internal microphone picking up sound.

  • As soon as the jack is unplugged, no sound whatsoever is coming from the speakers

This is my detailed system information :

  Kernel: 6.6.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=2721f802-59c4-4338-bca1-23b0da1a8bb9 rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 info: latte-dock
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP Envy x360 2-in-1 Laptop 15-fe0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 8BE0 v: 69.32 serial: <superuser required> UEFI: Insyde
    v: F.03 date: 08/29/2023
  ID-1: BAT1 charge: 26.6 Wh (52.0%) condition: 51.2/55.7 Wh (91.9%)
    power: 7.9 W volts: 15.2 min: 15.1 model: 333-AC-31-A SA04055XL type: Li-ion
    serial: <filter> status: discharging
  Device-1: hid-0018:04F3:4164.0002-battery model: ELAN2513:00 04F3:4164
    serial: N/A charge: N/A status: N/A
  System RAM: total: 16 GiB note: est. available: 15.34 GiB
    used: 6.07 GiB (39.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 13th Gen Intel Core i7-1355U bits: 64 type: MST AMCP
    arch: Raptor Lake level: v3 note: check built: 2022+ process: Intel 7 (10nm)
    family: 6 model-id: 0xBA (186) stepping: 3 microcode: 0x411C
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 400 min/max: 400/5000:3700 scaling: driver: intel_pstate
    governor: powersave cores: 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400 7: 400
    8: 400 9: 400 10: 400 11: 400 12: 400 bogomips: 62688
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep smx split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip user_shstk vaes vme vmx vnmi
    vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:a7a1 class-ID: 0300
  Device-2: Luxvisions Innotech HP Wide Vision 5MP Camera
    driver: hid-sensor-hub,usbhid,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 3-7:2 chip-ID: 30c9:00ab class-ID: fe01
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: eDP-1 model: Samsung 0x416c built: 2020 res: 1920x1080 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (RPL-U)
    device-ID: 8086:a7a1 memory: 14.98 GiB unified: yes
  API: Vulkan v: 1.3.274 layers: N/A device: 0 type: integrated-gpu
    name: Intel Graphics (RPL-U) driver: mesa intel v: 23.1.9-manjaro1.1
    device-ID: 8086:a7a1 surfaces: xcb,xlib
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51ca class-ID: 0401
  API: ALSA v: k6.6.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f1 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:3 chip-ID: 8087:0033
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 42.78 GiB (9.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZH
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS1 temp: 22.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 97.76 GiB size: 95.67 GiB (97.86%) used: 12.31 GiB (12.9%)
    fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 label: N/A
    uuid: 2721f802-59c4-4338-bca1-23b0da1a8bb9
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 86.8 MiB (33.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM uuid: 1E8D-1595
  ID-3: /home/<filter>/Data raw-size: 273.44 GiB size: 273.43 GiB (100.00%)
    used: 30.39 GiB (11.1%) fs: exfat dev: /dev/nvme0n1p5 maj-min: 259:5
    label: Data uuid: B899-E86C
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 104.83 GiB fs: ntfs
    label: Windows uuid: 6A4AF2494AF21195
  ID-3: /dev/nvme0n1p6 maj-min: 259:6 size: 642 MiB fs: ntfs
    label: Windows RE tools uuid: FC002F77002F3852
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 2-0:1 info: super-speed hub ports: 3 rev: 3.1
    speed: 20 Gb/s (2.33 GiB/s) lanes: 2 mode: 3.2 gen-2x2 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-1:4 info: Sunplus Innovation Optical Mouse type: mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s (183 KiB/s)
    lanes: 1 mode: 1.0 power: 98mA chip-ID: 1bcf:0005 class-ID: 0301
  Device-2: 3-7:2 info: Luxvisions Innotech HP Wide Vision 5MP Camera
    type: video,HID driver: hid-sensor-hub,usbhid,uvcvideo interfaces: 6 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 500mA
    chip-ID: 30c9:00ab class-ID: fe01 serial: <filter>
  Device-3: 3-10:3 info: Intel AX211 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-4: 4-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 36.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 0 fan-2: 0
  Processes: 269 Uptime: 1h 47m wakeups: 0 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1134 libs: 315 tools: pamac Shell: Bash v: 5.2.21
  running-in: konsole inxi: 3.3.31

i have read a few topics about sound issues on similar laptops, but i don’t have the knowledge to actually understand anything deep enough to fix my problem.


Any help is appreciated :slight_smile:

nikgnomic: post edited to show inactive link in preformatted text format. Forum does not allow new users to post active links

Hi @Acetone and welcome to the Manjaro community

Let’s start with these:

Once you have formatted your post to make it easier for others to read, I’m sure someone will help you further. Cheers.

1 Like

Thanks a lot @soundofthunder, i’ve done my best to edit the post.


Based on other sounds problems i have found on the forum i’ve tried a few things

  • I have tried updating the BIOS via HP Smart assistant in windows (the system is dual-boot for work purposes) : no change, sound is ok in windows, inexistant through speakers in linux and very faint through earbuds (but present)

  • Switching kernels : i was originally running 6.6.8-2 LTS. Tried 6.7.0rc7-2 : no change . Tried 6.6.7_rt18-1 : no change. Tried 4.19.303-1 : system doesn’t boot.

  • I have found this thread, of someone with a very similar problem, but i don’t understand the depth of the fix for now, how could i check that the problem is the same ?


Any ideas on where i could look next ?

Any help is greatly appreciated, as i need my manjaro system to do video editing :smiley:

!!PCI Soundcards installed in the system

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Raptor Lake-P/U/H cAVS [8086:51ca] (rev 01)
	Subsystem: Hewlett-Packard Company Raptor Lake-P/U/H cAVS [103c:8be0]

A patch has been created recently (26 Jan 2024) to get Cirrus smart amplifiers working for HP systems

[v1,4/4] ALSA: hda/realtek: Add quirks for various HP ENVY models - Patchwork

These models use 2 or 4 CS35L41 amps with HDA using I2C or SPI.
Some models have _DSD support inside cs35l41_hda_property.c.

` + SND_PCI_QUIRK(0x103c, 0x8be0, “HP Envy 15”, ALC287_FIXUP_CS35L41_I2C_2),

But the patch has not been included in latest kernel releases (v6.6.15, v6.7.13 or v6.8-rc3)
so it may take a few weeks for a patched kernel to be available on Manjaro stable branch