Fail to boot after update

Same problem myself today. Managed to get into GUI by changing to free nvidia driver with mhwd-tui after switching to a tty (CTRL + ALT + F3)


Then select install free driver option (3).

Problem is now my performance is tanked and I cannot do any of my usual graphic-heavy tasks. Trying to install the non-free drivers gives me this

( Untitled - Paste-bin for Sharing Code and Text if image doesn’t work)

Older kernels have unsupported warnings now, too. Never seen that before

So I installed newer kernel, too. Didn’t fix mhwd-tui from not being able to pull the non-free drivers, expectedly.

The heck’s going on…

1 Like

you are running the 5.17 kernel which is EOL, so switch to another kernel in grub and then remove the 5.17
also noticed you have installed the 5.16, so remove it too


Thanks for the heads up but as I said this simply didn’t change anything.

it wants to install onto the 5.16 and 5.17 kernels which are no longer supported, so remove these kernels, and run installation of nvidia drivers again…

Bruh I can’t even

To clarify, that picture is old when I first noticed. I’m on the latest kernels and they’re all removed. Still same error. I’ll do a pacman fix and restart.

select the 5.15 kernel in grub, can you boot with it?

I don’t get a grub screen it just uses whatever the latest kernel installed is.

Then you need to press ESC on keyboard to show the kernel select list.

you are running the 5.17 kernel so during booting tap repeatedly esc the grub menu should appear, if esc doesnt work try tapping shift

1 Like

Selected latest kernel manually this time. Looks like it was auto selecting a backup one or something. Another problem was that the mhwd-tui wasn’t uninstalling the free drivers and still using them.

mhwd-gpu -r -pci video-linux

as su worked. After a reboot all seems back to normal :slight_smile:

just to be sure post output from:
mhwd -l && mhwd -li

1 Like


1 Like