Camera not working on Acer Aspire A515-57G

Please someone help me solving camera issue… I have tried every solution online but still camera is not detected by any software.

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.6.19-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 16 × 12th Gen Intel® Core™ i5-1240P
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: Acer
Product Name: Aspire A515-57G
System Version: V1.26

output of lsusb :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0408:4033 Quanta Computer, Inc. ACER HD User Facing
Bus 003 Device 003: ID 04f3:0c4f Elan Microelectronics Corp. ELAN:Fingerprint
Bus 003 Device 004: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

output of dmesg | grep uvc

[    5.374356] uvcvideo 3-7:1.1: Failed to query (129) UVC probe control : 26 (exp. 48).
[    5.374360] uvcvideo 3-7:1.1: Failed to initialize the device (-5).
[    5.374416] usbcore: registered new interface driver uvcvideo
[   41.870053] usbcore: deregistering interface driver uvcvideo
[   49.652173] uvcvideo 3-7:1.1: Failed to query (129) UVC probe control : 26 (exp. 48).
[   49.652196] uvcvideo 3-7:1.1: Failed to initialize the device (-5).
[   49.652449] usbcore: registered new interface driver uvcvideo

Thank you for any help in advance.

Hi @Ap2011930, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Please also note and heed: Forum Rules - Manjaro

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.


Thank you for the additional information.

However, in this guide:

…it specifies to please provide the output of:

inxi --full --admin --filter --width

…which I can’t find here. Please go through the guide and provide everything that’s required.

From what I could deduce from the incomplete information, this:

Seems to be your camera, and according to this page:

The device is supported by kernel versions 4.5 and newer according to the LKDDb:

and it seems you’re using

So try an older kernel version, perhaps, version 6.1 is what I’d recommend:

Too install it, run:

sudo mhwd-kernel --install linux61

Reboot into it, when successfully done:

All available kernels installed on your system will be presented upon booting up. GNU GRUB is visible with a couple of options. Choose “Advanced Options for Manjaro Linux” by using the arrow keys , on your keyboard and then ↵ Enter.

On the next screen (as illustrated) are backup copies of each kernel version installed (which will also be automatically removed if or when a kernel version is deleted). To select a kernel, simply use the arrow keys , to highlight the desired version, and then press ↵ Enter.

Thank you for replying. I switched to kernel version 6.1 as you suggested and yet problem persists. I am currently running that kernel. and here is the output for

inxi --full --admin --filter --width
  Kernel: 6.1.80-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=95f4974a-b9e0-42a6-9963-8fb6704e7a3d rw quiet splash
    resume=UUID=71f6007a-08e7-4c15-ab61-8e96b012e008 udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland vt: 1 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Laptop System: Acer product: Aspire A515-57G v: V1.26
    serial: <superuser required>
  Mobo: ADL model: Ganymede_ADU v: V1.26 serial: <superuser required>
    part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 1.26
    date: 01/23/2024
  ID-1: BAT1 charge: 37.9 Wh (71.5%) condition: 53.0/53.0 Wh (100.0%)
    volts: 16.0 min: 15.4 model: PANASONIC AP19B5L type: Li-ion serial: <filter>
    status: discharging
  Info: model: 12th Gen Intel Core i5-1240P bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x430
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB L2: 9 MiB
    desc: 4x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 410 high: 561 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 561 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400
    15: 400 16: 400 bogomips: 67600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-12.2
    process: Intel 10nm built: 2021-22+ ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:4626
    class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 2050] vendor: Acer Incorporated ALI
    driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 bus-ID: 0000:01:00.0
    chip-ID: 10de:25a9 class-ID: 0302
  Device-3: Quanta ACER HD User Facing driver: N/A type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:2 chip-ID: 0408:4033
    class-ID: fe01 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
    unloaded: nouveau alternate: fbdev,nv,vesa dri: iris gpu: i915,nvidia
    display-ID: 0
  Monitor-1: eDP-1 res: 1745x982 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: iris
    surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
    inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:4626 memory: 7.29 GiB unified: yes display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 2050 driver: nvidia v: 550.54.14
    device-ID: 10de:25a9 surfaces: xcb,xlib,wayland device: 1
    type: integrated-gpu name: Intel Graphics (ADL GT2) driver: mesa intel
    v: 24.0.2-manjaro1.1 device-ID: 8086:4626 surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Acer Incorporated ALI driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.1.80-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI RTL8111/8168/8411 driver: r8169 v: kernel
    port: 3000 bus-ID: 0000:2b:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp43s0 state: down mac: <filter>
  Info: services: NetworkManager,wpa_supplicant
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 476.94 GiB used: 24.04 GiB (5.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2450 MTFDKBA512TFK
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: V5MA010 temp: 40.9 C
    scheme: GPT
  ID-1: / raw-size: 200 GiB size: 195.8 GiB (97.90%) used: 15.21 GiB (7.8%)
    fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Src: /sys System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 8 GiB note: est. available: 7.47 GiB used: 3.07 GiB (41.1%)
  Processes: 343 Power: uptime: 1m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend,
    test_resume image: 2.97 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1131 libs: 343 tools: pamac,yay Compilers:
    clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash v: 5.2.26
    running-in: konsole inxi: 3.3.33

Let me know what can i do next!


So it seems to be using the correct kernel. However,

…the driver still isn’t being loaded, despite the website status it is. The linux hardware website also specifies that it’s not working on other distributions, either. So it seems there is some kind of problem with it.

Let’s see if the driver at least gets loaded:

Run the following:

lsmod | grep --ignore-case uvc

If nothing is returned, run the following to load the module:

modprobe uvc_driver

I think that’s it. I’ve never done this, so I’m not entirely sure about it.

Test it then, if it works we’ll make it persistent. If it doesn’t, there’s nothing I can do further and I doubt anyone else will be able to either.

Here is the output for

lsmod | grep --ignore-case uvc
uvcvideo              163840  0
videobuf2_vmalloc      20480  1 uvcvideo
videobuf2_v4l2         40960  1 uvcvideo
videobuf2_common       86016  4 videobuf2_vmalloc,videobuf2_v4l2,uvcvideo,videobuf2_memops
videodev              319488  5 v4l2_async,videobuf2_v4l2,ov13858,uvcvideo,videobuf2_common
mc                     77824  6 v4l2_async,videodev,videobuf2_v4l2,ov13858,uvcvideo,videobuf2_common

and second command is giving me

modprobe: FATAL: Module uvc_driver not found in directory /lib/modules/6.1.80-1-MANJARO

OK, so it’s not that the module isn’t being loaded, there’s just something else happening. Or not happening. So the second command would have had no effect, even if it was correct.

So, as I said earlier, I have no idea if it can be fixed, never mind even how.

So your best option is to wait fort someone who does.

Sorry I couldn’t be of more help!


Thanks buddy! I really appreciate you trying to help. That’s enough for me. I will wait for some advanced user to see this post and hopefully give me some solution.

1 Like

I can only point you to a solution - you have to do the work by yourself.

From here I got to here where you can download a different version of one file that is used to compile the kernel driver for this camera.

To build it yourself you’ll need the actual kernel source for the kernel you are using - and you need to recompile at least this one piece - probably the whole kernel.

You essentially replace the original file with this one.

DKMS is likely the best approach.

Or see the Arch Wiki here and/or here.

It’s going to be some work - not a real problem if you are familiar with AUR and kernel compiling, but a rather huge endeavour if you have no prior experience with that.

Thanks for suggesting but i have already tried with my previous kernel and also with current kernel but it didn’t work for me at all! If there is anything else I can try let me know.

I don’t know what you tried, what you did.

You replaced that file and compiled that module (or the whole kernel) successfully?
Then you booted that kernel?
And it still didn’t work?

Actually I followed the whole procedure that was given on the link that you mentioned and everything went smoothly without any errors. But still camera didn’t work.

Which procedure?

You could not have done it like this:

Arch build system - ArchWiki

because the devtools package is not available for Manjaro

So, the “traditional” way would be to fetch the kernel source, replace that file and compile it.
Then copy it to where the original module was.

The instructions here

Comment #19 : Bug #2000947 : Bugs : linux package : Ubuntu

can’t be used verbatum on Manjaro - that directory (build) does not exist - not to my knowledge

That command could not have been successful.

You would have needed to adapt it.

One more hint:

[HowTo] Manually build a Manjaro kernel module

If it still doesn’t work with the recompiled module … then it doesn’t work. :man_shrugging:

There is no easy solution. That camera isn’t supported in Linux yet and to get it working requires building a patched uvcvideo kernel module.

Doing that requires some technical knowledge. You will need to use the general instructions from [HowTo] Build a (patched) kernel module with the specific code changes from the “open uvc_driver.c file and scroll down…” step from Acer A515-57G Quanta Webcam 0x4033 Fix On Linux · GitHub .

This is too much of technical difficulty for me… Is it possible that kernel is updated with available patch by community anytime? I already had the problem in endeavour os with latest kernel version that my laptop suddenly used to freeze and continuous caps lock blinking. But it didn’t happen in manjaro but camera isn’t working now. I guess the hardware has too many incompatibility issues!

Eventually that will happen yes. Apparently a patch was accepted last week - Comment #132 : Bug #2000947 : Bugs : linux package : Ubuntu . I don’t know whether it will be backported to earlier kernels like 6.1 though.

Actually I was previously on kernel 6.6 but switched to 6.1 as suggested by @Mirdarthos … But since it is not working on this one as well then i guess i will switch back to 6.6. Is it available for 6.6? if not I hope it gets available soon. Thank you all for helping me out in any way possible. I will wait for kernel updates with this issue fixed.

It’s not available on any kernel, that post said a patch had been accepted but afaik it hasn’t even been applied to 6.9rc yet. That’s all I know I’m afraid.

EDIT Had a look at LKML and this seems to be the patch which should fix the problem with your camera and others. But since kernel 6.9 is now in the release candidate stage I guess it won’t be merged until 6.10. So it will be a while yet before it’s available.

Okay! Thanks for the help.