Can't connect to Huawei Mobile Broadband

hello everyone,
i am dual-booting windows and manjaro

for some reason my huawei modem doesn’t show in my networks tab even though it is connected to my pc and works on windows.

i ran LC_ALL=C lsusb | grep Huawei and it shows up:

Bus 003 Device 009: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard

i have tried to disable fast startup and hibernation in windows and bios but didn’t work :frowning:

i downloaded linux61-rt-r8168 but didn’t work.

i looked at other forums for solutions but nothing works

but nothing worked.
i am really confused and would appreciate any help.

Hi @InternetNotWorking, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Please also note and heed: Forum Rules - Manjaro

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

1 Like

Hello @InternetNotWorking :wink:

This stick must have 2 modes: storage and modem. The storage contains the windows driver, but that is not needed on linux. There is a terminal tool which is called usb_modeswitch. But I guess you switched already.

From what I see it is a dongle which connects to mobile internet (UMTS/3G/LTE etc.). No ethernet or wifi. It should have a SIM slot, or? Anyway… you need to configure a mobile connection with that dongle.

1 Like

please clarify.

yes it has a sim slot.

I don’t know exactly how to do this with your device, but here is a reference: Just search for your model name or device id or vendor id in that text file.

You will see a different chipID when you switch, but 12d1:1506 is a modem here, not a storage.

Then put in a sim card and configure a connection in your Network Manager. “Mobile Broadband” I guess?

it is has a sim card in it, and works on windows but not manjaro

Look, this stick is made with Windows in mind. No wonder it works there out of the box. On Linux you need to configure it manually.

oh ok how do i do that?
with usb_modeswitch?

Read again please:

it already has a sim card, also i can’t find any network managers for huawei.

Yeah. There is only one Network Manager. You don’t an extra one for huawei. KDE right? Guess you need nm-connection-editor, so that you can add it (install it). I don’t use KDE, so cannot help here. Probably open the “systemsettings” and look for “connections”. There you should be able to add a connection.

Or perhaps here, in System Settings:

please provide some system info (copy the textual output - paste it into the OT mark the text and press the </> icon in the post toolbar)

inxi -Fxc0

Install the packages

sudo pacman -Syu manjaro-modem modem-manager-gui

Restart your system


Then launch the Modem Manager GUI from your system launcher

Hello thank you so much for your help i have followed your steps and added the network but i can’t connect what should i do?

  Host: souimasta Kernel: 6.1.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 Desktop: KDE Plasma v: 5.27.7 Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 3020 v: 00
    serial: <superuser required>
  Mobo: Dell model: 040DDP v: A01 serial: <superuser required> UEFI: Dell
    v: A20 date: 05/27/2019
  Info: dual core model: Intel Core i3-4160 bits: 64 type: MT MCP
    arch: Haswell rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 925 high: 1300 min/max: 800/3600 cores: 1: 800 2: 1300
    3: 800 4: 800 bogomips: 28746
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics
    vendor: Dell driver: i915 v: kernel arch: Gen-7.5 bus-ID: 00:02.0
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0 driver: X:
    loaded: modesetting dri: i965 gpu: i915 resolution: 1368x768~60Hz
  API: OpenGL v: 4.5 Mesa 21.3.9 Amber renderer: Mesa DRI Intel HD Graphics
    4400 (HSW GT2) direct-render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 8
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  API: ALSA v: k6.1.49-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.78 status: off
  Server-3: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8168 v: 8.050.03-NAPI port: e000 bus-ID: 02:00.0
  IF: enp2s0 state: down mac: b0:83:fe:b6:fe:bf
  Local Storage: total: 465.76 GiB used: 13.16 GiB (2.8%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-75U6AA0
    size: 465.76 GiB
  ID-1: / size: 33.35 GiB used: 13.14 GiB (39.4%) fs: ext4 dev: /dev/sda5
  ID-2: /boot/efi size: 96 MiB used: 25.3 MiB (26.3%) fs: vfat
    dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 185 Uptime: 1h 58m Memory: total: 4 GiB available: 3.75 GiB
  used: 3.24 GiB (86.4%) Init: systemd Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: 1157 Shell: Zsh v: 5.9 inxi: 3.3.29

It is simple to setup using

→ System Settings
→ Network
→ Connections
→ Click +
→ Mobile Broadband
→ Any GSM device
→ Country
→ Provider name
→ Usually Default plan works
→ Finish

I have a T550 with a WWAN card - I just followed the recipe laid out in my previous comment.

Plasma will - if device is active as modem - ask for SIM PIN - provide the PIN and you are connected.


when i started the modem manager i pressed “Let’s Start” then it closes

Yes - just select the correct parameters - modem manager works in the background.

i did all of these steps but i can’t connect to it

Then I don’t know.

It seems the GUI is not functional on a plasma desktop

what is the output of