Autorandr not working

I have been using autorandr for some time now. Everything seemed to work fine until an update yesterday,.
When i try to check for my configuration using the command autorandr i get this response

Traceback (most recent call last):
  File "/home/wangui/.local/bin/autorandr", line 33, in <module>
    sys.exit(load_entry_point('autorandr==1.11.post1', 'console_scripts', 'autorandr')())
  File "/home/wangui/.local/bin/autorandr", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.10/importlib/metadata/", line 919, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.10/importlib/metadata/", line 518, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: No package metadata was found for autorandr

I have tried reinstalling autorandr but that doesn’t fix anything. Any help is appreciated. Thanks.

How to increase your chances of solving your issue:

Please provide Information:

You did read the Announcement post, right? :wink:

Hello there! Thank you for taking the time to respond to this. I’m pretty sure i missed the Announcement post, where do i find it?

I did try rebuilding the AUR packages but nothing worked. I am still having trouble with this.

Report the issue here then:

I removed all the old package of autorandr and rebuild again. I had to clear cache as well as all unused files. Rebooted and it worked. Rebuilding the package does work. Thank you for all your help. Much appreciated.