Bootloader error mess while doing a Manjaro i3 fresh install

Hello dear Manjaro peeps!

Short story, I have an old MacBook pro (2014) with Osx still installed and Manjaro XFCE running on another partition. XFCE started being just buggy so I decided to clean the Osx partition and do a totally fresh install with Manjaro i3 :slight_smile:

I chose to let the installer delete the old partitions and create a 8gb swap partition. I got wifi working earlier in the installer boot menu but not during the actual installer.

I got this message after the installation from the USB stick was almost finished:

" The bootloader could not be installed. The installation command

returned error code 1"

What to do?

Edit: bah I can’t even get the forum software to post my pasted info without effing it up >_< I’ll try posting an image:

You could try using ``` instead of images :wink:

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --verbosity=8 --filter --width 
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

Sorry for being such a newb :wink:

I’m posting this from my phone since I can’t get wifi to work on the MacBook.

I searched for this bootloader thingy grub thingy error but found stuff from older and other distributions.

I show a picture from the inxi =

In the effing annoying ■■■■■■ meantime I’ll be searching on my phone how I can get wifi to work on the Manjaro i3 USB stick installer

At least on macbooc Pro 9.2 there is a solution for wifi here

Maybe at least say what macbook is it exactly (inxi -zv8)
And i am pretty sure there is some special procedure for the bootloader EFI too…it is a Mac after all…

Thanks for helping :slight_smile:

inxi -zv8 gave a lot more info

It seems I have Broadcom BCM4360 802.11ac as wifi chip.

Maybe this picture gives more info on where I can begin?

Try to connect a phone with usb cable and see if you will get internet with tethering, it will make your life easier.,x#Wi-Fi
So now we know that you have to update to kernel 66 and then install linux66-broadcom-wl for the wifi to work. On the same page there is something about the bootloader too.

Ok thanks! I also found some threads about my specific wifi chip. I’ll check that later. Now I’m off to buy some food and beer!

I’ll check this thread later tonight

Thanks again

EDIT: it worked to let my phone tether share internet with the MacBook. Altho the browser in the installer, pale moon, isn’t good enough to let this forum sign me in so I still have to write everything on my phone. But atleast I can surf most pages and try to learn what to do and learn how I can make the Manjaro i3 USB installer work with the bootloader stuff.

I’m still no near finding out what to do but I gotta have a working laptop :slight_smile: Otherwise I’ll go to a friend tomorrow and make a Manjaro xfce usb stick again

EDIT2: I guess what I need to do is set some GRUB parameters in the boot menu before the actual installer loads?