Libreoffice slow/hangs and not saving files

My problem sounds similar to this one, Libreoffice Hangs When Saving - #11 by slumbergod, however I don’t understand the solution well enough to give it a try. Libreoffice, calc specifically, is not saving a spreadsheet that I use often. it also takes a really long time for Libreoffice to load when first opening and also hangs when you save and exit. This was not always the case on this computer so something has changed to impact it.

I thought onlyoffice was doing the same thing however I just reinstalled it and it seems to be fine and saving the same spreadsheet without issue. I tried changing my themes in XFCE by searching and pulling up the “Appearance” and “LightDM GTK+ Greeter” apps. I had them matching on theme previously. Right now using Adwaita. It doesn’t seem to make a difference. Like I mentioned, I’m not sure I fully understood that solution if that is even my same problem.

Correction regarding onlyoffice. It is still being buggy as well. It did save some changes I made the first time then I made some more changes and saved and noticed some of my changes from the first time were gone. It’s like both softwares are unpredictable if they will save or not. I have had Libreoffice save a test change sometimes but usually not.

Don’t know about saving, but about starting, if you are on xfce, remove


And install instead


The post is misleading anyways.
If you want to set vcl you only have to do it in one place.

You could set these as a global environment variable in /etc/environment or a few other places …
But lets use the example of the libreoffice start scripts (and I think you are using ‘fresh’)
You can use any of the following, included with some explanation:

#GTK3 support

#GTK4 support (under heavy development)

#KF5 support (based on qt5 VCL plugin mentioned below)

#GTK3 support with KDE5 file pickers (alternative to native kf5 one)

#Qt5 (under construction)

#raw X11 support

The file /etc/profile.d/ will have these already, you simply need to remove the comment (#) in front of the line you want to enable.

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gtk3_kde5
#export SAL_USE_VCLPLUGIN=gtk3
#export SAL_USE_VCLPLUGIN=gtk4

PS. If we dont assume vcl is the problem … then I might suggest a few other things, such as disabling java runtime - doing so is known to speed up libreoffice.
(you can find it in LO > Tools > Options > Advanced)

Only had time so far to try this post. Both were installed, removing portal-gnome fixed the slowness problem, libreoffice launches really fast now and doesn’t hang when saving, however, it is still not saving changes I make.

Examples of changes I’m making are formatting cells changing from numbers to currency or moving/dragging changing the width of columns. Will try other recommended steps soon.

This is what I have in that directory.

$ cd profile.d
$ ls
debuginfod.csh               perlbin.csh  vte.csh  gawk.csh

That doesnt show us the whole path:

ls /etc/profile.d

And also whats the LO?

pacman -Qs libreoffice
$ ls /etc/profile.d
debuginfod.csh               perlbin.csh  vte.csh  gawk.csh

The other command returns nothing. It’s installed right now using Flatpack through the add/remove programs. I can uninstall and reinstall using pacman. I had tried both to see if any difference. Flatpack version

Okay uninstalled, went back to official (extra) and still version.

$ pacman -Qs libreoffice
local/libcdr 0.1.7-6
CorelDraw file format importer library for LibreOffice
local/libreoffice-still 7.5.5-2
LibreOffice maintenance branch

I need to work on some documents today so I will see how this goes and report back.

Some write (word docs) have been saving good today. Spreadsheet is not saving. I added data to just two cells, clicked save, existed, re-opened and the data is not there.

I should also mention I installed OnlyOffice as well and its having same issues saving changes. Would seem to be an indication of problem bigger then LibreOffice.

What filesystem are you saving them to?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

1 Like


Yes, but I was unable to find my issue besides the one thread I mentioned (but didn’t understand).

  Kernel: 6.1.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=3a13bcab-9d90-4203-95b1-078f8c590d5c rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 4180J22 v: ThinkPad T420
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: LENOVO model: 4180J22 serial: <filter> UEFI-[Legacy]: LENOVO
    v: 83ET82WW (1.52 ) date: 06/04/2018
  ID-1: BAT0 charge: 71.2 Wh (99.9%) condition: 71.3/71.3 Wh (100.0%)
    volts: 12.5 min: 10.8 model: SANYO 42T4763 type: Li-ion serial: <filter>
    status: not charging
  Device-1: hidpp_battery_0 model: Logitech M350 Wireless Mouse
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  System RAM: total: 8 GiB available: 7.64 GiB used: 4.81 GiB (62.9%)
    igpu: 64 MiB
  Array-1: capacity: 16 GiB slots: 2 modules: 1 EC: None
    max-module-size: 8 GiB note: est.
  Device-1: ChannelA-DIMM0 type: DDR3 detail: synchronous size: 8 GiB
    speed: 1333 MT/s volts: N/A width (bits): data: 64 total: 64
    manufacturer: Kingston part-no: 99U5428-080.A00LF serial: <filter>
  Device-2: ChannelB-DIMM0 type: no module installed
  Info: model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 875 high: 1100 min/max: 800/3400 base/boost: 2700/2700
    scaling: driver: intel_cpufreq governor: schedutil volts: 1.2 V
    ext-clock: 100 MHz cores: 1: 800 2: 1100 3: 800 4: 800 bogomips: 21538
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb est flush_l1d
    fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce md_clear mmx monitor msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni
    popcnt pse pse36 pti pts rdtscp sep smx ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tsc tsc_deadline_timer vme x2apic xsave xsaveopt
    xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Lenovo ThinkPad T420 driver: i915 v: kernel arch: Gen-6
    code: Sandybridge process: Intel 32nm built: 2011 ports: active: LVDS-1
    empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0126 class-ID: 0300
  Device-2: Chicony integrated camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.6:5 chip-ID: 04f2:b221
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: LG Display 0x40a0 built: 2010 res: 1366x768 hz: 60
    dpi: 112 gamma: 1.2 size: 310x174mm (12.2x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Lenovo 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  API: ALSA v: k6.1.49-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.78 status: n/a (root, process) tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    with: pulseaudio-alsa type: plugin tools: pacat,pactl,pavucontrol
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
    driver: e1000e v: kernel port: 5080 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0085 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Broadcom BCM2045B (BDC-2.1) driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.4:4 chip-ID: 0a5c:217f
    class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 119.24 GiB used: 60.87 GiB (51.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7PA128HMCD-010L1
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 8L1Q scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GT50N rev: LT20
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 119.24 GiB size: 116.81 GiB (97.96%)
    used: 60.87 GiB (52.1%) fs: ext4 block-size: 4096 B dev: /dev/sda1
    maj-min: 8:1 label: N/A uuid: 3a13bcab-9d90-4203-95b1-078f8c590d5c
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 8087:0024
    class-ID: 0900
  Device-1: 1-1.3:3 info: Upek Biometric Touchchip/Touchstrip Fingerprint
    Sensor type: <vendor specific> driver: N/A interfaces: 1 rev: 1.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 147e:2016 class-ID: 0000
  Device-2: 1-1.4:4 info: Broadcom BCM2045B (BDC-2.1) type: bluetooth
    driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 chip-ID: 0a5c:217f class-ID: fe01 serial: <filter>
  Device-3: 1-1.6:5 info: Chicony integrated camera type: video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 200mA chip-ID: 04f2:b221 class-ID: 0e02
  Hub-3: 2-0:1 info: full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 8087:0024
    class-ID: 0900
  Device-1: 2-1.2:3 info: Logitech Unifying Receiver type: mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c52f class-ID: 0300
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 1972
  Processes: 236 Uptime: 12m wakeups: 3 Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7 Packages: 1231
  pm: pacman pkgs: 1211 libs: 376 tools: pamac pm: flatpak pkgs: 15 pm: snap
  pkgs: 5 Shell: Sudo (sudo) v: 1.9.14p3 default: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.29

After reinstall using Official (extra) I see libeoffice sh file. I unmarked

#export SAL_USE_VCLPLUGIN=gtk3

Rebooted and tried again.

Here is my fix for mine I think though. This popup kept coming up each time on my spreadsheet and when I finally read it it says certain changes won’t be saved. I don’t know how my document got into shared mode (I have no need to share it). After figuring out how to disable it (Tools > Shared Speadsheet) those changes that wouldn’t saved are saving so far. I think that’s it. I’m going to leave this post open bit more to test and make sure.


Thank you everyone for your help and patience with me.

That shared setting seem to resolve it. Thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.