[HowTo] post screenshots and links

Difficulty: ★☆☆☆☆

You’ve probably been sent here by a more experienced user because you cannot post links nor screenshots :sob: so please follow the simple instructions of this tutorial below to allow you to post both screenshots and links in any post and have a short explanation of why you can’t do this easily… :+1: :innocent:

If you’re reading this in response to a question, please click the green link above this text to bring you to the full unabridged text of the tutorial itself.

If you can read this line, you’re already where you’re supposed to be! :+1:

(Please click the ► to expand any of the below sections:)

On this forum here you need to have Trust Level 1 (=TL1) to be able to post screenshots and links in-line.

That's dumb! Why is that?

Well, that’s because on our old forum we got tons of screenshots of text, links to SPAM, PR0N and other things you don’t want on a forum, so all the new users are prohibited from posting links and pics because of a few bad actors. :sob:

How to post links:

  • Precede the link with a back tick ` and end it with another back tick like this:

    https://forum.manjaro.org

  • That’s it! You now have a (non-clickable) link that the experts here can right-click on and open in a new tab.

How to post screenshots:

Please adhere to the following rules when posting a screenshot:

  1. Please, don’t post screenshots of text!
    1.1. Definitely don’t post screenshots of text!
    1.2. Even when posting screenshots of text is easier than posting text, only Rule 1. :arrow_up: applies! :innocent: :wink:
    1.3. Shooting a photo from your screen with your phone/digital camera is by definition a screenshot so Rule 1. :arrow_up: applies here as well! :stuck_out_tongue_winking_eye:

    Why the @#%* can't I post screenshots of text?

    It’s easy:

    • you post a screenshot once, but it gets read many times
    • text makes it easier for all the people that are trying to help you to use some google-foo to help you without having to type the text that you did not type just once.
      So the really busy, really knowledgeable people see a screenshot of text and move onto the next question instead of helping you. :sob:
    • It costs the Manjaro Team a fraction of the $$$ to store text whereas full-size screenshots take up much more space (and thus $$$) :money_with_wings:
    • How to post text (I.E. from a terminal):
      • Edit your post
      • Type 3 backticks ```
      • Copy the text from the terminal
      • Paste it in your post below the 3 backticks
      • Type yet again 3 backticks
      • Continue typing normally if you need to type more text, so your post looks like this:
        My flux capacitor is discharging at an alarming rate!
        sudo flux-info
        --- FLUX 1.3.1 --------------------------------------------
        fluxacpi    = inactive 
        +++ Flux Capacitor Status: FLUX0
        /sys/class/power_supply/FLUX0/manufacturer                   = OEM
        /sys/class/power_supply/FLUX0/model_name                     = BTTF2
        /sys/class/power_supply/FLUX0/energy_full_design             =  10 [MegaCochranes]
        /sys/class/power_supply/FLUX0/energy_full                    =   9 [MegaCochranes]
        /sys/class/power_supply/FLUX0/energy_discharche              = 385 [KiloCochranes]
        
        +++ Flux Capacitor Features: Charge Thresholds and Recalibrate
        
        What should I do now?
  2. Only post screenshots when someone is asking you to post a screenshot!

    Why?

    This one is easy: it’s much more efficient to be reading:
    When I’m going to System Settings Fonts Font Management, the fonts don’t render in the preview window.
    than to look at three huge screenshots! (Again: Please help us help you!) :+1:

    Exceptions: When does it make sense?
    • When you want to show a graphical error, describe it with text, thus making it searchable and then post a screenshot.
    • If a GUI element doesn’t have a text name or label.
  3. Please make a screenshot of the relevant portion of the screen only!
    (I.E.: don’t post a screenshot of the entire desktop to say that you have a minuscule button in the lower right edge of the screen that is turning red: take a screenshot of the relevant part only!) :innocent:

  4. Make your screen shot and save it locally

    How do I do that?

    That depends on your Desktop Environment: :stuck_out_tongue_winking_eye:

  5. Go to https://paste.pics/

  6. Click the Browse button

  7. Browse to your screenshot and click on it

  8. Press the Open button

  9. Copy the URL!
    (It’ll look like this: https://paste.pics/b03cd32463532de2ddfe4a1d82adc218)

  10. Paste this URL into your question / response using the methodology for posting links described above:

    https://paste.pics/b03cd32463532de2ddfe4a1d82adc218

    (So please don’t forget to precede and end this URL with a ` )


That’s it! Thank you for your cooperation and understanding!

:+1:

26 Likes
"Sorry, you can't include links in your posts."
Cannot use link in my posts anymore : bug!
Please provide command to include custom EDID binary in init with mkinitcpio
Keyboard shortcuts / hotkeys for brightness and volume stopped working, also cannot install anything from pamac
Can't see and can't add notification area plug-in
App can be launched via terminal but isn't listed with other applications
Wifi won't work
Weird line above window showing desktop behind
Can't connect wifi
Memory leak with KDE & Kdenlive
High disk I/O in kworker
After re installing and updating my manjaro, I am not able to configure my HP Officejet 4630 printer
Installer Bug in Manjaro KDE-dev-20.2.1-unstable-210215-linux59
Why do I can not upload images here?
Kwalletmanager, do i need it?
Sorry, you can't embed media items in a post
ERROR: Unable to load the 'nvidia-drm' kernel module - installing Nvidia drivers help
Not able to move files on network share
What are the most common questions (FAQ) in forum
Limited replies for new user
[Stable Update] 2020-08-28 - Kernels, Systemd, PAM, PAMBASE, KDE-git, Deepin, Pamac, Nvidia 450.66, LibreOffice 7.0
Some application buttons do not work
Welcome and introduce yourself - 2020
"Sorry, you can't include links in your posts."
NetworkManager not working after Windows Update
Snap's interfaces configuration
MuseScore3 -- Can't click 'OK' in Preferences
Nicotine+ not opening since last general update
Dual DP LG ultrafine 5k display sync issues
Boot stuck after update
[Stable Update] 2020-09-08 - Kernels, Mesa, Browsers, KDE Apps 20.08.1, Systemd, LibreOffice 7.0.1, Deepin
What are the requisites to TL2?
How to use color emojis? Or, how to set an order of preference for color emojis?
[Stable Update] 2020-09-11 - Kernels, Gnome 3.36.6, MHWD, Pamac, VirtualBox
Manjaro 20.08 latest update breaks wifi in Pinebook OG
[SOLVED] Display Manager stopped working after package update
Manjaro 20.1 64-bit "Mikah" and Perfect-Privacy VPN
Ugly Notifications after update
Dual boot doesnt work
Remove username and settings icon from the top of the menu
No sound over hdmi after last update
Problema con bootloader
No sound over hdmi after last update
Crashing Randomly During Idle After Last Update?
Youtube fullscreen problem on Firefox 80.0.1
Drivers of my Wi-Fi not added to manjaro dde
Thunderbird window size issue
Timed out waiting for device disk, dependency failed, and emergency mode
Window Decorations drawing a thin border when no border selected
Black SOD off Live USB
My system freeze since last update
Sorry, you can’t embed media items in a post
Sorry, you can’t embed media items in a post
Installation does not start
External and Bluetooth microphone not detected
Prevent taskbar from flashing and popping up when application launches new window
Very Interesting Problem with Manjaro 20.1
HP Envy x360 13-ar0022nn AMD Ryzen 5 3500U sound problem
SDL not rendering window
KDE Manjaro zoomed in, unusable
I have samba failure message but it does work (ish)
How to Install VPN Secure Me on Manjaro KDE
Intermittent sound
"Failed to add printer" promt on one pc, but can add network printer on other pc
Manjaro Neon Red Dragons Wallpaper?
Battery icon is constantly in charging mode
Missing navigation icons on some apps
Sleep and hibernate not working in HP pavilion dv6
How to provide good information
No images and links? What gives?
Installing nvidia drivers on manjaro gnome
Horizontal Flickering Which worsens under certain conditions
Major screen corruption/sync issues with non-free NVIDIA driver
Cannot add pictures in forum post
Partition tables changed by Windows (LUKS)
Manjaro Neon Red Dragons Wallpaper?
System keeps freezing
Shutdown Laptop after failed login attempts (and fall back to LUKS)
Graphical issues on pure Qt applications when setting global scale above 100%
Steam font too small
No option to blank screen when lid is closed in gnome
Realtek TP link wn-722n
Changing volume too fast causes system restart
Apps using both alsa and pulseaudio, headless and multi-user desktop
[PinePhone] Community Edition with Manjaro Phosh
Calendar events in gnome shell overlap with world time
Problem with the mouse cursor
Screen tearing in Firefox fullscreen Youtube videos
Audio output from headphone but not speaker
Installing nvidia drivers on manjaro gnome
Manjaro installation on an existing encrypted partition
Microphone available but no sound detected
Change Alt+Tab behavior from switching windows to switching applications
Bluetooth Headset profile switches from "HSP/HFP" to "off" after ending a call
Weird Screen After Waking up from sleep mode
Xfce not storing settings after reboot? (keyboard layout, keyboard shortcuts, panel plugins, panel sub-settings, etc)
Intermittent green hue
How to make youtube faster
Ads pop-up appears when starting Manjaro
Yakuake display problem - changes size every now and then, sometimes cut off
Wallpapers by Lunix
Manjaro not recognising/unable to partition M.2 ssd (trying to dual boot with windows)
Why I cannot post links?
Weird boot screen after last update
Can't find option to activate AUR packages anymore
No GUI or desktop display on boot after uninstalling lightdm
Firefox appearance and VLC not playing
Help with the Archwiki process for 15are05 Elantech touchpad fix
Standard program assignment issue
Fresh install with local build of ungoogled-chromium
Jumpy mouse scroll in XFCE
System fonts unreadable ( pamac) and browsers
[Continuation] from how to install huion driver
Update manjaro failed
Manjaro black screen after log in on KDE
Can't post links or inxi output
Errors when I update
[HowTo] bulletproof your personal effects (save your stuff!)
Taskbar chrome shortcut (apps) icons change back to google-chrome's on loading
Linux - Thunar folder icon
Manjaro on Pine64+ mini board same as pine64 LTS
Screen bugging when waking up from sleep mode on iMac
Screen going crazy - (hue and saturation?) post installation
[2021-02-09 update] Black screen after login
Night light not working since last update - Manjaro GNOME - Testing Branch
Raze crashes on manjaro
New laptop, fresh Manjaro install, no sound
How to build nvidia-340xx with linux511?
XFCE Panel Status Tray Menu Location
Searching about a way to translate KDE breath2 theme
I lost the original menu of manjaro (xfce)
Hardware error on boot using new hardware
Beginner question: Ext4 Partition is readonly

I hate. how morons setup a bot to spam the crap out of a forum.

But Haven’t seen the last one yet!

1 Like

I just tried to follow above advice of parsimony and wanted to post only this Link
https://docs.xfce.org/_media/xfce/xfce4-session/logout2.png’.
Sadly I forgot to envelope with ‘’ so the png seem to have been inserted as a whole - quite the contrary to my good intentions :frowning_face:
Is this the intended behaviour of the editor?

TL1s (which you are) can now use the envelope. TL0s still can’t so leaving this up in case any ever needs to post a screenshot (when asked)

:innocent:

A Salomonic solution.
Thanks for sorting this out.

1 Like

Please delete that. I hate these links so much :sob:

Just use the back ticks with ` … that would be helpful :pray:

removed…

It’s better than an imgur link!: they don’t work without scripts and cookies enabled on your system! (and I have enabled neither…)

Thoughts?

:scream:

:pray: :bowing_man: :raised_hands:

I have no problem with https://paste.pics/, but just say that they should post only the weird number would make me crazy.

TL0 should just, if not avoidable, paste the links with back ticks `. Thats all.

Think of doing that several times… Myself i will stop viewing links at all here by this behavior. Should someone else have a look there. :wink:

2 Likes

Revamped it completely:

  1. Explain why
  2. Explain how to post a link
  3. explain how to post a screenshot by using the expertise they just gained in posting a link.

Gut genug???

:innocent:

P.S. We can then select the text link, right-click and ask Firefox to Open Link in New Tab

1 Like

What is even easier (and what I see people do even more), is make a photo of your screen, instead of a screenshot… :wink:

( although I guess you could say a photo of a screen can be considered a screen-shot )

True. I’ll add that in now…

:innocent:

1 Like

Acknowledged. Noted all the points and the reasoning behind :wink:

While in my eyes: “A picture is worth a thousand words” :wink:

Despite the fact that I am a visual type and I find dry text too dry and boring, also I think screenshots of actual panels, GUI elements, desktop etc are way more newbie and Win user friendly in general and most people likes visual things to interpret. Same as the GUI on PCs vs terminal commands in the eyes of Win users :wink: But I understood all the points too above in the rules, pics eats up storage space and cash too.

I will need to learn those other semi graphical tools that you guys are using here, thext boxes, scrolling boxes and that black text field etc.

1 Like
  • Start here.
  • Continue there for the advanced stuff.

:stuck_out_tongue_winking_eye:

1 Like

A post was split to a new topic: How do I write in these button-like boxes?

yes understandable, some ppl are not ethical and considerate enough to think before posting and post in a scrambles emotional state of mind frantic and nutty lol