Mac Wi-fi issue

Hello everyone!

Very new to Linux here, please excuse lamer’s questions. Had installed Ubuntu earlier to Mac 8,1 it worked okay for some time. Began to ask for updates and terribly lag. So searched for “best Linux for older computer”. Someone somewhere have pointed at Manjaro. Well, Arch first. I wish I had more time to play with it and win the terminal installation. Sincerely, didn’t want to give up, just ain’t got too much time to win that terminal installation; when retired, will get to it :slight_smile:

Anyways, have installed Plasma. Now can’t get it connected to wi-fi. The wireless adapter has actually worked during UEFI usb installation. Now, when installed to internal drive there’s just ethernet connection window crossed. In settings it shows wireless option that ‘has never been used’.

Can someone please steer me at the right direction?



I hate to be the bearer of bad news, but if you have one of the macs that has no hard-wired ethernet connection it is difficult to install the driver (likely the broadcom wl) that you need. Manjaro (and arch) are distros that do not install proprietary drivers by default, and broadcom is proprietary. Manjaro requires that the user intervene and choose to install it (the drivers are in the AUR repository). Without a hard-wired connection you will need to tether via an android phone in order to get connectivity, and then yay broadcom wl
First you should run, in a terminal inxi -Fxxzr which should show which broadcom chip you have (the driver will probably be listed as ‘NA’, but could be listed as a pcie driver (the latter is doubtful). Anyway, I’ve installed various distributions on several different Apples, and every one with the broadcom chip used the ‘wl’ wifi driver.

Installing off-line is possible, but there are requirements. From the archlinux wiki website:

An Internet connection is the ideal way to install the broadcom-wl driver; many newer laptops with Broadcom cards forgo Ethernet ports, so a USB Ethernet adapter or Android tethering may be helpful. If you have neither, you will need to first install the base-devel group during installation. Then, use another Internet-connected computer to download linux-headers and the driver tarball from the AUR, and install them in that order.

All that said, I recently installed MX Linux on a macbook pro retina that had no hard-wired ethernet, and MX installed the Broadcom wl driver out of the box.

1 Like

Thanks for the response, very informative! Though I may have a slightly easier situation here. This Mac has regular Ethernet connection and we were able to get it work via regular cable.

As a side note, it’s somewhat weird to me that when system had loaded from usb, it was able to get WiFi going and connecting, but when installed it wasn’t?

Anyways, you mind me asking what the next step would be to download the proprietary driver if we do have it connected via Ethernet cable?



Hi @MMK, and welcome!

Macs are notoriously difficult, because everything is proprietary, IIRC. Thus, I’ll point you here:

However, I can also give you the whole welcome speech and advise you to provide the necessary information so that perhaps someone who knows about Macs will be able to assist. So, without further ado:

Frankly, to be able to provide better assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:


pasted text


This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang: Also, if your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

Actually just removed broadcom-wl-dkms from my mbp 5,4 with Broadcom BCM4322 this morning. Had been working fine but recently started acting up.
Reverted back to b43 by removing the broadcom-wl-dkms package and then following dedoimedo’s instructions here How to enable Broadcom Wireless on Manjaro . Works fine again.

Thank you all for replies, will keep trying to get it to work.