Black Kde Screen

Hi I just made some updates and after the reboot i found this black screen.
I can use Manjaro but I can’t interact with the desktop (no right click).
It’s not the first time I have this problem.

PS. How can I upload the screenshot?

1 Like

Try this, see if it resolves it:

  1. Log out of KDE

  2. Switch to TTY2 with CTRL + ALT + F2

  3. Login with your username/password to this terminal

  4. Stop the SDDM service

sudo systemctl stop sddm
  1. Rebuild KDE cache
kbuildsycoca5 --noincremental
  1. Wait about ten seconds

  2. Restart the SDDM service

sudo systemctl restart sddm && exit
  1. Switch back to TTY1 with CTRL + ALT + F1 and login to your KDE session

If this still doesn’t resolve it, there’s one extra thing you can try, but it will mean you need to redo your display config.

Hi @Jose96, and welcome!

It didn’t work.
I don’t care if I have to redo my display configuration.

it seems that if I modify my display config (I’m using an hdmi monitor) this problem disappear but I don’t know why.
Maybe it’s related to the fact that I’m using an external monitor.

Thank you.

Repeat the above steps, but before Step #7 do this:

rm -rfv ~/.local/share/kscreen

Then continue with Step #7 and #8.

Please be careful with the rm command. It will not prompt you for a confirmation, so make sure you don’t accidentally type in something else or use auto-complete for the wrong target.

Removing the directory ~/.local/share/kscreen will reset your Display / external monitor settings. By modifying the settings, you might have forced KDE to refresh the config files.

It’s possible that with updates to KDE, there is a mis-match of older settings (maybe a different format?) and the latest KDE/Plasma version.

1 Like

Thank you, this worked !!!

1 Like

I must be in a stupor. Are my eyes or mind playing tricks on me, or did you just change your avatar profile image? :face_with_spiral_eyes:

just changed.
I logged out after installing matlab and now i have the same problem…

Even after repeating the above (all of them) steps?

No i think I have just to change my monitor config, it’s faster.
But I’d like to understand why this problem comes out