Conflict while installing emacs


I had the 29 version of emacs installed, I removed it and want to install version 28, however I get the below conflict when trying to install -

$ sudo pacman -S emacs
[sudo] password for murtaza:
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libtiff (4.5.0-3) breaks dependency ‘’ required by sane

Considering I just installed it with no problems:

$ pamac install emacs                                                                                                                                                                                                                                         Preparing...
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: Mirdarthos (mirdarthos)
Synchronizing package databases...
Resolving dependencies...
Checking inter-conflicts...

To install (4):
libotf    0.9.16-4  (Required By: emacs)  extra  85.9 kB
m17n-db   1.8.0-4   (Required By: emacs)  extra  1.5 MB
m17n-lib  1.8.0-13  (Required By: emacs)  extra  327.2 kB
emacs     28.2-2                          extra  42.6 MB

Total download size: 44.5 MB
Total installed size: 124.5 MB

Apply transaction ? [y/N] y
Download of m17n-db (1.8.0-4) started
Download of m17n-lib (1.8.0-13) started
Download of m17n-lib (1.8.0-13) finished
Download of emacs (28.2-2) started
Download of m17n-db (1.8.0-4) finished
Download of libotf (0.9.16-4) started
Download of libotf (0.9.16-4) finished
Download of emacs (28.2-2) finished
Checking keyring...                                                                                                                                                                                                                                    [4/4]
Checking integrity...                                                                                                                                                                                                                                  [4/4]
Loading packages files...                                                                                                                                                                                                                              [4/4]
Checking file conflicts...                                                                                                                                                                                                                             [4/4]
Checking available disk space...                                                                                                                                                                                                                       [4/4]
Installing libotf (0.9.16-4)...                                                                                                                                                                                                                        [1/4]
Installing m17n-db (1.8.0-4)...                                                                                                                                                                                                                        [2/4]
Installing m17n-lib (1.8.0-13)...                                                                                                                                                                                                                      [3/4]
Installing emacs (28.2-2)...                                                                                                                                                                                                                           [4/4]
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                                                                                                                                                                                                         [1/7]
Refreshing PackageKit...                                                                                                                                                                                                                               [2/7]
Updating icon theme caches...                                                                                                                                                                                                                          [3/7]
pacman-backup.hook                                                                                                                                                                                                                                     [4/7]
Checking for .pacnew and .pacsave files...                                                                                                                                                                                                             [5/7]
Updating the info directory file...                                                                                                                                                                                                                    [6/7]
Updating the desktop file MIME type cache...                                                                                                                                                                                                           [7/7]
Transaction successfully finished.

I think your system and/or mirrors are of sync and not updated. So resync you mirrors:

sudo pacman-mirrors -f 5

And update your system:

pamac upgrade && pamac upgrade --aur --devel || echo -e '\033[0;91mThere was an error upgrading the system. AUR packages not upgraded.\e[0m'

Reboot, and try to install emacs again:

pamac install emacs

Hope this helps!

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like

The correct command would be pamac install emacs

(or sudo pacman -Syu emacs)

Otherwise, you’ll end up in a Partial Upgrade state.

1 Like

I get the below error while installing emacs -

$ pamac -S emacs
pamac: error while loading shared libraries: cannot open shared object file: No such file or directory

Have you done the update that I mentioned? And @mithrial and me gave you more correct commands to install stuff.

And besides, you’re not very clear on what happens and how you’re going about things. Please see:

1 Like

Okay, so if you duplicate your question, I’ll duplicate my answer:

1 Like

I tried the below command and I get the same error as above.

pamac install emacs

I am now doing sudo pacman -Syu emacs, its not complete yet.

Well then, wait for it to complete.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.