Errors when I update

hello, i get these errors when I updated now. The kernel 5.8 boots but the screen is dark,
pic1: “htttttps://”

Pic2: “-----htttttps://”

Pic3: “htttttps://”

Do i wait for a patch on linux 5.8 maybe?

Hey @balo could you please fix your URLs? Thanks :pray:

1 Like

links not allowed for me yet, you can edit those to https and remove those symbols

Have fixed it for you :wink:


yeah thanks

@balo Which graphic card do you use?
Otherwise stay on 5.7 until 5.8 gets some more patches

Do you have any logs?
How to provide good information

1 Like



  Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=7e99febc-c7a0-461e-a05e-9c1d0f821107 rw pci=nomsi,noaer 
  resume=UUID=6bc41930-4ab3-4912-8840-fe2e6dc11375 radeon.si_support=0 
  Desktop: GNOME 3.36.5 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 80M8 v: Lenovo G51-35 serial: <filter> 
  Chassis: type: 10 v: Lenovo G51-35 serial: <filter> 
  Mobo: LENOVO model: Lenovo G51-35 v: SDK0J40700WIN serial: <filter> 
  UEFI: Lenovo v: C3CN67WW date: 08/10/2016 
  ID-1: BATT charge: 20.5 Wh condition: 21.0/28.5 Wh (74%) volts: 16.0/14.4 
  model: LENOVO LCFC type: Unknown serial: <filter> status: Unknown 
  Topology: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics 
  bits: 64 type: MCP arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 
  microcode: 7030105 L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 17573 
  Speed: 1587 MHz min/max: 1000/2200 MHz boost: enabled Core speeds (MHz): 
  1: 1847 2: 1660 3: 1953 4: 2164 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo driver: amdgpu 
  v: kernel alternate: radeon bus ID: 00:01.0 chip ID: 1002:9851 
  Device-2: Syntek type: USB driver: uvcvideo bus ID: 3-1.2:4 
  chip ID: 174f:14e9 serial: <filter> 
  Display: wayland server: 1.20.8 compositor: gnome-shell driver: ati 
  unloaded: modesetting,radeon alternate: fbdev,vesa display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD KABINI (DRM 3.37.0 5.7.17-2-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.6 direct render: Yes 
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 chip ID: 1002:9840 
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k5.7.17-2-MANJARO 
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Lenovo Z50-75 driver: rtl8723be v: kernel port: 2000 bus ID: 01:00.0 
  chip ID: 10ec:b723 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 1000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Local Storage: total: 465.76 GiB used: 54.56 GiB (11.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: LVM1 scheme: GPT 
  ID-1: / raw size: 263.04 GiB size: 257.91 GiB (98.05%) 
  used: 54.43 GiB (21.1%) fs: ext4 dev: /dev/sda2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 
  System Temperatures: cpu: 38.5 C mobo: N/A gpu: amdgpu temp: 41 C 
  Fan Speeds (RPM): N/A 
  Processes: 209 Uptime: 2h 20m Memory: 6.70 GiB used: 3.04 GiB (45.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1474 lib: 437 flatpak: 0 Shell: Bash v: 5.0.18 
  running in: gnome-terminal inxi: 3.1.05

What does mhwd -li say?

[raihan@raihan-pc ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
         network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!
[raihan@raihan-pc ~]$

Seems to be ok, have no more idea, better create a Thread with this topic

its only the 5.8, 5.7 is running good

I have tested 5.8 in a early state and it’s run ok and I am using a very old GPU :joy:

1 Like

i think its my display, the new kernel seems to missing the firmware for my display but for some reason it exists in 5.7 strange :thinking:

You can also switch to testing branch but be careful and try 5.8.5

Oh I see there is also 5.8.3 so unstable is the one that includes 5.8.5

I recommend not trying unstable if you don’t know what you do.

1 Like

hmm installed 5.9 rc it gives the same error
WARNING: Possibly missing firmware for module: xhci_pci
5.9 kernel will boot dark too. I am starting to wondering if I broke something…

==> Building image from preset: /etc/mkinitcpio.d/linux59.preset: 'default'

-> -k /boot/vmlinuz-5.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.9-x86_64.img

==> Starting build: 5.9.0-1-MANJARO

-> Running build hook: [base]

-> Running build hook: [udev]

-> Running build hook: [autodetect]

-> Running build hook: [modconf]

-> Running build hook: [block]

==> WARNING: Possibly missing firmware for module: xhci_pci

-> Running build hook: [filesystems]

-> Running build hook: [keyboard]

-> Running build hook: [fsck]

==> Generating module dependencies

==> Creating gzip-compressed initcpio image: /boot/initramfs-5.9-x86_64.img

==> Image generation successful

==> Building image from preset: /etc/mkinitcpio.d/linux59.preset: 'fallback'

The warning has been known for a long time
v5.9-rc3 v5.9-rc2 v5.9-rc1 v5.8 v5.8-rc7 v5.8-rc6 v5.8-rc5 v5.8-rc4 v5.8-rc3 v5.8-rc2 v5.8-rc1
and it looks like we’re waiting a little longer



ah thank you very much for the clarification, I have not been keepin up with these stuff since 2019 so I was kinda lost :slightly_smiling_face:

1 Like

AMD depreciated support for some older GPUs in 5.8. Check the release notes.

1 Like

cc @balo

Let me point you onto the most important part of the [HowTo] post screenshots tutorial:

Please, don’t post screenshots of text!
1.1. Definitely don’t post screenshots of text!
1.2. Even when posting screenshots of text is easier than posting text, only Rule 1. :arrow_up: applies! :innocent:


1 Like