WiFi cannot be enabled after upgrading BIOS

I am using Manjaro 5.15.94-1 in an HP desktop. Yesterday, I tried to update the BIOS, and I succeeded by doing it in WinPE. Unfortunately, after rebooting I found that I cannot enable the Wi-Fi card.

ip link show wlo1

3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether d2:7b:72:1c:8f:d8 brd ff:ff:ff:ff:ff:ff permaddr 7c:70:db:0f:8a:61
altname wlp0s20f3

I tried to enable it by ip link set wlo1 up, but it raise an error “RTNETLINK answers: Input/output error”. And there is no helpful message in dmesg | grep firmware or dmesg | grep iwlfifi. Any idea how to solve it?

BTW, I am using Network Manager. Despite the Wifi is inactive, the wired connection is okay.

Hi @gigi314,

I just tested this :point_down:

And the command should actually be:

sudo ip link set wlo1 up

If that still doesn’t work, please provide the output for:

ip link


inxi --admin --verbosity=7 --filter --no-host --width

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Thanks. In fact what I executed is exactly sudo ip link set wlo1 up, and it doesn’t work.

The following is the output of inxi command:

  Kernel: 5.15.94-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7e1e44a4-c988-47e8-a008-82027be86cf7 rw quiet
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: HP product: OMEN by HP 45L Gaming Desktop GT22-0xxx
    v: N/A serial: <superuser required> Chassis: type: 3
    serial: <superuser required>
  Mobo: HP model: 8917 v: 00 serial: <superuser required> UEFI: AMI v: F.31
    date: 10/19/2022
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 62.56 GiB used: 4.38 GiB (7.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i9-12900K bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 2
    microcode: 0x26
  Topology: cpus: 1x cores: 16 mt: 8 tpc: 2 st: 8 threads: 24 smt: enabled
    cache: L1: 1.4 MiB desc: d-8x32 KiB, 8x48 KiB; i-8x32 KiB, 8x64 KiB
    L2: 14 MiB desc: 8x1.2 MiB, 2x2 MiB L3: 30 MiB desc: 1x30 MiB
  Speed (MHz): avg: 810 high: 876 min/max: 800/5200:3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 825 2: 843 3: 800 4: 835
    5: 876 6: 801 7: 800 8: 801 9: 799 10: 801 11: 799 12: 800 13: 801 14: 801
    15: 800 16: 800 17: 800 18: 800 19: 800 20: 800 21: 801 22: 827 23: 812
    24: 828 bogomips: 153024
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pconfig pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid
    rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep smx
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tme tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip
    vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: Hewlett-Packard
    driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
    chip-ID: 10de:2204 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.70x13.43")
    s-diag: 692mm (27.24")
  Monitor-1: DP-0 res: 3840x2160 hz: 60 dpi: 163
    size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce RTX
    3090/PCIe/SSE2 direct-render: Yes
  Device-1: Intel Alder Lake-S HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 0000:00:1f.3 chip-ID: 8086:7ad0 class-ID: 0401
  Device-2: NVIDIA GA102 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:1aef
    class-ID: 0403
  Sound API: ALSA v: k5.15.94-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000
    bus-ID: 0000:02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:6
    chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 2.75 TiB used: 126.49 GiB (4.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD WD
    BLACK Gen4 SDCPNRY-1T00-1106 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS2 temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: VP02 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
    used: 126.46 GiB (13.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 7e1e44a4-c988-47e8-a008-82027be86cf7
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 31.4 MiB (10.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: 57FF-3D2B
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ntfs label: DATA
    uuid: B66084186083DD8D
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: HP TracerLED type: HID driver: hid-generic,usbhid
    interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 103c:84fd
    class-ID: 0300 serial: <filter>
  Device-2: 1-7:3 info: Cherry GmbH G83 (RS 6000) Keyboard type: Keyboard
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 046a:0011 class-ID: 0301
  Device-3: 1-8:4 info: Seiko Epson L4160 Series type: Printer,Mass Storage
    driver: usbfs interfaces: 7 rev: 2.0 speed: 480 Mb/s power: 2mA
    chip-ID: 04b8:112a class-ID: 0701 serial: <filter>
  Device-4: 1-12:5 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-5: 1-14:6 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 28.0 C mobo: N/A gpu: nvidia temp: 32 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 437 Uptime: 22m wakeups: 2 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1549 libs: 351 tools: pamac,yay pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.25

Looks good, according to what I can see. Please provide the output of:

ip link show

Here is the output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 6c:02:e0:44:0f:a4 brd ff:ff:ff:ff:ff:ff
3: wlo1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether aa:dd:6a:0c:39:ed brd ff:ff:ff:ff:ff:ff permaddr 7c:70:db:0f:8a:61
    altname wlp0s20f3

Welp, I found this, which states:

I found this series of bug reports related to the same kind of problem: bug.launchpad, bugzilla.kernel.org 1, bugzilla.kernel.org 2, bugzilla.kernel.org 3.

Quoting Emmanuel Grumbach (egrumbach) in the first link above:

This is an electrical problem. I can’t do anything about it

so it seems to be a problem arising from bugs/faults in the physical card.

So I don’t think we can do much about it. Or at least, I can’t.


Thanks anyway. It is quite weird, because everything goes file before I updated the BIOS. I think it might have something to do with the firmware.

I think so too. Have a look here:


So try Kernel 6.1 then.

1 Like

Wifi card seems not to be initialized by the UEFI and therefore Linux has no access. Probably fastboot is enabled which skips some devices to speed up?

Some options to consider …

  • Does the BIOS have a utility to test hardware?

  • Reverting BIOS to previous version

  • Temporarily install windows 10 or 11, to rule out hardware failure (and may do the init on the card). I’d do it on a removable HDD or SSD and be prepared to have to rewrite the linux EFI record afterwards.

Thanks for the hint. It turns out that Wi-Fi works under kernel 6.1.

But I encounter another important issue while using linux61 kernel: NVIDIA driver cannot be detected, so only shell is launched without the desktop.

yay -Qs linux61-nvidia shows:

local/linux61-nvidia 525.89.02-3 (linux61-extramodules)
    NVIDIA drivers for linux

The inxi -G command shows driver: N/A. And mhwd -li reports:

video-nvidia            2021.11.04               false            PCI

NVIDIA driver works well if I switch back to kernel 5.5.

This is a separate issue and should actually have its own topic. It can reference this one.

Please provide the output for:

mhwd --list && mhwd --listinstalled

… along with the other information requested above in said new topic.

I found a solution to this issue: add ibt=off inside the line GRUB_CMDLINE_LINUX_DEFAULT of /et/default/grub.

It is actually a bug:

nvidia may not boot on Linux 5.18 (or later) on systems with Intel CPUs (likely only of 11th Gen and onward) due to FS#74886/FS#74891. Until this is fixed, a workaround is disabling the Indirect Branch Tracking CPU security feature by setting the ibt=off kernel parameter from the boot loader.

1 Like

If the ip link and inxi commands already shows your WiFi device, it means it is already enabled. :thinking:
Do you perhaps mean unable to Connect to your Access-point?

I don’t think so, because it seems he has sorted it with kernel 6.1:

That could still be the same because of driver or cipher compatibility.
The hardware shows up in the output of the commands he posted, so hardware wise the device is already enabled…
Plus as you quoted using another kernel, which is software, it works, so thats another proof of the hardware already being enabled…

Yeah, I know. The new kernel is working, so I don’t think it was previously only an access point. Plus in the link I provided:

…the issue is fixed with kernel 5.17…

Anyhow, IMHO, the topic title is misleading to the actual problem…
It should not mention enabled in combination with BIOS, because that implies a hardware issue.
While the actual problem is in software…

1 Like

I am not a native English speaker, and I also realized the word enabled might be somewhat misleading :smile:

But anyway, now I am using Kernel 6.1, and both Wi-Fi and NVIDIA can work.

Just a suggestion but in the future before updating the bios reset the bios to defaults.After updating the bios reset to defaults again to clear anything left over from the older bios.Once that’s done reset the bios to the way you had it set up secure boot fast boot off etc.