Hardware error on boot using new hardware

Hey Guys,

I’m getting the following messages every time I boot my Pc. It doesn’t seem to impact anything, but it worries me nonetheless. I just bought the cpu and motherboard, so I don’t think that it is actually damaged hardware. Does someone know how to fix this?

My specs

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.6-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i5-10400F CPU @ 2.90GHz
Memory: 15.5 GiB of RAM
Graphics Processor: GeForce GTX 1060 6GB/PCIe/SSE2

if same result with boot on USB iso live manjaro ?
it come from microcode

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. Please also read this:
    [HowTo] post screenshots and links
    Especially these bits:


  4. It looks like one of your RAM chips has failed / is failing / is about to fail. Have you done a memtest from grub yet?


Ok, here is the ouput of inxi --admin --verbosity=7 --filter --no-host --width:

  Kernel: 5.11.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=4ead3640-ed8d-4a0e-920e-28ee6c42fab4 ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: H570 Phantom Gaming 4 serial: <filter> 
  UEFI: American Megatrends LLC. v: P1.30 date: 01/29/2021 
  RAM: total: 15.51 GiB used: 4.36 GiB (28.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i5-10400F bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 5 microcode: E2 
  cache: L2: 12 MiB bogomips: 69629 
  Speed: 2702 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 2702 2: 800 
  3: 800 4: 800 5: 800 6: 801 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 460.56 
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c03 
  class-ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 91 s-size: 1070x301mm (42.1x11.9") 
  s-diag: 1112mm (43.8") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") 
  diag: 609mm (24") 
  Monitor-2: DP-4 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 
  direct render: Yes 
  Device-1: Intel vendor: ASRock driver: snd_hda_intel v: kernel 
  bus-ID: 00:1f.3 chip-ID: 8086:f0c8 class-ID: 0403 
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403 
  Device-3: Microsoft LifeCam HD-3000 type: USB driver: snd-usb-audio,uvcvideo 
  bus-ID: 1-7:4 chip-ID: 045e:0779 class-ID: 0102 
  Sound Server-1: ALSA v: k5.11.6-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: yes 
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel 
  port: efa0 bus-ID: 00:1f.6 chip-ID: 8086:15fa class-ID: 0200 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: 3000 
  bus-ID: 02:00.0 chip-ID: 8086:24f3 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: deprecated dynamic noprefixroute scope: global 
  Message: Output throttled. IPs: 19; Limit: 10; Override: --limit [1-x;-1 all] 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-9:6 chip-ID: 8087:0a2b class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Message: No LVM data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 2.73 TiB used: 340.46 GiB (12.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 033 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD20EZRZ-00Z5HB0 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0A80 scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw-size: 465.45 GiB size: 457.14 GiB (98.22%) 
  used: 340.44 GiB (74.5%) fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: 4ead3640-ed8d-4a0e-920e-28ee6c42fab4 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 3823-3631 
  Alert: No Swap data was found. 
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/sda3 maj-min: 8:3 size: 465.45 GiB fs: ntfs label: N/A 
  uuid: FA5E244B5E24034D 
  ID-3: /dev/sda4 maj-min: 8:4 size: 515 MiB fs: ntfs label: N/A 
  uuid: 100CAAA00CAA8078 
  ID-4: /dev/sdb1 maj-min: 8:17 size: 976.56 GiB fs: ext4 label: N/A 
  uuid: 6ad50a4e-89f1-4ac0-a3e6-3a6ee5350648 
  ID-5: /dev/sdb2 maj-min: 8:18 size: 886.45 GiB fs: ntfs 
  label: WindowsDateien uuid: 3486DF9D86DF5DC4 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-2:2 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1 
  speed: 480 Mb/s power: 100mA chip-ID: 174c:2074 class-ID: 0900 
  Device-1: 1-4:3 info: ROCCAT Kone Pure SE type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 1e7d:2dca class-ID: 0300 serial: <filter> 
  Device-2: 1-7:4 info: Microsoft LifeCam HD-3000 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  power: 500mA chip-ID: 045e:0779 class-ID: 0102 
  Device-3: 1-8:5 info: Holtek USB Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 04d9:a09c class-ID: 0300 
  Device-4: 1-9:6 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2b class-ID: e001 
  Device-5: 1-11:7 info: Alcor Micro AU6477 Card Reader Controller 
  type: Mass Storage,HID driver: hid-generic,usb-storage,usbhid interfaces: 2 
  rev: 2.0 speed: 480 Mb/s power: 250mA chip-ID: 058f:6364 class-ID: 0300 
  serial: <filter> 
  Device-6: 1-13:8 info: ASRock LED Controller type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 26ce:01a2 class-ID: 0300 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 7 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 2-6:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0 
  speed: 5 Gb/s power: 8mA chip-ID: 174c:3074 class-ID: 0900 
  System Temperatures: cpu: 30.0 C mobo: N/A gpu: nvidia temp: 39 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25% 
  Processes: 313 Uptime: 41m wakeups: 0 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1454 lib: 421 
  flatpak: 0 Shell: fish v: 3.1.2 default: Bash v: 5.1.0 running-in: konsole 
  inxi: 3.3.03 

No, how do I do this? Simply boot into grub, go to the console and enter memtest?

Edit: Ok so I read through a view posts and it seems like I can’t really use it since I have an UEFI and can’t go into a bios mode :confused:

Sorry, the messages are shown at boot so I figured posting an image is my best option since I can’t copy-paste the messages. I would edit my question, but I can’t find a way to do so :thinking:

Before you try anything else, upgrade to Kernel 5.10 LTS and see if the hardware error goes away (that’s an easy check)

If it remains:

  • Remove DIMM from bank 6 and reboot.
  • Does the hardware error go away?
    • If yes: Replace that DIMM
    • If no: what’s the new hardware error?

All the other stuff looks OK, except this:

So read this: Swap - Manjaro

sudo journalctl --system --priority=1 | grep --ignore-case hardware


1 Like

I see there are BIOS updates too for this motherboard, It could be worth a try to update it (at your own risk of course). Switching kernel to 5.10 LTS could be a proper easier solution too.

1 Like

I am getting the same error , I just got a new board , a intel z590 ( asrock entreme 590) that is when The error started . At 1st I thought to try different memory kits , reseat the GPU card , reseat the CPU .
Tried every bios setting under the sun . I also get with memtest " Internal error line 169 test C

nope not a memory issue the fact that we both have Asrock Z590 boards and both have the exact same problem , indicates to me some kind of bios, firmware issue

also not a bios update issue as I am running the latest 1.4

say what cpu are you using a rocket lake or comet lake ? Me I am using a 10600kf just wondering if it is because of not running a rocket lake and the kernal is seeing things being disabled

ok the problem is with the Asrock Z590 , I just swapped back to my MSI b460 Tomahawk and all those error messages went bye bye . I am sending My Asrock Z590 Extreme back to new egg , swapping it out for a MSI Z590 Torpedo
I will update when I get the board to see if messages return


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

I am not sure if I found THE solution , why do I say this ? Because I am moving to a different chipset , a b460 chipset and the problem went away . was it the chipset or the motherboard that caused the issue ?
Did Asrock produce a buggy board or is it something in the Intel Z590 chipset ?
is it that manjaro Just cant deal with a Z590 chipset ?
I will have a definite answer to that question soon as I have a new MSI Z590 en route to try out


I got the MSI Z590 installed with a fresh install of Manjaro , switched to the latest Kernel . 5.11 and the problem returns , not asrocks problem . I suspect it is a problem either with the Intel ME firmware or Manjaros’ kernel not seeing something … Not that I am complaining , it just too new cutting edge hardware . I am suprised that the B460 chipset worked so well

Maybe it is a kernel or BIOS issue.

I had also a similar problem with different messages after updating my BIOS once and I had to disable IOMMU in BIOS to get rid of the message on boot. It took three consecutive BIOS updates for that to eventually being fixed. Maybe it is a not so serious issue that will get fixed in later BIOS check you manufacturer for new BIOS in the future.

ok problem is solved for me , MSI just released a cpu microcode update in a beta bios , I suspect Asrock needs to do the same .
Flashed to the latest bios and poof all gone :slight_smile:

1 Like

:+1: nice

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.