Issue with Audio output Only available choice is Dummy output please help

Hi Very new to linux so i’m sorry if this is a very basic fix but i’ve been searching over different forums trying to find people who have solved this issue but only ran into dead end’s I’m trying to get my Laptop’s Audio To work but when I go to settings the only audio output available is “Dummy Audio” there is also no Mic selection although I have a built in Mic From my Laptop there doesn’t seem to be an end to this problem its constant I have checked for pulse Audio update’s and Tried starting and killing it although not sure if that did anything. Any help would be really appreciated as i want to keep using linux although i need my speakers

Hi @AUTISMO, and welcome!

While I highly doubt I’ll be able to help you, I can point you here: How to provide good information and, if applicable, here: [HowTo] post screenshots and links

Hope you manage!

PulseAudio module module-always-sink creates a Dummy Output when PulseAudio cannot detect any audio devices available for playback

I suggest you check ALSA hardware configuration for any errors detecting audio devices

sudo --upload
1 Like

i ran this command and Got this link

I’m not sure exactly what I’m Looking at but I’m assuming the issue is that it’s not registering any sound cards.

You should consider updating system BIOS
laptops and netbooks :: yoga series :: yoga 7 15itl5 - Lenovo Support DE

With current kernel the audio device is recognised correctly:

0000:00:1f.3 Multimedia audio controller [0401]: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller [8086:a0c8] (rev 20)
	Subsystem: Lenovo Device [17aa:3832]

But error messages show problems loading the Sound Open Firmware driver

[    7.305811] sof-audio-pci-intel-tgl 0000:00:1f.3: Direct firmware load for intel/sof/sof-tgl.ri failed with error -2
[    7.305814] sof-audio-pci-intel-tgl 0000:00:1f.3: error: request firmware intel/sof/sof-tgl.ri failed err: -2

[    7.305815] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to load DSP firmware -2
[    7.306087] sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof_probe_work failed err: -2

Kernel v5.14 should be able to load driver sof-audio-pci-intel-tgl for audio devices to function in ALSA correctly

ALSA data also shows 2 sound servers running

      Installed - Yes (/usr/bin/pipewire)
      Running - No

      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

So Updated the Bios to 514 also stopped the other soundcard although im still getting dummy ouput

ALSA data is showing same version numbers for BIOS firmware and kernel as data in post #4
Firmware Version: F5CN38WW
Kernel release: 5.13.19-2-MANJARO

For my specific yoga 7 model updating to 5.15 and rebooting fixed my speaker issues

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.