AMD and HyperX Cloud Flight S

Hello everyone,

I want to come to you because I have a particular problem.
I have an amd sound card (linked to the GPU) and a HyperX sound card (linked to my headset).

The latter seems to be well recognized. But unfortunately I can’t activate it.

[flamme@flamme-standardpcq35ich92009 ~]$ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0x90600000 irq 64
 1 [S              ]: USB-Audio - HyperX Cloud Flight S
                      Kingston HyperX Cloud Flight S at usb-0000:0e:00.0-1.3, full speed

When I use asoundconf I can see 2 devices. The first one doesn’t do anything, the second one activates the headset, but makes me lose the microphone of this one.
i.imgur. com/SZAfMC8.png

I can’t figure out why I can’t select my device in the Manjaro settings.
Can you help me solve this problem?

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Please also read this:
    [HowTo] post screenshots and links


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.

1 Like

Thank you for your feedback. I’m sorry to answer so late, but I don’t have the email notifications :frowning:

  Kernel: 5.10.61-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=0b38115e-618c-4a36-8bf0-54ae7ffd89ab rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Qemu System: QEMU product: Standard PC (Q35 + ICH9, 2009) 
  v: pc-q35-5.1 serial: <filter> Chassis: type: 1 v: pc-q35-5.1 
  serial: <filter> 
  Mobo: N/A model: N/A serial: N/A UEFI: EFI Development Kit II / OVMF 
  v: 0.0.0 date: 02/06/2015 
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A 
  status: N/A 
  RAM: total: 31.35 GiB used: 2.28 GiB (7.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3 
  family: 19 (25) model-id: 21 (33) stepping: 0 microcode: A201016 cache: 
  L2: 2 MiB bogomips: 54387 
  Speed: 3394 MHz min/max: N/A Core speeds (MHz): 1: 3394 2: 3394 3: 3394 
  4: 3394 5: 3394 6: 3394 7: 3394 8: 3394 
  Flags: 3dnowprefetch abm adx aes apic arat arch_capabilities avx avx2 bmi1 
  bmi2 clflush clflushopt clwb clzero cmov cmp_legacy cpuid cr8_legacy cx16 
  cx8 de erms extd_apicid f16c fma fpu fsgsbase fsrm fxsr fxsr_opt ht 
  hypervisor ibpb ibrs invpcid lahf_lm lm mca mce misalignsse mmx mmxext movbe 
  msr mtrr nopl npt nrip_save nx ospke osvw pae pat pclmulqdq pdpe1gb 
  perfctr_core pge pku pni popcnt pse pse36 rdpid rdrand rdseed rdtscp 
  rep_good sep sha_ni smap smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp 
  svm syscall topoext tsc tsc_adjust tsc_deadline_timer umip vaes vme vmmcall 
  vpclmulqdq wbnoinvd x2apic xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu 
  v: kernel bus-ID: 03:00.0 chip-ID: 1002:73bf class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") 
  s-diag: 1165mm (45.9") 
  Monitor-1: HDMI-A-0 res: 3840x2160 dpi: 139 size: 700x390mm (27.6x15.4") 
  diag: 801mm (31.5") 
  OpenGL: renderer: AMD Radeon RX 6800 XT (SIENNA_CICHLID DRM 3.40.0 
  5.10.61-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
  Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] 
  driver: snd_hda_intel v: kernel bus-ID: 0c:00.0 chip-ID: 1002:ab28 
  class-ID: 0403 
  Device-2: Kingston HyperX Cloud Flight S type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.3:8 chip-ID: 0951:16ea 
  class-ID: 0300 serial: <filter> 
  Sound Server-1: ALSA v: k5.10.61-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: yes 
  Device-1: Red Hat Virtio network driver: virtio-pci v: 1 modules: virtio_pci 
  port: f000 bus-ID: 01:00.0 chip-ID: 1af4:1041 class-ID: 0200 
  IF-ID-1: enp14s0u1u4c4i2 state: down mac: <filter> 
  IF-ID-2: enp1s0 state: up speed: -1 duplex: unknown mac: <filter> 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 500 GiB used: 17.11 GiB (3.4%) 
  ID-1: /dev/vda maj-min: 254:0 model: N/A size: 500 GiB block-size: 
  physical: 512 B logical: 512 B speed: 1.5 Gb/s type: N/A serial: N/A 
  scheme: GPT 
  SMART Message: Unknown smartctl error. Unable to generate data. 
  Optical-1: /dev/sr0 vendor: QEMU model: QEMU DVD-ROM rev: 2.5+ 
  dev-links: cdrom 
  Features: speed: 4 multisession: yes audio: yes dvd: yes rw: none 
  state: running 
  ID-1: / raw-size: 499.7 GiB size: 490.78 GiB (98.22%) used: 17.11 GiB (3.5%) 
  fs: ext4 dev: /dev/vda2 maj-min: 254:2 label: N/A 
  uuid: 0b38115e-618c-4a36-8bf0-54ae7ffd89ab 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/vda1 maj-min: 254:1 label: NO_LABEL 
  uuid: F306-15BD 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 15 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Adomax QEMU USB Tablet type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 0627:0001 class-ID: 0300 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 15 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 3-1:5 info: 0 THUB ports: 7 rev: 2.0 speed: 480 Mb/s 
  chip-ID: 0000:0000 class-ID: 0900 
  Device-1: 3-1.1:6 info: ROCCAT Kone XTD Optical Mouse type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 200mA chip-ID: 1e7d:2e23 class-ID: 0300 
  Device-2: 3-1.2:7 info: ROCCAT Vulcan Pro type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 1e7d:30f7 class-ID: 0300 
  Device-3: 3-1.3:8 info: Kingston HyperX Cloud Flight S type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 6 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 0951:16ea class-ID: 0300 
  serial: <filter> 
  Device-4: 3-1.4:9 info: Apple iPhone 5/5C/5S/6/SE type: Still Imaging 
  driver: ipheth,usbfs interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 05ac:12a8 class-ID: 0601 serial: <filter> 
  Device-5: 3-2:4 info: Cooler Master ARES type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 2516:014d class-ID: 0300 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Message: No sensor data found. Is lm-sensors configured? 
  Processes: 270 Uptime: 3m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1265 lib: 352 flatpak: 0 
  Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06 

Sorry I can’t edit my first post to put the capture.

1 Like

That’s a weird config… Are you running Manjaro in a VM? If yes, what’s your host system and hardware pass-through???


1 Like

Manjaro is indeed running in a VM through QEMU 4.
There is only the graphics card in passthrough. For the peripherals I use the usb of the GPU

Windows 10??? :stuck_out_tongue_winking_eye:

nop unraid
I didn’t even know that QEMU could be put on Windows :slight_smile:

I know there are sometimes conflicts between PipeWire and PulseAudio:

systemctl --user disable --now pipewire.socket && systemctl --user disable --now pipewire.service && systemctl --user mask pipewire.socket

Does that help?

Never heard of that but if the guest has 32G of RAM,I’m afraid to ask what the host has…


1 Like

Unfortunately I still don’t see the headset in output :frowning:

  Sound Server-1: ALSA v: k5.10.63-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: no

128go :slight_smile:

1 Like
  • “Flamme démon”
  • Giga-octets

:fr: :question:


What kind of headset is this anyway? USB? BlueTooth? 3.5mm jack?

If the first 2: have you passed that onto the guest as well?
For the last one: Are you sure the 3.5mm jack is hardware wired to the AMD chipset?


1 Like


The HyperX Cloud Flight S is a USB dongle that transmits in wifi.

But really its particularity is that it has 2 audio cards (at least on Windows). But using asoundconf you can see the 2 cards.

If I select the first one I only have the microphone. If I select the second one I only have the speakers :frowning:

1 Like

We have a resident Audio expert, but he’s on leave for the moment. Just choose one for the moment until he’s back. I’ll bookmark this question to revisit it in 2 weeks.


1 Like

That it rests to return in full form for this case of madness :slight_smile:

Thank you for your help

1 Like

@nikgnomic Do you have a moment to look into this one, please?


1 Like

It’s been a long time since I asoundconf'ed (maybe back around 2012)

I am fairly certain that asoundconf is not needed on an Arch distribution, but I will have to go look at some of the old ALSA scrolls to check


If I can do otherwise, no problem.
If necessary, I can give you a hand on the machine to watch.

@Fabby Thank you for your follow-up

This was older than I thought

This post is from 2012 referencing back to 2009

What package is supposed to provide /usr/bin/asoundconf? - Debian User Forums
alsa-utils (1.0.19-1) unstable; urgency=low

asoundconf was a tool introduced by Ubuntu which could be used to
generate asoundrc files for systems with special needs. The script
was not being maintained and was getting buggy, and the Debian and
Ubuntu teams have agreed to get rid of it for the next release. Users
can use Pulse or similar technologies to configure their preferred
sound devices and sinks.

– Jordi Mallach <> Sat, 28 Mar 2009 12:53:02 +0100

And alsaconf is not included in package alsa-tools from v.1.0.20

2009-05-06 - alsa 1.0.20 release

Changes v1.0.19 v1.0.20 - AlsaProject - alsaconf
alsaconf - prefer /etc/modprobe.d/sound/50-sound.conf

This package should not be needed on Manjaro KDE

Manjaro package pulseaudio-alsa creates the default ALSA configuration file for using PulseAudio as the default sound server

# Default to PulseAudio

pcm.!default {
    type pulse
    fallback "sysdefault"
    hint {
        show on
        description "Default ALSA Output (currently PulseAudio Sound Server)"

ctl.!default {
    type pulse
    fallback "sysdefault"

It might be possible to set ALSA to use PulseAudio as default with this command

asoundconf set-pulseaudio

But if that does not help, delete the 2 configuration files in user home folder to revert to default ALSA configuration

rm ~/.asoundrc ~/.asoundrc.asoundconf

Hello to all,

Thank you for your precious help. I tried all your methods and nothing worked. So I started looking at my hardware.

I am connected to a 4 port usb hub, I removed it and went direct. The headset worked directly. So I ordered a new usb hub and now everything works.

I’m really sorry to have made you lose time on the headset is the configuration of pulseaudio when the problem came from a usb hub :frowning:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.