No x11 login after full update


I ran update on all available updates and upon reboot I cannot get a usable desktop with KDE X11. It just kind of flashes and then hangs and goes back to the SDDM login screen. KDE Wayland works fine. Any thoughts?

I’m thinking coffee would go down quite well just about now.

About your situation we’d need to know how the update was performed as well as How to provide good information and, if applicable, see [HowTo] post screenshots and links.

1 Like

Thanks for the prompt reply. The update was completed using pamac.

I’m not sure how I can get a screenshot of what this is doing. There are no usable error messages that I am seeing and it does not reach a complete usable desktop.

You mentioned that Wayland works fine, can you boot into that and provide the logs? as well as the rest of the information specified above?

The Xorg.1.log file in /var contains the following:

[218470.523] (EE) RADEON(0): [drm] failed to set drm interface version.
[218470.523] (EE) RADEON(0): Kernel modesetting setup failed
[218470.523] (II) UnloadModule: “radeon”
[218470.523] (EE) Screen(s) found, but none have a usable configuration.
[218470.523] (EE)
Fatal server error:
[218470.523] (EE) no screens found(EE)
[218470.523] (EE)
Please consult the The X Org Foundation support
at wiki xorg
for help.

This is very strange. It worked before the update.

In an effort to further troubleshoot, I created a completely new user profile and with the new user KDE x11 works fine.(as does Wayland) It’s only broken with the existing user, only for x11.

Where are screen configs stored? I’ll try comparing the logs between the old and new user to see if there is something else there that may explain what is breaking the screen config.

Only as general fix after update, I suggest to:

a) check config conflicts you might not saw during updates:

sudo pacman -S meld;
sudo DIFFPROG=meld pacdiff;

b) clean cache:
-) logout from every user session to sddm (login) screen;
-) switch to virtual terminal (TTY) for example TTY3: Ctrl + Atl + F3;
-) login into TTY;
-) run these 3 commands from the sub-section of KDE - ArchWiki
-) systemctl reboot to reboot PC and check for that issue again.

Low chances that it will fix the problem, but could.

Also after you did that all above, check the
journalctl -p3 -b
journalctl -p3 -k
journalctl -p4..4 -k
outputs. Are there some messages which possibly could be related to the issue you met?

Thanks for the additional options Alven. I checked into the meld option, here is the 1 result it returned:

[]$ sudo DIFFPROG=meld pacdiff
==> pacnew file found for /etc/default/grub

I checked the differences between the grub file and the pacnew, most of the changes appear in the GRUB_CMDLINE_LINUX_DEFAULT section with apparmor changes, there’s also a resume UUID. Could these have an impact?

I’ll look into the TTY steps a little later, probably around lunch time.

If another user works, then that grub file doesnt matter.
(though do deal with your pacnews)

It is something about the configuration of the original user … something in ~/.config for example.

It is likely that the ‘KDE - troubeleshooting - configuration related’ link is applicable to you.

(Do note that if you run the suggested commands there you will need to reconfigure your desktop)

But in order to have no other issues, better to resolve config issues - to leave the config in the state which adds it’s new state you got with update but saves the customization you need.

To reconfigure? How cache folder cleanup touches configs?
Or you meant the

‘KDE - troubeleshooting - configuration related’ link

in your post and not the commands which I linked?

So if you do this …

If you cannot find the problem, but you do not want all the settings to be lost, navigate to ~/.config/ and run the following command:

$ for j in plasma*; do mv -- "$j" "${j%}.bak"; done
(KDE - ArchWiki)

It does not affect only your cache … and your desktop will be ‘reset’ as in you need to add your widgets again etc.

1 Like

I was able to resolve this. I tried the following: “for j in plasma*; do mv – “$j” “${j%}.bak”; done” - All of the bak files were created and settings put back to default, but this did not work.

What did work was clearing out the cache in TTY. Right now, I only have one single monitor plugged in. I found that in the newly created user profile I can get X to crash every time if I set one of my monitors to a resolution that is tall instead of wide. Since the originally reported issue is resolved I will create a different discussion with the proper focus.

Interestingly enough, this issue has been fully resolved with all monitors working now. A couple of hundred new updates showed up in pamac so I installed them, I have no issues anymore since the last reboot. Very strange that this all happened so quickly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.