Black SOD off Live USB

I downloaded the newest XFCE, used Rufus to burn it to a usb, it booted to the usb fine, when it came up to options and i selected boot, the screen turns black and no longer accepts user input. ctrl alt f2, control c, nothing. I was wondering if it has anything to do with the graphics adapter, or the fact that i have technically 6 drives in my computer and 1 is a windows installation and 3 others are a raid 5 array, and i’m trying to install to the last one. If there’s a way for me to attach images i’ll do that later through trying to setup a vm to show where i get stuck.
Thanks in advance, also i’m somewhat new to linux grub stuff, so please explain where i’m supposed to put what, not just “Oh go put a nomodeset kernal param”. I have no idea what that is or where to put it.


If this is correct from your user description: GPU: NVidia RTX 2070 Super
then you need to select nonfree driver option, from the menu, before you boot. The default one is free

You could use this service and share the link:

Please read this (cc @bogdancovaciu )


I think it was actually my USB drive. I was using nonfree already because i remember linux and nvidia not getting along. after burning the ISO to three flashdrives, the third one worked. I have no idea why, but it’s up so i’m not gonna question it.

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.