Windows Manjaro and grub boot fail

hi my hard drives partitons has ~40Gb(windows) ~20Gb (manjaro) empty space and some unchangable small partitions (400mb max)(by windows) and partition that has boot loader has 1gb empty space so ı decided to give some of the space to manjaro and windows using gpart after giving space i re booted my laptop and ı cant boot into windows then ı just try to fix it by fixing windows boot configuration
bootrec/ scanos
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd
then re started and grub is not booted
Noting booted grub is not even started and bios cant find operating system

Windows is unsupported.

When you remodel your partition layout you will most likely have changed the guids of the partitions.

This will - if any of the system partitions are reordered/changed - render the system non-bootable.

Systems using MBR to boot is incompatible with system using EFI so dual-booting mandates same bootloader.


Is there any way to fix it

Hi @Fmert2, and welcome!

  1. Please, please, please use proper grammar. I found this extremely hard to read and understand.
  2. Please see:

is nothing detected in bios boot options?

nothing detected in bios boot options

do you have manjaro usb?
install manjaro, then download windows iso, flash it, run it, and repair windows boot partition with it

I have manjaro and windows usb so how do i repair windows boot partition?

look on internet on guides how to repair windows bool with usb, thats plenty of them…

Boot from the Windows install medium and select the repair option, I’m guessing.

But I haven’t worked with Windows in more than a year, so might be wrong.


Hello @Fmert2 :wink:

It is not clear how your paritions table looks like. Please provide more information:

sudo parted -l

Since you are running “bootrec /fixmbr”, I assume it is a BIOS with a MSDOS partition table. Therefore, only one boot loader can be used per hard disk. To set up a dual boot, grub must be installed in BIOS mode (NOT UEFI), which then starts the Windows boot loader.

Model: ATA ST9500325AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 32,5MB 31,5MB primary ntfs
2 43,0MB 416GB 416GB primary ntfs
3 416GB 466GB 50,5GB primary ext4
4 466GB 500GB 33,9GB primary ext4 boot

As mentioned by @linux-aarhus, you need to read this wiki article:

There you need to boot a Manjaro Install Disk and then do the following:

  1. Open a terminal and type this to change to the local installation:
    sudo manjaro-chroot -a
    It should search the installation and do all the steps needed to enter it.
  2. Then reinstall the bootloader and overwrite the MBR, so that the BIOS loads the grub bootloader:
    grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sda
  3. And then create a boot menu:
    grub-mkconfig -o /boot/grub/grub.cfg
  4. Type exit to leave the chroot and reboot.

Also to mention: Keep sure that the file at /etc/default/grub has a variable like this:


Without a # in front of. That is needed to enable detection of other OS’s while executing grub-mkconfig -o /boot/grub/grub.cfg :wink:

Just open it with an editor:

nano /etc/default/grub

Change it and save it. This have to be done on the local installation while being in chroot

Thank you for fixing grub boot loader

Windows boot partition fix

Use Bootrec.exe in the Windows RE to troubleshoot startup issues Fix Windows 10 Winload.efi Is Missing or Corrupt In BIOS (Solved) - YouTube

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.