[Stable Update] 2024-05-29 - Kernels, Plasma 6.0.5, GNOME 46.2, Mesa

I didn’t install them via aur.

Openai whisper I installed via info here:

GitHub - openai/whisper: Robust Speech Recognition via Large-Scale Weak Supervision (I think, it’s a long time ago)

Darkradiant I’ve build from source:


I will probably try rebuilding DarkRadiant at least.

Edit: I got Whisper working again using an AUR package.

1 Like

There has been a recent Python version bump. That, coupled with other recent changes, will probably mean some things need to be rebuilt no matter where they came from.

See Python 3.12 info in this same thread.


I am having issues with the Wynsdey update that I haven’t seen posted elsewhere.

  • One of my two GPUs (AMD RV730 GL FirePro V3750) no longer drives video output even though it is detected by the OS.
  • If I drop to a tty, then the monitors attached to the non-working GPU start working, and the other monitors attached to the other GPU freeze
  • I’m also getting corrupted display issues. Like this is my cursor:

The update seems to have broken support for one of my GPUs and is causing corrupt graphics on my other GPU. I appreciate any guidance!

`$ inxi -bz`
  Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64
  Desktop: GNOME v: 46.2 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4403
    date: 04/27/2022
  Info: 12-core AMD Ryzen 9 5900X [MT MCP] speed (MHz): avg: 2565
    min/max: 2200/4950
  Device-1: AMD RV730 GL [FirePro V3750] driver: radeon v: kernel
  Device-2: AMD Cape Verde XT [Radeon HD 7770/8760 / R7 250X] driver: radeon
    v: kernel
  Device-3: Logitech Webcam C930e driver: snd-usb-audio,uvcvideo type: USB
  Display: wayland server: X.Org v: 24.1 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: radeon unloaded: modesetting
    dri: radeonsi,r600 gpu: radeon resolution: 1: 1920x1080~60Hz
    2: 1920x1080~60Hz
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Wi-Fi 5 Wireless-AC 9x6x [Thunder Peak] driver: iwlwifi
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Local Storage: total: 51.87 TiB used: 10.23 TiB (19.7%)
  Memory: total: 64 GiB note: est. available: 62.7 GiB used: 8.43 GiB (13.4%)
  Processes: 606 Uptime: 2h 24m Shell: Zsh inxi: 3.3.34
sudo mhwd -l
> 0000:0b:00.0 (0300:1002:683d) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:07:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

> 0000:05:00.0 (0300:1002:949f) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Edit: I’ve discovered some relevant log entries in journalctl:

gnome-shell:6746: GLib-CRICITAL **: g_close(fd:0) failed with EBADF. The tracking of file descriptors got messed up
grome-shell:6746: libmutterWARNING **: Failed to open gpu '/dev/dri/card0': No suitable mode setting backend found

/dev/dri/card1 works perfectly fine, that is the GPU that is working. Why is the other one failing? I still don’t know how to go about fixing this.

1 Like

Hmm… I just got around to applying the stable updates from 2024-05-13 onwards, and having spent a good while following the guide to dealing with the latest system Python updgrade.

I’m not 100% sure, but I think it’s this latest (2024-05-29) update which includes Pipewire that has caused my problem. My laptop speakers work fine, but my wired headphones do not work at all. I’m using wireplumber as a session manager.

I think someone else had a similar problem with the first big update ([Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, Nvidia, Pacman - #259 by DrRevert) but the fix (involving ~/.config/wireplumber) is not relevant to me.

Since this update, after typing in my LUKS password at the initial prompt but before the diagnostic messages appear, I get this:

Keyfile could not be opened. Reverting to passphrase.

A password is required to access the luks-<id> volume:
Enter passphrase for /dev/nvme0n1p2:

I can then enter my LUKS password again and it continues booting. I suspect there’s something wrong with my mkinitcpio.conf. I’ve merged the .pacnew provided by this update, the resulting file is (sans comments):

HOOKS=(base udev keyboard keymap autodetect modconf kms block consolefont encrypt openswap resume filesystems fsck)

(I tinkered with HOOKS a lot previously following some posts here in an attempt to get USB keyboards to work at the initial LUKS prompt, with no luck, hence the weird order).

OK, I think I fixed it: I went to pavucontrol and saw that the Built-in Audio profile was Analog Surround 4.0 Output + Analog Stereo Input (unavailable).

I changed that to Analog Stereo Output, which restored audio in my headphones

I also found Analog Stereo Duplex profile worked as well – indeed these were the only two profiles which weren’t marked (unavailable) in the drop-down menu.

Hope this helps someone else. I think this happened to me once before after an update as well, but I had trouble remembering this fix. I wish I could properly understand how audio on Linux works so that I don’t have to keep blindly playing around with the ornaments in order to fix a problem with a straightforward solution. One day maybe.

1 Like

Hi I just updated my system from before the 2024-05-13 update where KDE updated to 6. I can’t comment on that thread anymore as it’s closed but it went somewhat okay, still trying to see what changed and what’s not working anymore.

I’m missing the kernel app. Before the update there was an app to check available kernels and install them. Where is that now? Also I think the drivers section is missing, where I could choose which driver I wanted to use (open source, vs proprietary) for my hardware.

Also the KDE plasma report that is pre-installed in the system tray produces the following error and not working:

file:///usr/share/plasma/plasmoids/org.kde.plasma.weather/contents/ui/main.qml:452:25: Type FullRepresentation unavailable

file:///usr/share/plasma/plasmoids/org.kde.plasma.weather/contents/ui/FullRepresentation.qml:38:24: Cannot assign object of type "QQC2.Action" to property of type "Action_QMLTYPE_93*" as the former is neither the same as the latter nor a sub-class of it.

EDIT: I found the kernel app, it’s no longer a standalone app that I can search and find in the launcher. Instead I had to go to the system tray >Manjaro settings manager and right click that to find the kernels. However the hardware/drivers app is still missing

Hello everyone, this is my first post here, please don’t through a lot of tomatoes. So, since the previous update I’m getting troubles with frozen screen, when nothing is active and only power button can help. It happens occasionally on different loads, sometimes during just laptop idling. The interesting part is that Caps Lock led starts blinking once the system got frozen. Please let me know what information is required to troubleshoot this issue.

Generated on 2024-06-06 13:07:1717664835

#################### inxi -Fxzc0 ########################

  Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro base: Arch Linux
  Type: Laptop System: LENOVO product: 82L5 v: IdeaPad 5 Pro 16ACH6 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required> UEFI: LENOVO v: GSCN33WW
    date: 07/04/2022
  ID-1: BAT0 charge: 71.9 Wh (100.0%) condition: 71.9/75.0 Wh (95.9%) volts: 17.1 min: 15.4
    model: Celxpert L20C4PE1 status: full
  Info: 8-core model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3
    rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 516 high: 2256 min/max: 400/4680 cores: 1: 400 2: 400 3: 400 4: 400 5: 400
    6: 400 7: 2256 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400 14: 400 15: 400 16: 400
    bogomips: 105453
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Lenovo driver: nvidia v: 550.78
    arch: Ampere bus-ID: 01:00.0
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series] vendor: Lenovo driver: amdgpu
    v: kernel arch: GCN-5 bus-ID: 05:00.0 temp: 43.0 C
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB bus-ID: 3-4:5
  Display: wayland server: X.org v: with: Xwayland v: 24.1.0 compositor: kwin_wayland
    driver: X: loaded: amdgpu,nvidia unloaded: modesetting,nouveau dri: radeonsi gpu: nvidia,amdgpu
    resolution: 1: 1920x1080 2: 2560x1600
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,radeonsi,swrast platforms:
    active: gbm,wayland,x11,surfaceless,device inactive: device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.8-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon Graphics (radeonsi renoir LLVM 17.0.6 DRM 3.54
  API: Vulkan v: 1.3.279 drivers: nvidia,radv surfaces: xcb,xlib,wayland devices: 2
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 05:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 05:00.6
  API: ALSA v: k6.6.32-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: off
  Server-3: PulseAudio v: 17.0 status: active
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter vendor: Lenovo
    driver: mt7921e v: kernel bus-ID: 03:00.0
  IF: wlo1 state: down mac: <filter>
  Device-2: ASIX AX88772B Fast Ethernet Controller driver: asix type: USB bus-ID: 1-2:2
  IF: enp5s0f3u2 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: br-239fb1dc4855 state: down mac: <filter>
  IF-ID-2: br-a736bda00cfd state: down mac: <filter>
  IF-ID-3: br-b7a2e7bd3bab state: down mac: <filter>
  IF-ID-4: docker0 state: down mac: <filter>
  Device-1: Foxconn / Hon Hai MediaTek Bluetooth Adapter driver: btusb v: 0.8 type: USB
    bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 341.6 GiB (71.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB temp: 36.9 C
  ID-1: / size: 459.43 GiB used: 341.6 GiB (74.4%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3
  System Temperatures: cpu: 58.1 C mobo: 42.0 C gpu: amdgpu temp: 44.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 28 GiB available: 27.26 GiB used: 6.05 GiB (22.2%)
  Processes: 379 Uptime: 7m Init: systemd
  Packages: 2086 Compilers: clang: 17.0.6 gcc: 14.1.1 Client: Unknown Client: krunner
    inxi: 3.3.34
1 Like

Hi @almond.cake, and welcome!

Please start a new thread and provide the necessary information so that we, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Please also note and heed: Forum Rules - Manjaro

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.


These may only be coincidental; but, both within the last few days seems like it might be worth attracting some attention:

1 Like

Welcome to the forum! :vulcan_salute:

That’s a kernel panic, and if it happens while the system is already up and running — as opposed to at boot — then the cause is usually faulty hardware. Common causes are overheating and/or a faulty memory module.

1 Like

Is there any way to investigate it in details? Most probably something isn’t compatible 6.6 kernel version since I haven’t seen the same issue while on 6.1

Please start a new thread as previously requested. This has nothing to do with the update. It is merely a coincidence to have presented itself at the same time.

That said,

journalctl --priority=warning..crit --no-pager --boot=-1


  • The --priority=warning..err argument limits the output to warnings and errors only;
  • and the --no-pager formats the output nicely for use here, on the forum;
  • the --boot=-1 argument limits the output to log messages from the previous boot. This can be adjusted to -2 for the boot before that, -3 to the boot before that, and so on and so forth.

Thanks for your help.I was too busy these days, I tried different methods that I saw in the forum with my same probel but didn’t work for me. I know every system is different. Finally I restored my KDE configuration and finally it works well. Also I create another account before restore the config and in that account it works perfectly.Maybe this helps someone that have the same problem.

I killed the LUKS slot I wasn’t using (from a previous failed attempt to use a USB key to unlock), removed its cryptkey from my kernel parameters, and ran grub-mkconfig, and it now asks for my LUKS password not twice but three times on boot! The Keyfile could not be opened message has been replaced by two differently-worded variations on “A password is required to decrypt” following the usual initial prompt.

Edit: I think the second (or third, I guess) prompt is likely GRUB - ArchWiki :

Without further changes you will be prompted twice for a passphrase: the first for GRUB to unlock the /boot mount point in early boot, the second to unlock the root filesystem itself as implemented by the initramfs.

Edit 2: I’m now back to where I was before this update by following dm-crypt/Device encryption - ArchWiki to embed a keyfile in initramfs. I still get the first prompt to decrypt /boot but subsequent decryptions use the keyfile. I think what probably happened to cause the third prompt was that I removed a keyfile from initramfs on my encrypted swap, thinking I was removing the USB keyfile on the disk (I’d totally forgotten about encrypted swap so didn’t check to see if more than one LUKS device was listed). The first prompt was for /boot, the second was for the disk and the third was for swap. Still no idea what caused the second prompt to appear though.

Hi after update discord is out of date, is it better to install discord with flatpak ?

It’s better to wait until it’s updated in the Manjaro repo; have a little patience. :wink:

See here:


It’s rare that I agree with that poster, however, I’m forced to agree with his general sentiment. :smile_cat: