Noob Trying Manjaro - Broadcom BCM43142 Wifi Not Working

Hi, I can’t get my wifi to work after several different tries. Here is my inxi:

   ~  inxi -N  :heavy_check_mark:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
Device-2: Broadcom BCM43142 802.11b/g/n driver: bcma-pci-bridge
   ~   :heavy_check_mark:

Welcome @LibertyMom. Can you provide a little more information about what you have tried so far?

What desktop environment are you using?

What network are you trying to connect to? Are you at home? Are there other devices connected to the network?

What is the output of:

nmcli g


nmcli r

1 Like

Thank you for your help.
I have tried backing the kernel to 5.10.89-1,

  • adding my wifi network to the network settings.
  • downloading the BCM43142 firmware from AUR.
    KDE Plasma
    I’m at home trying to connect to my home wifi network. There are other devices connected to the network.
       ~  nmcli g  :heavy_check_mark:
    connected full enabled enabled enabled enabled
       ~  nmcli r  :heavy_check_mark:
    enabled enabled enabled enabled
    Thanks for your help, I appreciate it because I know this is a common problem and you guys probably get tired of people asking. :slightly_smiling_face:

Does the WiFi pick up from a cold boot? Not a reboot–complete shutdown, wait a couple seconds, then boot back up.

1 Like

Let me try it and I’ll let you know.

No, it doesn’t. Here’s a screenshot of the connection I tried to add myself.
Oops, can’t send a screenshot yet apparently.

That is odd that you are not getting a connection, because your nmcli output suggests that you are connected.

What type of error message are you getting when you try to connect?

1 Like

When I unplug my ethernet cable, it says “no available connections.”

Thank you, BluishHumility for your help. Unfortunately, I have to get to sleep, so I will need to continue this tomorrow. Again, thank you for taking the time. If you think of any ideas, please let me know. :slightly_smiling_face:

No worries, I’m sure we’ll get it sorted out. :blush:

1 Like

In terminal:

pamac install linux510-broadcom-wl

substitute to install appropriate kernel version, e.g linux515-broadcom-wl

install appropriate linux headers as well for good measure

pamac install linux510-headers or linux515-headers as appropriate

Should be available in mhwd…


What @jrichard326 said, and if it still doesn’t work, please see, [HowTo] Provide System Information and, if applicable, [HowTo] post screenshots and links


And, in addition to what @jrichard326 said, I’d recommend you rather use the -dkms driver, as this survives kernel rebuilds. And it seems to be available in the community repositories:

$ pamac search broadcom
broadcom-wl-dkms                                                                                                                                                                                                         community
Broadcom 802.11 Linux STA wireless driver

So, should theoretically be installable with:

pamac install broadcom-wl-dkms

Or, that’s the theory, anyway.

1 Like

Thank you jichard326, it worked!
I appreciate your time very much.
Thanks for helping a frustrated noob. :wink: :blush:

1 Like

Thank you for your help. I’m happy to report that jrichard325’s solution worked. I’m untethered! :grinning:

1 Like

I’m genuinely happy it worked!

However, remember that his option isn’t dkms so definitely won’t survive ALL updates. It might some, I’m not :100: on that, but it won’t all. Especially involving your kernel. So you might need to rebuild the driver after updates, and definitely when changing kernel versions.

My experience with these (linux515-broadcom-wl) on two older computers, is that when they update the kernel these are automatically updated whether on Stable Branch or any other branch that I have used. They are in the official repositories (extra).

That’s excellent! As I mentioned, it would probably survive some updates, but not all.

For example, I think it might survive an update from kernel 5 version 5.13 to version 5.16, but I highly doubt a driver installed for, let’s say, version 4.14 will be good with an upgrade to kernel version 5.4. Or even 4.19.

Or something like that, anyway.

Which would have been true using

sudo mhwd -i pci network-broadcom-wl

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.