Stuck on clean when booting with 2 monitors

New user here.

Installed Manjaro Xfce & setup all no problem, very nice thanks!

Today I powered down & plugged in a second monitor (both HDMI) to my ASUS Prime B560M-A LGA1200 Motherboard . At boot I am stuck on the clean boot screen. I am using the motherboard onboard Intel graphics.

If i reboot & unplug the second screen it boots as normal. Plug the second screen in & it’s detected & lets me choose the arrangement & all is well.

Reboot & it hangs again at the clean line.

It’s consistantly like this. Any solutions out there?

Thanks, Paul

Hello @paul42 and welcome :wink:

That is a really weird behavior. I have no solution, but we can investigate what problem it is at the logs:

Open a terminal and type:

journalctl --dmesg --boot 0 --no-hostname --no-pager
journalctl --dmesg --boot -1 --no-hostname --no-pager

and also the the xorg logs:

export logs=( "/var/log/Xorg*.log" "$HOME/.local/share/xorg/Xorg*.log" )
for x in ${logs[@]}; do echo -e "\n---$x---\n$(cat $x)"; done

Likely the logs are very big… So use an external service for that.

Thanks will get back tomorrow with the info…

Unfortunately the PC in question has decided to expire, even though it’s only ten days new.

Thought it was the psu but it appears to be the motherboard, so it goes back to the supplier on Monday.

Got my pc back with a replaced motherboard & all good apart from this dual monitor issue.

Links for info as requested below. Using onboard Intel graphics & 2 x HDMI on motherboard.

I deleted “quiet” in “/etc/default/grub” & updated so I could see the boot messages as I did find some folks had found that helps. No change for me though.

One small detail I noticed. During a single monitor boot the boot messages are shown in what I regard as a normal smallish font size but during a dual monitor boot the text is a much larger font.

Failed boot with 2 mons plugged in followed by forced power off & successful boot with 1 mon
boot 0
boot -1

Successful boot with 1 mon & 2nd plugged in after login
boot 0
boot -1


Hope this helps
Thanks, Paul

@paul42 There seems to be zero errors. Normally it should work, but what I see is, that it uses the modesetting module and you have 11th Gen CPU. There might be a problem with this driver…

[  2059.719] (II) LoadModule: "modesetting"
[  2059.719] (II) Loading /usr/lib/xorg/modules/drivers/
[  2059.720] (II) Module modesetting: vendor="X.Org Foundation"
[  2059.720] 	compiled for, module version = 1.21.1
[  2059.720] 	Module class: X.Org Video Driver
[  2059.720] 	ABI class: X.Org Video Driver, version 25.2

First thing I would try is setting up xorg with the intel driver instead…

Create a config file:

sudo nano /etc/X11/xorg.conf.d/20-intel.conf

and paste this into it:

Section "Device"
	Identifier "Intel"
	Driver "intel"
	Option "TearFree" "1"

(You can easily switch the driver by replacing Driver "intel" with Driver "modesetting")
Save it. Now reboot and check the xorg logs again and maybe it works now.

When using modesetting (which is the default), you can force some settings on the kernel parameter:

video=HDMI-0:1680x1050@60e video=HDMI-1:1680x1050@60e

(force enable output of HDMI-0/1 at resolution 1680x1050 at 60hz )
Kernel mode setting - ArchWiki
and you can completely disable KMS:


At grub it can be add at the file /etc/default/grub inside the variable string: GRUB_CMDLINE_LINUX_DEFAULT="". Don’t forget sudo update-grub after every change.

Thanks for the reply.

I tried the driver change, that didn’t fix it. I booted with 1 mon I, plugged the 2nd in & enabled it in settings then rebooted & still hung.

I tried the video=HDMI line adding it to grub & updating but made no difference, still had the large text & hang with both monitors. Was that where you meant me to add it?

That’ll teach me to for speccing the latest gen intel if that’s the issue. Doubtless it will get fixed in time.

1 Like

Maybe it’s because the modules load late, which could cause a “timing issue”…

Replace/Add this:


to the file /etc/mkinitcpio.conf

Then run:

sudo mkinitcpio -P

Now the driver loads as early as possible.

But however, since there is no issue logged, it is just a guess.

Nope didn’t help but thanks. Tried hibernate & suspend, suspend was good for 2 boots then stopped as well.

Tried kernel 5.15.6-2 but no difference.

Found this, looks like I just need some patience

edit: forgot to add it just made the freeze happen much earlierin the boot so i suppose that shows that’s where the issue lies

Just thought I would update this issue. Now running on kernel 5.16.2-1 and no change to my dual monitor issue. Its not much of an issue, I can be patient, as plugging in the second screen at the login prompt works every time once I login.

Otherwise very happy with Manjaro, everything working very nicely. All recent updates worked seamlessly, totally stable system.


I had an issue where I could only boot with a single monitor (XFCE).

Stuck on clean when booting with 2 monitors

I would then plug in the 2nd & all would be ok. This appeared to be due to lack of support for the 12th gen Intel chips.

After the last set of updates the issue is fixed. Now reliably booting with two HDMI monitors.

Patience works it seems…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.