Multiple Issues when installing manjaro with KDE Plasma as Dual Boot


I have multiple problems when trying to install manjaro on my desktop pc.

1: Installing in UEFI mode fails with an error during the drive formatting process. I am unfortunately not able to post the screenshot I made of the error, but it says “The installer failed to create partition on disk ‘m4-…’” with a short log but no visible errors. I use the “Erase Disk” funtion when asked for how to install. Afterwards the KDE partition Manager even shows /dev/sda1 being a fat32 partition. Installing in Bios-Mode runs without issues.

2: KDE Plasma only starts in X11 and not Wayland mode. When trying to log in to Wayland mode it just cycles back to the login screen. I read that this may be connected to the graphics card, since I use nonfree drivers. Does anyone have advice, where I could get some log information on this?

3: My Windows-Installation is not picked up by Grub. I think this might be related to the system being installed in Bios-Mode, while windows is in UEFI-Mode? Or do I need to mount the Windows partition for Grub to find it? I am not quite sure since it worked flawlessly with my previous installation of linux mint. Booting into it also works from the uefi-settings.

I use the following hardware:
CPU: Intel Core i5-6500
Ram: 16 GiB
GPU: Nvidia RTX 3060 TI
Drives: sda: Crucial m4 128 GiB <— Linux Drive
sdb: Samsung 870 QVO <— Windows Drive
sdc: 3 TB HDD for storage

Also another short question: What is the preferred way to mount the harddrive on boot? Previously I often had issues with windows leaving it dirty (since it is formatted as NTFS), causing issues booting. So I mounted it via a startup script, running ntfsfix first. Bot it felt more like a workaround than a real fix.

Hi @volucris, and welcome!

That actually happens when You don’t have fast startup disabled in the UEFI BIOS and in Windows. Nothing to with NTFS.

For more, see:

For a good way of mounting drives, see:

See [HowTo] post screenshots and links

Wayland is still full of bugs. And there are many problems with it and Nvidia GPU, IIRC. So have a look here:

I’d also recommend you open new threads, each containing one issue you’re looking for assistance with.

Hope you manage!

Could be a conflicting setting in Plasma.

The setting makes Plasma mount known devices, which causes what you are describing.

1 Like

This fix (first Link by linux-aarhus) solved the issues installing in UEFI mode.
At that point windows was also detected instantly by Grub.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.