Cannot install software

Hi, I am trying to migrate from Windows to Linux. I have installed Manjaro on a Lenovo G50 laptop. Everything seems to be working fine for the moment except that I cannot install any software at all either with the built in add/remove software utility, or with the web installer online. I have also tried to install the “web-installer-url-installer” but that won’t install either from the web or the downloaded file. It seems the system has been locked not to install any software at all. Please help.

Please elaborate. Does some kind of error message show? Do you click the button and nothing happens?

What web installer?

Thank you for your response. Yes, there is an error message after i select an app from the web software center and click download. First there is a [synchronizing databases] message, then the error message: [Failed to prepare transaction]. Please find the screenshots attached.

I tried to upload the error screenshots but received a message that I cannot upload media. I tried to truncate the picture titles, but that didn’t help. How am I supposed to upload the screenshots please?

This one:
I tried to post the link but received a message that I cant post links. Lets see. It might work if I don’t include the http thing and just write the rest of it. Please include the http yourself and change the dashes to periods

run this command and post output from it:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

and use formatting for the outputs:

your output here
1 Like

-Excellent! Thank you very, very much Brahma. All software is now visible, available, downloadable and installable. Everything is great now, except that I can download the game Aisleriot Solitare but when I click to run it there is a temporary flash on the screen as if it was opening but then it disappears. But huge thanks for rest of the 99.9% that you fixed. :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.