Keyboard not working on Asus Vivobook S 15 OLED K3502ZA

well the keyboard should be accesible now, post the output of

sudo libinput list-devices | egrep -i Device


sudo libinput list-devices | egrep -i Device                                                                                                                                                                                                  ✔  3s  
Device:           Video Bus
Device:           Power Button
Device:           Lid Switch
Device:           PixArt USB Optical Mouse
Device:           USB2.0 HD UVC WebCam: USB2.0 HD
Device:           Logitech USB Keyboard
Device:           Logitech USB Keyboard Consumer Control
Device:           Logitech USB Keyboard System Control
Device:           ASUE120B:00 04F3:31C0 Mouse
Device:           ASUE120B:00 04F3:31C0 Touchpad
Device:           Asus WMI hotkeys

please check your bios setting for the touchpad. is there a entry of the mode ? if so set it to basic-functionality not the extended, save and reboot

I looked everywhere, did not find any setting related to the touchpad

tried mint live usb, keyboard doesnt work there either

well i would download the latest iso and do a new install, but never use a second(external) keyboard while installing on a laptop with built-in keyboard. this drives the system mad. also make sure that the latest bios is installed (check the manufacturer download-page for bios-updates).
at this point i can’t recommend any other solution, maybe someone else knows better.

As far as I can tell, that laptop’s keyboard is still PS/2 and doesn’t work in (recent) kernels. Totally unsure 'bout that, so more than ready to be proved wrong.


If you add the i8042.dumbkbd parameter to the GRUB_CMDLINE_LINUX the PS/2 keyboard will be shown in the output of the libinput list-devices (or xinput also), but sadly the keyboard still not working.

Here is my case:

[grxb@asus-s14x ~]$ cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=eeaa1257-889b-4419-9b95-ba09e5be0184 udev.log_priority=3 i8042.dumbkbd i8042.noaux i8042.noloop i8042.nomux i8042.nopnp i8042.notimeout i8042.reset=Y i8042.unlock i8042.kbdreset i8042.probe_defer"


[    1.488694] i8042: PNP detection disabled
[    1.490802] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.608010] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2

libinput list-devices:

Device:           AT Translated Set 2 keyboard
Kernel:           /dev/input/event2
Group:            9
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles:   n/a
Rotation:         n/a
[grxb@asus-s14x ~]$ sudo xinput
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ASUE120B:00 04F3:31C0 Mouse             	id=14	[slave  pointer  (2)]
⎜   ↳ DuckyChannel International Co., Ltd. Ducky Keyboard Mouse	id=11	[slave  pointer  (2)]
⎜   ↳ ASUE120B:00 04F3:31C0 Touchpad          	id=15	[slave  pointer  (2)]
⎜   ↳ Logitech MX Ergo                        	id=18	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=17	[slave  keyboard (3)]
    ↳ Video Bus                               	id=6	[slave  keyboard (3)]
    ↳ DuckyChannel International Co., Ltd. Ducky Keyboard	id=8	[slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD         	id=13	[slave  keyboard (3)]
    ↳ Asus WMI hotkeys                        	id=16	[slave  keyboard (3)]
    ↳ DuckyChannel International Co., Ltd. Ducky Keyboard System Control	id=9	[slave  keyboard (3)]
    ↳ DuckyChannel International Co., Ltd. Ducky Keyboard Consumer Control	id=10	[slave  keyboard (3)]
    ↳ DuckyChannel International Co., Ltd. Ducky Keyboard	id=12	[slave  keyboard (3)]
    ↳ Logitech MX Ergo                        	id=19	[slave  keyboard (3)]

I have an Asus Vivobook S14 OLED K3402ZA, so I’m also interested the solution so much. :confused:

1 Like

it’s better to open your own thread even if its the same problem or a similar problem.

Just tried this, downloaded the latest iso, installed using an onscreen keyboard. Still same problem. :frowning:

Bios is at latest version.

it looks like this is a widespread issue with this line of laptops. If we can find a solution here this thread will be valuable to other people looking to use manjaro on this hardware

Try kernel 6.0-rc1 when available. It’s a shot in the dark though (I’m too lazy to figure out if there are any asus additions).

(Would be nice if mainline PKGBUILD for manjaro was available somewhere…sigh)

EDIT: Ok, it’s available now (PKGBUILD that is).

this model has even with ms-windows problems and need a specific driver for the normal use of the keyboard. good luck mates but this is a suspicious model.

Hi I have found out the patch for this laptop it is listed in the kernel bugs so it will be officially patched soon!
How can i share the link here?
on the “bugzilla.kernel .org” id is 216158

here you are:

just one more thing how can i apply the patch myself? listed there

as i understand this is jaus a preliminary, i can’t see any avaiable patch for now.

You need to compile kernel yourself:

  • git clone desired kernel from manjaro gitlab
  • download .patch file and put it in same directory
  • edit PKGBUILD and add the patch
  • build with makepkg

1 Like

Thanks everyone the keyboard now works after patching and building the kernel!

1 Like