Window Decorations drawing a thin border when no border selected

Hey all,

Got a bit of a weird problem I can’t seem to solve.

My system is all up to date running kernel 5.8 and nVidia 450 drivers.

When using Window Decorations other than Breeze I can’t remove borders completely. For some reason it’s drawing a thin border around all my Qt applications. When selecting my GTK theme it works just fine. I’ve had KDE on my PC with the Qogir theme running perfectly fine then I installed and ran GNOME for a month and just recently decided to switch back to KDE (full system re-install for these).

I’ve had a search around and can’t find anything on how to resolve this issue. It’s not just Qogir either, its all decorations bar Breeze really, the other theme I like to run is Arc and that has the borders drawn in as well.

I’ve got some screenshots for examples but I can’t seem to attach them to this post unfortunately.

Any help appreciated, thanks all.

1 Like

I’m getting this exact same issue, though only on my desktop and not on my laptop. I don’'t believe this is an issue with the theme itself as i’m running the same theme on both my machines, and only the desktop has the problem. I’ve tried multiple window decorations like you and have noticed the same thing, everything but Breeze seems to be broken. GTK apps respect the no border setting, but Qt apps don’t.

Screenshots (had to put space between .com otherwise I couldn’t add the link):
imgur .com/a/s8HxpJO

For the future:


1 Like

Please notify the theme developer of this.

For other themes: it’s easy to get into the KDE repository but nearly impossible to get out of so a lot of themes are abandonware E.G. KDE 4 themes that don’t necessarily know about High-DPI screens, new plasma features, … so take a theme that works for you and then customize it yourself with the resources of the theme you want and then publish a new version if the developer doesn’t correct bugs any more…


1 Like

This appears to be an issue with the theme, yes. I’ve created a pull request on the Qogir theme to adjust the padding.

Under ~/.local/share/aurorae/themes/Qogir/:


Change from 11, to 10:

Should be:

Edit: Turns out it fixed it for the ultrawide, but not 1080p… :frowning:


Yeah I reckon its a DPI issue, thank you for the information.
Using devRs little hack I got them both working but playing around with the padding in the rc file.

1 Like

Thank you

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.