Error when install barracudavpn client

Hello everyone, I’m a newbie with Manjaro.

I want to install Barracudavpn Client. Install process is all good but when I run barracudavpn, It got an error:

*** buffer overflow detected ***: /usr/bin/barracudavpn terminated
======= Backtrace: =========
======= Memory map: ========
00400000-0099c000 r-xp 00000000 fe:00 161963                             /usr/bin/barracudavpn
00b9b000-00be3000 rw-p 0059b000 fe:00 161963                             /usr/bin/barracudavpn
00be3000-00bfe000 rw-p 00000000 00:00 0 
01e18000-01e8c000 rw-p 00000000 00:00 0                                  [heap]
7f4825264000-7f4825266000 rw-p 00000000 00:00 0 
7fff06c32000-7fff06c54000 rw-p 00000000 00:00 0                          [stack]
7fff06cab000-7fff06caf000 r--p 00000000 00:00 0                          [vvar]
7fff06caf000-7fff06cb1000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 --xp 00000000 00:00 0                  [vsyscall]
[1]    62419 IOT instruction (core dumped)  env TERM=xterm /usr/bin/barracudavpn

I tried install from AUR and convert from .deb file from official site but still got the same error.

I really need this one for my job, please help me.

https ://
Image for more details (please remove the whitespace). I don’t know why can’t I embedded image or link in the post itself.

How to post links when the forum software tells you that you can’t as a new user.

There are two versions of it in the AUR - the barracudavpn-bin uses the .deb package version from the supplier.

AUR (en) - Packages

1 Like

Have you tried installing barracudavpn-bin from the AUR? barracudavpn has been out of date for months.

1 Like

Thanks @Nachlese and @Yochanan for quickly respond.

I don’t see any package named barracudavpn-bin in AUR, how can I install it?

@Nachlese @Yochanan I installed barracudavpn-bin by yay

yay -S barracudavpn-bin

Still got the same kind of error.

I’m running kernel 5.19, Is it the cause?

According to your next post you found barracudavpn-bin.

Out of curiosity I would like to test to see for myself - but I can’t as the software download requires an account, which I do not have.

If your system is fully up to date (is it?)
there can still be a difference between Manjaro and Arch package versions if you are on the stable branch of Manjaro.

I can’t help.

except perhaps with this:

if you look at the PKGBUILD - what it does:

  • the .deb package is extracted/unpacked
  • the contents of it (of the data.tar.xz archive inside it) are extracted
  • this is then installed (copied to) /usr/bin - instead of /usr/local/bin where the Debian package manager would put it

It’s quite easy to do that by hand - with the caveat that your package manager would not know about it.

But that is where these files should already be after your successful installation.
Why it doesn’t work but dumps core instead: I don’t know

Thanks for your response, I have no idea why I got this problem. It’s kind of weird, I did a lot of research but haven’t found any solution yet. I think maybe the main cause belong to new kernel that I’m using (5.19)

Exactly what I thought, the problem belong to newest kernel (5.19), when I switched back to 5.15, it worked like a charm. Thanks for reply my question.

I need to say that barracudavpn Client is not stable when running in Manjaro, it works well for the first time whenever the system is rebooted, but then I try another time (in the same session), it still got the error above.

I don’t know where is the root cause of this problem. However, it seems like not many people in the Manjaro community using this software.

I’m thinking to another solution to solve my problem that I need to run barracuda as my job’s requirement.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.