Problem with the mouse cursor

I too have this problem. I am running Gnome (Testing) under Wayland. I have a low cost Nvidia card and use the open source driver. If I use kernel 5.11.1 or 5.11.2 then the cursor is deformed into a skeletal affair (quite ladder-ish), narrow, vertical and about twice the normal height, which changes shape as the cursor changes shape (arrow, hand etc) or when I try a different theme.

If I log into Gnome under Xorg, the problem is immediately resolved. Since Wayland is one of my motivations for using Gnome, this is not my preferred solution! So far I revert to using 5.10.

Sadly a screenshot does not help. The screenshot program substitutes a correct cursor.

Hope this helps.

Look at it in full screen not in a small window, the resolution issues will disappear.

I don’t really understand what bkarlan is saying. The pointer issue persists regardless of window boundaries. Screenshot corrects the pointer in a full screen shot, with or without windows present.

I don’t really think wishful thinking will cure this problem. There is a hiccup somewhere in the 5.11/Wayland/Nouveau environment. It does not exist under 5.10 nor under Xorg.

Just to confirm: Kernel 5.11.5-1 still has this anomaly.

It might be worth mentioning that the ladde-rish cursor is virtually unusable. This is not just a cosmetic problem.

This is more than just a Manjaro/Gnome/Wayland problem. It is present on openSUSE Tumbleweed/KDE/PlasmaX11 also. It isn’t window manager specific, same results with KDE, IceWM and TWM. The other thing I have in common with @bobwad is an Nvidia graphics adapter - mine is a Quadro K1100M.

The messed up cursor is present at the login screen before the desktop is loaded and as @bobwad said it’s way more than a cosmetic issue. Changing the cursor theme and/or size makes no difference nor does changing the theme.

Is it maybe an issue with nouveau and kernel support? With libdrm_nouveau2 v.2.4.104-3 the cursor is messed up when booting with kernel 5.11.xx, displays correctly with any previous 5.10.xx or older version.

I would attach images of what an arrow, hand, and text cursor look like but it says I can’t embed media items in the post. I’d make them links but it says I can’t do that either :frowning:

If you’re not yet allowed to post links, wrap the link in single backticks. Like


will render as

Hope this helps!



1 Like

Thanks for the help @Mirdarthos.

arrow cursor:

hand cursor:

text cursor:

Yes, that’s it.

I just tried 5.11 under Onara and it’s still the same ladder.

Can confirm with gnome manjaro and 5.10.
I do have a nvidia k1100m with open source driver running.

You are having the ladder issue on 5.10? Had you installed 5.11 at any point?

It’s a known problem,
The fix should start showing up in later versions of the kernel - 5.11 for openSUSE, not sure about Manjaro.

For those experiencing this issue, is it feasible to test this using the proprietary nvidia driver (or switch the display to use the Intel card, if applicable)?

I know that if I try to use the Nvidia drivers, I’ll never boot back into the GUI.

Switching to the proprietary nvidia driver will not allow you to login to your GNOME / Xfce session?

If you want to keep using the nouveau driver, looks like a fix is coming for Linux kernel 5.11, as posted by @therapon above.

That is correct, if I try the Nvidia drivers, I’ll have to reinstall the OS completely as I’ll just have a blank screen and I’m not a programmer so the only option I know of is to reinstall and never use the Nvidia drivers again. I’ve tried it several times.

I can run 5.11 in Manjaro KDE without any problems. BTW, I cannot run the Nvidia drivers in KDE either as it also won’t ever boot into the GUI.

Good news - for me, at least.

I have installed Linux 5.12 and the cursor i just fine with Gnome and Wayland. :grinning:

Thank you to whoever that was.

I have been running 5.11 since the update about a week ago and the ladder issue has disapeared.