Error activating XKB configuration - Cinnamon 4.8.6



First of all I’m aware of all the topics that talk about this issue (69108, 43831, 51718, 52490, and 45150), but none of them include a solution to my instance of it.


I have 2 keyboard layouts installed: “English (US)” and “Spanish”, I’ve installed “English (US)” when I installed the system and “Spanish” through “System Settings” => “Keyboard” => “Layouts”.


Sometimes when I boot up the computer and log in an error message appears reading:

Error activating XKB configuration
There can be various reasons for that.

If you report this situation as a bug, include the results of
xprop -root | grep XKB
gsettings get org.gnome.libgnomekbd.keyboard model
gsettings get org.gnome.libgnomekbd.keyboard layouts
gsettings get org.gnome.libgnomekbd.keyboard options

Here’s the result of those commands:

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = “evdev”, “”, “us”, “”, “”
_XKB_RULES_NAMES(STRING) = “evdev”, “”, “us”, “”, “”

gsettings get org.gnome.libgnomekbd.keyboard model

gsettings get org.gnome.libgnomekbd.keyboard layouts
[‘us’, ‘es’]

gsettings get org.gnome.libgnomekbd.keyboard options

If that message does appears:

  • I would only have the default keyboard layout installed (“English (US)”) under “System Settings” => “Keyboard” => “Layouts”.

  • The lightdm greeter displays the text “us” next to a keyboard icon:
    If the message does not appear:

  • I would have both “English (US)” and “Spanish” as installed keyboard layouts.

  • The lightdm greeter displays the keyboard icon but no text next to it:

  • Running xprop -root | grep XKB now outputs this:

_XKB_RULES_NAMES_BACKUP(STRING) = “evdev”, “pc105”, “us,es”, “qwerty”, “grp:win_space_toggle”
_XKB_RULES_NAMES(STRING) = “evdev”, “pc105”, “us,es”, “,”, “grp:win_space_toggle”

  • All other commands return the same outputs.

Running the following command does fix the issue whenever it happens:

setxkbmap -model pc105 -layout us,es -option grp:win_space_toggle

However I shouldn’t have to manually run a command (or add it to the .bashrc file) for keyboard layouts to work.

Restarting the system does fix the issue sometimes.

I did reinstall the whole system the first time this happen to me, the results were the same (won’t do that again at this point).

I had Manjaro installed on this machine before with the same keyboard layout config and without any issues.

System info

  • Desktop: Cinnamon 4.8.6
  • Kernel: 5.4.124

Any help or pointers on what could be causing this would be greatly appreciated.

inxi output:

  Kernel: 5.4.124-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=df7a105e-6ebc-4a94-bb06-ba9156e9161c rw quiet apparmor=1 
  security=apparmor resume=UUID=bd9d7dac-f62e-4ec5-bc1d-7a6957726858 
  Desktop: Cinnamon 4.8.6 tk: GTK 3.24.29 vt: 7 dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 20NB001SUS v: ThinkPad E590 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20NB001SUS v: SDK0J40697 WIN serial: <filter> 
  UEFI: LENOVO v: R0YET36W (1.19 ) date: 10/21/2019 
  ID-1: BAT0 charge: 23.8 Wh (61.0%) condition: 39.0/45.7 Wh (85.4%) 
  volts: 12.3 min: 11.1 model: Celxpert 01AV448 type: Li-poly serial: <filter> 
  status: Charging cycles: 230 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M560 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  RAM: total: 15.36 GiB used: 6.77 GiB (44.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: DE cache: L2: 8 MiB bogomips: 32012 
  Speed: 829 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 829 2: 841 3: 900 
  4: 868 5: 833 6: 890 7: 806 8: 851 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
  popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss 
  ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc 
  tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300 
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 1-6:4 chip-ID: 5986:2113 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.2 
  direct render: Yes 
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.4.124-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 2000 
  bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp4s0 state: down mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 2000 
  bus-ID: 05:00.0 chip-ID: 8086:2526 class-ID: 0280 
  IF: wlp5s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: br-5c6b28891bc3 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IF-ID-2: br-73a94807038e state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IF-ID-3: br-799aab51ed78 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IF-ID-4: docker0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Permissions: Unable to run lvs. Root privileges required. 
  Message: No RAID data found. 
  Local Storage: total: 476.94 GiB used: 281.52 GiB (59.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 rotation: SSD serial: <filter> rev: 0108ADLA scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 459.75 GiB size: 451.53 GiB (98.21%) 
  used: 281.52 GiB (62.3%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: df7a105e-6ebc-4a94-bb06-ba9156e9161c 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: 4879-6B7A 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.89 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: bd9d7dac-f62e-4ec5-bc1d-7a6957726858 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52b class-ID: 0300 
  Device-2: 1-6:4 info: Acer SunplusIT Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 5986:2113 class-ID: 0e02 
  Device-3: 1-8:5 info: Synaptics Metallica MOH Touch Fingerprint Reader 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 06cb:00a2 class-ID: ff00 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 45.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 3300 
  Processes: 289 Uptime: 2h 04m wakeups: 8 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1475 lib: 474 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.04

Thank you for your time :slight_smile:

Hi @ferares, and welcome!

While I don’t think I’ll be able to help, I can point you here:



Hello, I had they same problem and similar results with posted fixes. This worked for me; go to etc/default/keyboard and make sure XKBMODEL=“pc105”. mine had the quotes but no model. of course pc105 would be different for a different keyboard.


@Mirdarthos Thank you for the guides, I’ve updated my post accordingly.
@laja I’ve tried your solution the last couple of days and it seems like it works!, I’m not 100% sure the problem is gone since it’s an intermittent issue but I’ll mark your answer as a solution for now, thank you so much!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.