Manjaro installation on an existing encrypted partition

A. “Introduction”.

Hello everybody! I’m pretty new to using Linux systems and my knowledge of this topic is not very good yet. I am trying to install Manjaro KDE Plasma Edition version 21.0.2 from a USB 2.0 stick in UEFI mode, which was burned with belenaEtcher v1.5.117 on Windows 10 Enterprise LTSC x64 (SHA1 hash and GPG signature of ISO file are correct and were verified by me). I want to manually create the required for Manjaro installation disk partitions and, if possible, manually encrypt the future “root” partition with some custom encryption options.

B. “Disk Partitioning”.

For this purpose, I booted into a live system on USB flash drive in UEFI mode and installed gparted via Console:

sudo pacman -Sy gparted

In gparted I created:

  1. 512 MiB GPT disk partition with the FAT32 file system and assigned boot and esp flags to it, label “EFI”, for Grub bootloader;
  2. 256 GiB GPT disk partition with the BTRFS file system, label “Manjaro”, for Manjaro installation.

In my disks configuration EFI partition is /dev/sdb3 and Manjaro partition is /dev/sdb4.

C. “Encryption”.

After that, I ran the following commands via Console to encrypt Manjaro partition with some custom options and create BTRFS file system:

  1. sudo cryptsetup luksFormat --type luks1 -c aes-xts-plain64 --key-size 512 --hash whirlpool --iter-time 10000 --use-urandom /dev/sdb4

#Encrypts /dev/sdb4 to LUKS1 partition with aes-xts chiper, 512b key size and Whirlpool hash algorithm;

  1. sudo cryptsetup open /dev/sdb4 Manjaro

#Opens encrypted LUKS1 partition /dev/sdb4;

  1. sudo mkfs.btrfs /dev/mapper/Manjaro

#Creates BTRFS file system inside encrypted LUKS1 partition /dev/sdb4.

And now I want to install the system via Calamares v3.2.37-1, but I don’t know how to do it.

D. “Installation”.

I) In the first case, when LUKS partition is opened via Console, Calamares sees BTRFS partition in /dev/sdb4 - exactly the partition where I want to install Manjaro.
In Calamares I’m using “Manual Partitioning” option and assign following Mountpoints to my partitions:

  1. /boot/efi for dev/sdb3 (as recommended in Manjaro User Guide);
  2. / for dev/sdb4.

After completing the setup configuration and proceeding to the system installation (pressing “Install” button in latest overview dashboard where changes not yet applied), almost instantly, I got error message:

Boost.Python error in job "mount". Command '['btrfs', 'subvolume', 'create', '/tmp/calamares-root-opi6ewy8/@']' returned non-zero exit status 1. None.

After pressing “OK” button Calamares closes without completing the installation, and LUKS partition closes too.

II) In the second case, when LUKS partition is not opened via Console, Calamares sees LUKS partition in /dev/sdb4, but not BTRFS file system - this is logical, but I’m not sure if the installation can be continued this way, because the partition is encrypted (I have not tried this).

E. “Conclusion”.

All described above has led me to a dead end and I do not know what to do. Please, explain to me what I must do to achieve the described goals, maybe in some other way than that I tried to do it. Thank you so much if you have read up to this point! I will be very grateful for any help in solving my problem. If you want to help me, please try to describe everything in as simple and understandable language as possible (I’m very new to Linux). I understand English and Russian languages, here is my Telegram username, in case if it is more convenient for you to write to me in it: @hotcapy.

F. “The Purpose”.
I want to install Manjaro Linux to BTRFS file system inside encrypted LUKS1 partition with aes-xts-plain64 chiper, 512b key size, Whirlpool hash algorithm and the number of iterations corresponding ~10 seconds passphrase decrypt time.


Can you perhaps edit your post from the “wall of text” it is now to be a little bit more readable?

Put some linebreaks in, create some structure, paragraphs …

As it is, it’s almost impossible to read.


Hello, @Nachlese!
I am really sorry for the original version of my post.
It was my first post and I tried to describe my situation in as much detail as possible to make it easier for forum users to help me, but I completely forgot about a convenient and readable design.
I edited my post and tried to structure the information in it and highlight the important parts.
I really didn’t want to make it difficult for you. I’m sorry again.

If there is no other solution here, could this be a workaround to install Manjaro on BTRFS partition without encryption, copy all it’s files to elsewhere, encrypt partition manually and then paste files back? What else I will have to do in this case, maybe some edits in Grub config files to make new partition configuration work?

I just got a btrfs partition running with luks encryption a few days ago using the steps, here.

Only a couple of hiccups. It took a couple of tries, but I eventually got it. Not sure if it had something to do with my wifi… I was plugged into the ethernet when I finally got it to work.

It does use architect, and is therefore a bit more advanced, but the instructions are complete and very well written.


:+1: Welcome to Manjaro! :+1:

Please read this:

1 Like