Pamac has fewer packages to update than CLI pacman

I am still fairly new to Manjaro and was wondering, why does “Add/remove software” (pamac) show only some updates, while sudo pacman -Syu shows many more?
Also, even if I answer “No” in CLI, then reopen pamac, there’s no change.
Are some minor update types not shown in pamac?
I’d include a screenshot but it doesn’t let me embed it or even paste a link here :expressionless:


Follow this to share that information. Also explains why you can’t share links yet.

I’m quite curios, because pamac should actually show same number of packages as pacman, except when AUR is enabled, so pamac would show more …

May be that will solve your problem :

  • in Pamac, clic on the icon on the right,
  • then “Actualise database”.

Ok, thanks :slight_smile:
Here it is:

I tried it now. But the system is updated so I can’t tell if it made a difference. Will see in the coming week :slight_smile:

Also, I think this problem started when I “updated the mirrors” (something I was unfamiliar with coming from Ubuntu). And I did that because some package updates could not be downloaded, because their sources were unreachable.

Sadly recently pamac has had issues (at least for me) downloading the databases from repositories that tell the system what upgrades are available. It will leave a .part file in /var/lib/pacman/sync meaning it didnt download the whole thing. Pacman on the other hand has no issues like this, and always seems to download all the database files.
Thats the likely reason you will see more updates with pacman. Its gotten to the point I only use pacman now.

use bmenu - chose package manager ui from main window
run maintain system and then update system
enjoy your pamac working right

That shows also the Ignored list, so you musth have some packages in there … and also flatpaks … not sure what to make of it, because there is nothing related to Ignored packages update in the CLI.
So, you might want to decide if using Pamac UI or pamac cli or pacman (but not all of them simultaneously) to do a proper update, reboot the system and see if there you can notice any inconsistencies after that.

My Flatpack Updates wont update (won’t show up) with Pamac UI, i had this issue since around 2-3 month.

I had to use this command to update my Flatpack stuff:
flatpak update --system

Did you report the issue?

@bogdancovaciu , only Google Chrome from AUR is ignored, since the build process is clearly busted. And since on the screenshot “All” is selected, there are no more packages in queue.
Doing a full system update with pacman and restarting did not help. I’ve done it about 2 weeks ago. Then I was suspicious how come so few updates from the repos were available, since usually there was something new almost daily.

@scorpp13 , well, I tried that. Maybe this error message can be of use?

 checking systemctl ...
  The following systemd service(s) have failed. Please fix them manually. 
  Display detailed information about a systemd service with: systemctl status <SYSTEMD SERVICE NAME> 

  UNIT                   LOAD   ACTIVE SUB    DESCRIPTION            
● pkgfile-update.service loaded failed failed pkgfile database update

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.

You mean on unstable branch there is something new almost daily … How often did you switched branches?
This is how you find out from terminal on what branch your system is set now:
pacman-mirrors --get-branch

Nope, I’m on stable.
Maybe I overstated but they are available pretty often, so much that I noticed when there were far fewer :slight_smile:

On stable branch there can’t be more system updates than the announcements are

and prior to that there was the 2022-07-29 update …

If you refer to some AUR packages, yeah, that can happen, and if you refer to snaps or flatpaks that can happen too, but none go with a predefined pattern of updates.

I only created this Topic in June, where no one answered:

@bogdancovaciu , ok, however my suspicion was confirmed when I tried manually checking for updates through pacman. This happened to me twice and not only last time, when I decided to post it.
Maybe the thing I did by @scorpp13’s suggestion will help. I’ll see what happens.