XFCE Panel Status Tray Menu Location, still unresolved

I have the same problem like in thread [XFCE Panel Status Tray Menu Location] and the marked solution does not work in my case. Sorry for reposting but I can not append any comments there.

Does anyone else has this problem or another idea or solution to this problem?

Can you illustrate?


MS Teams is a good example:

  • I hover over the Teams icon in the panel
  • I press LMB
  • Menu opens, hovering over “Beenden”, which means quit
  • I release my LMB, but the DE interprets this as another click and immediatelly quits my Teams client
  • One workaround is to release the left mouse button very quickly (double click delay?), so that the app doesn’t quit and the menu is still open and usable, but this can not be an acceptable solution!

This is very annoying in my daily work and I hope someone will read this and give some workaround for this.

A few ideas:

  • do you have the same issue with other themes?
  • can you check the panel is actually at the very bottom of the screen?

Vaniila xfce uses main panel on top not on bottom like manjaro does. This can invite some irritations, i.e. notifications in the tray are not visible because they are shown “under” the panel.
So, try with panel on top as a workaround, if you are fine with a slightly different look.

@maycne.sonahoz @banjo: Thanks alot for your input and ideas. I tried them all and played around with several panel and display settings and I somehow fixed my problem. My findings:

  • Same problem with other themes. I’m using one of the default themes which ships with Manjaro. Themes seems unrelated to this issue
  • Panel was already at the very bottom, although the problem definitly occurs if I place the panel somewhere in between top and bottom. So panel and menu overlaps in that case which might make sense for that usecase
  • Putting the panel on top didn’t solve the overlapping problem either. Anyways, thanks for the historical explanation which sounds comprehensible

So, the problem occurs particularly on my external monitor. I toggled several settings in display settings and also panel settings. It’s working now. No overlapping between panel and menu anymore. I bet I can reproduce it again if I a play around more, so there is a bug when using external monitors.

I leave my settings like that for now and in case it occurs again, I now know how to possibly work around it.

Update: A couple minutes later and the icon menus appear now on the other screen. Quickfix: Panel preferences > Lock panel: Off

1 Like

Can you please detail? For future reference.

Sorry, I can’t exactly. I guess it was something with:

Panel Preferences:

  • General > Output (monitor switching)
  • Lock Panel (did help!)
  • not sure if other settings helped

Display settings:

  • Primary Display toggle
  • Scale
  • display arrangement in general