Connection to HDMI make the system freezing

Good evening,
I have a problem which I can’t solve, even after browsing the web during a lot of hours :

I have a second screen plugged to my computer on the HDMI port, but when I try to activate it with xrandr, all the system freeze :

xrandr --output HDMI-1 --auto --left-of eDP-1

When I tried this on Debian based system, it worked, but on arch based or fedora system, it never worked. After entered the command, the two screen became dark and the system is unresponsive (I made a script to shutdown the computer 1 minute after HDMI is plugged and the script not worked in this case).

What can I do to use my second screen over HDMI ?

If this can help you to help me, I have an Intel GeminiLake as GPU and mhwd -l provide this kind of information :

> 0000:00:02.0 (0300:8086:3185) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Hi @1m70deter, and welcome!

While I know this might be above me and I have absolutely no idea what the reason is, or could be, I can point you in this direction:

And, if applicable: [HowTo] post screenshots and links

Hope you manage!

@Mirdarthos I read your link and I’m very sorry to not gave enough information.

So, I tried to read logs file but :

dmesg | less

don’t keep logs after rebooting the computer, and, as I say, I have to reboot my system because it’s frozen.

journalctl doesn’t mention any critical error with display or xrandr.

If you want a description of what I’m getting (maybe it can help you) :

The two screen are enabled and the one on the right is wired to the second on the left. As you can see, both don’t show any information and are just black but enabled.

For understanding, I tried the same operation (displaying on two screens with HDMI) on an other HP computer with the latest version of Manjaro, on the same window manager and it worked. It’s only with my computer that it doesn’t work and I don’t know why…

I hope I provided enough information about this problem (also sorry for long time to reply)