PgAdmin Stuck at ```starting pgAdmin4 server```

I’m a newbie and I’ve just finished installing PostgreSQL in my system. I can run psql commands in the terminal but pgAdmin is refusing to start. It’s just stuck at this screen. Did I miss something?

1 Like

Hi @pecmun,

  1. How did you install it?
  2. Please see [HowTo] Provide System Information and, if applicable, [HowTo] post screenshots and links.
  3. Did you check PostgreSQL - ArchWiki
  4. Have you tried starting it from the terminal to see if it outputs any errors? Either way, please do so and provide any output you get.
1 Like

I installed it using
sudo pacman -Sy pgadmin4
I tried running it from the terminal but the result is the same.
The output is

QCoreApplication::applicationFilePath: Please instantiate the QApplication object first
QCoreApplication::applicationFilePath: Please instantiate the QApplication object first
Semaphore name: "pgadmin4-wintaa-a59283b86ae8ae85d20fdf770d799dd7-sema"
Shared memory segment name: "pgadmin4-wintaa-a59283b86ae8ae85d20fdf770d799dd7-shmem"
Python path:  "/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/lib/python3.9/site-packages" 
Python Home:  "/usr/lib/python3.9"

Yes, I did check the ArchWiki page but followed a tutorial from a different site but had similar steps in it.

I am totally unsure and might be completely wrong, but I think that might be the/one of the reasons why. a Lot of packages became problematic/unusable due to a python upgrade and needs to be rebuilt. I don’t know, let me ping @Manjaro-Arm to look, because:

  1. It might be why; and
  2. I don’t know who else.

Try removing it with pacman and then reinstalling it with pamac instead of pacman. Seeing as pamac already takes care of so much more than pacman for you, that might be all that is neccessary:

sudo pacman --remove pgadmin4
pamac install pgadmin4

We don’t have the python 3.10 yet, so it’s not because of that.

And if the above is the only output the application gives when launched, I don’t see any errors or warnings, so no idea what’s wrong.

But @pecmun did you update the system aswell when you installed pgAdmin4? Using -Sy is not recommended and can lead to partial updated systems.
Run sudo pacman -Syu to do an update.


@Mirdarthos uninstalling and reinstalling pgadmin4 didn’t work.
@Strit Uhh yeah I ran sudo pacman -Syu and it says there is nothing to do

Then I have no idea what else could be the matter.


pgadmin4 no longer works on Manjaro for quite some time. It’s a known issue (see below). You can use dbeaver instead.