Can't control fan speed; no span indication with inxi -F, nor with sensors

Manjaro XFCE 22.1.1
Kernel 5.15.104

Hi, my fan is running at max speed with no need, how can I control it?


sensors -version
sensors version 3.6.0+git with libsensors version 3.6.0+git

$ sensors
Adapter: ISA adapter
Package id 0: +39.0°C (high = +86.0°C, crit = +100.0°C)
Core 0: +32.0°C (high = +86.0°C, crit = +100.0°C)
Core 1: +38.0°C (high = +86.0°C, crit = +100.0°C)

Adapter: ACPI interface
temp1: +38.0°C (crit = +125.0°C)


Hi @artofit,

In general fans have speed controls on their pedestals.


Unless you mean your computer’s fans…in which case, we need to knows more. Please see here:

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

If your motherboard support PWM, then you should be able to use pwmconfig to configure it and fanspeed to manipulate it, however in most cases it is only controlled by your UEFI and you can only change such things there. Sometimes you can disable automatic fanspeed in the UEFI and manage it by the OS, but that are rare cases where it is possible.

/usr/bin/pwmconfig: There are no pwm-capable sensor modules installed



It would seem your motherboard does not support it. Perhaps, I don’t really know, you can try Powerdevil:

pwmconfig is an outdated tool. It can’t detect some new sensors.

I had the same problem as you. sensors output only contained information from acpitz-acpi-0 and coretemp-isa-0000.

In my motherboard’s manual I found that it was equipped with Nuvoton NCT6687D-M sensor. Then i installed kernel module nct6687d-dkms-git for that sensor. And now sensors provide a lot more information including fan speed, which in turn enables utilities such as fanspeed to be used for fan RPM control.