Gnome Display Manager Doesn’t Start

Yesterday I accidentally almost deleted my /var folder, I tried to “undo” it but I thought nothing was going to happen because at this point nothing had changed in the system but today when I tried to restart the system it hangs at “Stopped GNOME Display Manager
Starting GNOME Display Manager”
And never starts, I also can’t run any commands. Could someone help me, please ? (I tried to attach a picture of the screen but for some reason I can’t do it)

ctrl+fn+f2+alt to switch to tty2 and login there and enter sudo systemctl restart gdm.service

Thanks for you answer. So, when I open tty2 it doesn’t allow me to type any command, it just appears a blinking underline and when I try to type nothing happens

in that case try to switch between ttys with ctrl+fn+f3+alt so on

I found one I can see what I’m typing but no commands are working. When I press enter it just breaks a row

please share a screenshot here. upload it to imgur and share link

https ://paste. pics/d2ba9ddf68fc4725ae0dbaf8aeaa51b6

use the installing medium for manjaro (usb stick). poweroff off the system and reboot to the live session.

sudo su -
manjaro-chroot -a
systemctl enable gdm.service
pacman -Syyu
systemctl reboot

remove the usb and try to boot into your existing system

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.