Install Manjaro on VMWare Fling

Has anyone tried to install Manjaro with this:

I can’t move forward because pacman does not work. Internet is fine because I can ping IP numbers but not hostnames. I tried to change /etc/resolve.conf with no success.



So what image did you use?

Sounds like you are not getting DNS.

1 Like

Hi @ebiscaia, and welcome!

  1. You’re probable wondering what’s going on since you can’t post links. Have a look here: [HowTo] post screenshots and links

  2. That sounds like a DNS issue, right there. I have absolutely no idea what your settings are or if you can change them, so can’t help you with that. I can just tell you to double check your DNS settings.

I doubt it will, but I hope it helps!

1 Like

it’s resolv.conf without e and that is just a temporary measure until your next boot to test., not a permanent workaround as that gets overwritten by NetworkManager nowadays.

Better to test this way:

  1. open a terminal and type:


    then type:


    please post the output of that.

  2. What are your NetworkManager settings?



I used this one: and then converted to vmdk.

You are right. It was a typo.

nslookup: command not found

When I ping, I got 0% of packet loss, but when I ping
Temporary failure in name resolution.

Thanks everyone

My bad! :sob: I’m so used to having it available that I forgot to tell you to execute:

pamac install dnsutils

Then try nslookup again.

You also didn’t provide any answer to:



The problem was I couldn’t install or update the system. But that was solved by using
echo 'nameserver' > /etc/resolv.conf. I still had a problem with the keys, that I also overcame.

Now, it is requested to install two packages. I managed to install and configure grub, but what about linux-image-arm64? It seems to be is a debian package, so is there any Arch equivalent?


I’m sorry, but that is an entirely new question and though I can help with generic network issues, I’m not specialised enough to answer that new question…


It would be rather strange if an Arch based system would request you to install a Debian package.
… although the package might use a Debian package

Why do you think it want’s to use an unsuitable package?

I have not ever used Manjaro ARM or Arch ARM …

I will try following some Arch installation tutorial to figure out which packages need to do so.

1 Like

You will have to update grubs default configurations as our kernel is using different naming convention for kernel file and initramfs.

Next you should use linux and linux-headers as these are pure upstream kernel.

Btw I doubt fling will be able to find and efi without an esp partition but you can try installing efitbootmgr

I will try to write a guide to get efi and grub support on manjaro plus I have to update grub package and locally maintain it for Manjaro as the current package is from Arch Linux Arm.

Feel free to ping me for anything you need to test manjaro on fling.

@spikerguy, that would be great. Lemme know when you finish it and I give it a shot.

Not anytime soon, I will be on vacation from this weekend so won’t be working in pkgs much.
I will be back in August.

All good. Enjoy your vacation