[SOLVED] Display Manager stopped working after package update

Hello guys,

I have Manjaro Nibia (KDE) installed in my PC. I have downloaded the retroarch package (from the official repository) and then pamac asked for a reboot.

Since then, the Login Screen does not launch and I am stuck in a black screen.

I can access the tty console and tried some attempts to make It work again.

What I have already done:

  • updated the package manager mirrors list:

sudo pacman-mirrors -f3

  • forced all packages to be updated

sudo pacman -Syyu

  • installed lightdm and switched the sddm to it:

sudo pacman -S lightdm
sudo systemctl disable sddm
sudo systemctl enable lightdm

I have attached some photos to show the messages from journal, some files and the screen where I am stuck.

[EDIT] I have noticed I can’t attach links or photos in this forum IDKW… If you know how I can post them here It would help…

Really appreciate some help!!

1- The SDDM service is actually active but I get these errors that doesn’t make my login screen to be displayed

2,3- Some files

4- The stuck screen (with SDDM)

5- The stuck screen (with lightdm)

Hi @chandlerkc, and welcome!

You are a new user, therefore not the required Trust Level yet.

Please see “[HowTo] post screenshots and links” for more information.

1 Like

thanks a lot!

I have posted the links with a “$” in the middle, guess it might work by removing the symbol now

You’re welcome!

Just edit the post to change the links and add a backtick (``) before and after it. For example:

done!! :smiley:

I saw in the screenshot you still have Linux kernel version 5.9 installed.

Please see this post from me, from a few minutes ago.

I have installed the kernel 5.4 (LTS):

When I reboot, I get:

The system still boots with the kernel 5.9, I cannot remove it when it is currently used

Yes, I suspect that is because the 5.4 version you just installed is an earlier version than the 5.9 you currently use. AFAIK GRUB will boot with the newest one. There are 2 approaches you can with after this:

  1. The first is slightly more involved.
    1.1. To use it, reboot your computer, but just after the BIOS output of “press button to enter bios” press Esc.
    This will bring up the grub boot menu.
    1.2. In that menu, use your arrow keys to navigate yo the Advaanced options.
    1.3. In the Advanced options, select kernel version 5.4 to boot into.
    1.4. If successful, uninstall 5.9 as previously said.
    1.5. Continue as normal.

  2. This method is slightly less involved, but requires another download, and if it doesn’t work, it is recommended to use the previous method to get a working system again.
    2.1. Open a terminal and install version 5.10.

sudo mhwd-kernel -i linux510

2.2. When done, seeing as GRUB should reboot into the newest kernel version, reboot and it should boot into 5.10.
2.3. Continue to remove kernel version 5.9:

sudo mhwd-kernel -r linux59

2.4 If desired, continue with kernel installations and modifications as required.

Hope this helps!

I wish it could have solved the issue… The problem remains

  • Changed to kernel 5.4 and removed kernel 5.9
  • Installed kernel 5.10
  • Neither with kernel 5.4 or 5.10 the Display Manager seem to work properly

I wish it would’ve solved it as well, that I promise you! Like I said, I don’t know if it would’ve worked or not, but at least now it’s ruled out.

Other than reinstalling SDDM I don’t know where to go from here:

sudo pamac rinstall sddm

It didn’t work…

I believe it is not the sddm problem itself but something related to the “Failed to read Display Number from pipe”.

I have searched for that but nothing seem to solve the issue

Well, that’s the first time I’ve seen the error, as well.

According to this page:


Thank you so much for your help!!

I followed the ‘disabling xorg before GUI startup’ under xorg wiki and set the kernel parameter to rescue.target, but it didn’t help.

Then I just renamed the xorg.conf file to xorg_bak.conf so it doesn’t load, and voila, it worked!!

Unfortunately, other than Googling, I have absolutely no idea, sorry.

1 Like


There was no Xorg.conf file in /etc/X11

but I did the same thing with the vesa.conf file in /etc/X11/mhwd.d

renamed it to vesa_bak.conf and rebooted, the problem was solved, thanks a lot!!

I’m very happy it worked! And you’re very welcome!


Did the system now recreate the /etc/X11/Xorg.conf file?

I’m just curios 'bout it. You could, and maybe should take a backup once everything’s working again.

No, I believe in my pc there wasn’t even a file like that earlier…

but the file 90-mhwd.conf in /etc/X11/xorg.conf.d was replaced by an empty file

Well, at least now you’ve got a working system again. And I believe that’s the important thing.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.