HP Envy x360 13-ar0022nn AMD Ryzen 5 3500U sound problem

Have you tried using pulseaudio instead of alsa? How does pavucontrol look?

yes, nothing was changed. Same output as alsa. I can choose from different profiles, like > analog surround 2.0 output to 5.1 output. That is only after I changed things in HDAjackretask. Before anything I had only analog stereo output

Support For AMD Renoir with a new driver was only available from June 2020 with v5.8 kernel
Linux 5.8 Sound Changes Bring New AMD Renoir ACP Driver - phoronix.com

This has the new driver snd_rn_pci_acp3x which appears to be the AMD equivalent of sof-firmware drivers for Intel laptops, supporting buit-in digital microphone array DMIC
Intel laptops needed the latest development version (13.99) of Pulseaudio to get recent patches for audio support
and Intel SoundOpenFirmware was released before AMD Audio Co-Processor

This from Arch forum confirms that latest version of Pulseaudio is needed for AMD
[SOLVED] Microphone not working on Thinkpad T14s / Multimedia and Games / Arch Linux Forums

so I recommend installing pulseaudio-git from AUR

Another Manjaro user posted recently that they had to remove packages
libao, fluidsynth, lib32-fluidsynth and manjaro-pulse to get pulseaudio-git installed
and then reinstall the packages again
HP Envy - Sound does not work in Manjaro 20.1 PLASMA
(I have also just noticed that manjaro-pulse is only a metapackage so installing it again is not really necessary)

I don’t want to draw to many parallels with Intel hardware, but pulseaudio 13.99 got a 4 speaker (and 4 microphone) Intel laptop working
Lenovo ThinkPad X1 Carbon (Gen 7) - ArchWiki
It might do the same for this hardware :crossed_fingers: but it should at least get you closer to a full working solution


Hi, thanks for your help.

I did this : uninstall alsa-tools
Removed : libao , fluidsynth , lib32-fluidsynth and manjaro-pulse

Installed pulseaudio-git and after reinstalled packages from above libao , fluidsynth , lib32-fluidsynth and manjaro-pulse

Than I did this :

  1. Install sof-firmware (tested with 1.4.2-1)

  2. Configure PulseAudio’s to load Alsa modules with the correct device and channel settings, by adding these two lines to /etc/pulse/default.pa :

load-module module-alsa-sink device=hw:0,0 channels=4 load-module module-alsa-source device=hw:0,6 channels=4

After reboot I dont have a sound. When I try to open volume control got message :

Establishing connection to PulseAudio.Please wait

What I did wrong ? xD

the extra changes in Archwiki link numbered 1-4 was an earlier solution without pulseaudio v13.99

installing sof-firmware is only needed for Intel laptops, but it should not harm system by having this installed

the two lines added to /etc/pulse/default.pa should not be needed

the commands to load sink and source modules are incorrect and are causing Pulseaudio to crash
sink device=hw 0,0 equates to card 0, subdevice 0 which on your system is the HDMI output
source ‘device=hw 0,6’ does not exist - HDMI card 0 does not have any audio capture subdevices

suggest you edit /etc/pulse/default.pa and remove the two additional lines

then reboot system

and post response to these commands

sudo alsa-info.sh --upload
pacmd dump



[marko@marko-hpenvyx360convertible13ar0xxx ~]$ pacmd dump
No PulseAudio daemon running, or not running as session daemon.

1 Like


Hi, what is the next step ?

Wait for him to catch up. He’s the resident sound expert and all and every complex sound issue (like B&O speaker) falls into his lap… :man_shrugging:

Have you tried starting pulseaudio manually on the terminal already and did that give you any visible errors / warnings???


I am no expert on this hardware, and I can’t find out much about it online yet

Archiwiki has some reports about AMD Raven laptops but just mention that audio works with the latest packages

Pulseaudio is not running (alsa-info data confirms this) and must be restored before continuing work on original problem with speakers

suggest uninstall sof-firmware and reinstall pulseaudio-git to clear changes made

and install latest v5.9 kernel
go to Manjaro Settings Manager manjaro-settings-manager -m msm_kernel and click Install

and also remove the home folder configuration for Pulseaudio

rm -r ~/.config/pulse/


and hope for better ALSA data and working Pulseaudio

Observations from alsa-info data

Onboard analog still only has one speaker output connection

!!ALSA/HDA dmesg

[   10.884149] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC285: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[   10.884152] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   10.884154] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)

Pin configurations in !!HDA-Intel Codec information show this for the ‘working’ speakers

Node 0x17 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out

  Pin Default 0x90170180: [Fixed] Speaker at Int N/A

  Connection: 3
     0x02 0x03* 0x06

and is showing a connection to

Node 0x03 [Audio Output] wcaps 0x41d: Stereo Amp-Out
  Control: name="Speaker Playback Volume"

so the most likely un-used connections for retasking
(all shown as Pin Default 0x411111f0: [N/A] Speaker at Ext Rear)

Node 0x16 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
   Connection: 2
     0x02* 0x03
Node 0x1b [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
  Connection: 2
     0x02* 0x03

less likely to be these, unless a connection can be made to 0x03 by retasking

Node 0x14 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
  Connection: 1
Node 0x1e [Pin Complex] wcaps 0x400501: Stereo
  Connection: 1

These have no Connections and appear to be inputs

Node 0x18 [Pin Complex] wcaps 0x40048b: Stereo Amp-In

Node 0x1a [Pin Complex] wcaps 0x40048b: Stereo Amp-In
1 Like

I did what you suggested to me .

Alsa-info output is here : http://alsa-project.org/db/?f=289265e75894b9b4f79533401f8edd32022f5d22

pacmd dump output is here :

marko@marko-hpenvyx360convertible13ar0xxx ~]$ pacmd dump

Configuration dump generated at Thu Oct 8 21:44:21 2020

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id=“0” name=“pci-0000_04_00.1” card_name
=“alsa_card.pci-0000_04_00.1” namereg_fail=false tsched=yes fixed_latency_ra
nge=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card
load-module module-alsa-card device_id=“1” name=“pci-0000_04_00.6” card_name
=“alsa_card.pci-0000_04_00.6” namereg_fail=false tsched=yes fixed_latency_ra
nge=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_04_00.6.analog-stereo 0xdce2
set-sink-mute alsa_output.pci-0000_04_00.6.analog-stereo no
suspend-sink alsa_output.pci-0000_04_00.6.analog-stereo yes

set-source-volume alsa_output.pci-0000_04_00.6.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_04_00.6.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_04_00.6.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_04_00.6.analog-stereo 0x2893
set-source-mute alsa_input.pci-0000_04_00.6.analog-stereo no
suspend-source alsa_input.pci-0000_04_00.6.analog-stereo yes

set-card-profile alsa_card.pci-0000_04_00.1 off
set-card-profile alsa_card.pci-0000_04_00.6 output:analog-stereo+input:analo

set-default-sink alsa_output.pci-0000_04_00.6.analog-stereo
set-default-source alsa_input.pci-0000_04_00.6.analog-stereo


I have sound now, but everything is as before… only 2 speakers available

Can you post a screenshot of all pins in hdajackretask, please?


Here it is

  1. Please read this:

Especially this:

Please make a screenshot of the relevant portion of the screen only!
(I.E.: don’t post a screenshot of the entire desktop to say that you have a minuscule button in the lower right edge of the screen that is turning red: take a screenshot of the relevant part only! )

:stuck_out_tongue_winking_eye: :crazy_face:

  1. You have a lot of unconnected pins. What is in the drop-down menu of location and device? (No screenshot! Type it before you post another 3 giant screenshots!)


1 Like

Ok, sorry… Got it now.

And sorry again, I went with screenshots, because list is long , haha, and I need to learn how to properly include all informations.



So what happens if you:

  • connect one of the unconnected pins to one of these,
  • install boot override,
  • reboot,
  • play

repeat for one unconnected pin until one of the speakers starts playing, then go onto the next unconnected pin.

Have you tried that yet? (I.E. Brute force attack)


That is a lot “reboots” :slight_smile:

Yeah, I know and why I posted this before the weekend!


haha, good move xD

but but, is there some quicker solution ? :stuck_out_tongue:

maybe something from this thread HP Envy x360 13-ar0022nn AMD Ryzen 5 3500U sound problem - #12 by nikgnomic

Because I have Manjaro installed on external SSd disk, and every boot is so slow. Reboot actually does nothing, i neeed to shut down laptop every time to be able to boot on external disk

Your original question was asked 8 days ago, so I’d say: We’ve tried all those already… and doing that won’t take 8 days…

:stuck_out_tongue_winking_eye: :crazy_face:

1 Like