Can't find option to activate AUR packages anymore

Dear manjaro users,

I recently started using manjaro after a long history of being a ubuntu user. Although not perfect, I like what I get so far.

Unfortunately I had to reinstall the whole distro a few days ago as manjaro wouldn’t boot into its window manager anymore (I think it had something to do with gnome extension manager which I messed around with before reboot).

Since my home folder was on a separate partition and contained a lot of important data and settings, I kept the home partition and just formatted the root partition to reinstall manjaro on it. I deliberately chose a different user name for manjaro to create a new home folder and not use the old one. Everything went well. After installation I copied some settings and configs from my old home folder into my new one (such as the .config and .local folder and some other app specific folders). I was quite happy with the results until I started installing my favorite apps.

When trying to activate AUR, I noticed that the option was simply missing in the preference of pamac.

(I tried to insert a screenshot here but it wouldn’t let me. Just imagine the preference window without the “AUR” tab but “General”/“Official Repositories”/“Snap”/“Flatpak”/Cache" still being there)

Does anybody know why this might be the case and how to solve it? I didn’t find a single entry on the internet with someone having this issue…

Thanks in advance!
(and a happy new year)

Hello and welcome.

Here you’ll find first some info about why you cannot post screens yet and how to overcome it:

Could you try if reinstalling pamac from terminal reactivates the AUR ?

1 Like

I removed and reinstalled:


The result remains… (According to your rules I will upload a screenshot if needed but there ain’t much to see apart from what I described in my first post)

Any other ideas?

Do you have Software mode enabled in Pamac?
Go into Pamac (Add/Remove softwares) and click onto the upper-right menu. If Software mode is checked, uncheck it and return into the preferences. AUR tab should be available again.


Yeah that worked! Thank You!

(I’m sorry if this solution was too obvious, don’t know much about AUR and Manjaro yet…)

1 Like


No, not obvious, it’s a very very new feature added in the latest version of Pamac in December, I’m not used to it myself.

Finally, you did’nt have to reinstall all Pamac packages, but no harm done anyway.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.
P.P.S. @Falav Could you edit that post and make it more N00b friendly in case someone else stumbles across this solution. (I.E. Provide exact steps???) :+1:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.