Screenshot sharing window while using different Screenshot tool

Hello Everyone,

I have just installed the latest Manjaro.

I wanted to use Flameshot as screenshot tool and that works as intended… Except…

When I try to take a Screenshot with flameshot a System windows pops up asking if I’d want to share the screenshot with the appication trying to use it. Is there a way to disable this?

If needed I can send you a Screenshot of the window I am talking about

Any help is appreciated. Thanks for reading.

why not use the built in screenshot feature for gnome :slight_smile:

Because I prefer flameshot :sweat_smile:

Welcome to the Forum :wave:
Please share the screenshot of the pop up window.

Thanks for the reply and thank you for the welcome msg :smiley:
This is the window I’m talking about. If I click on share flameshot’ll open and I can take the screenshot using flameshot. But I always have to share the screenshot through this window first.

Hi @stoffelcpr,

Please see

as well as

and edit your post accordingly.

Thank you. I was trying to find a post like this but the search failed me (or I failed the search).

I updated the post accordingly.

See this Flameshot - ArchWiki and/or this and see if it helps.

I tried the links and sadly none helped. It’s not really a flameshot issue. It’s not really an Issue at all. It’s the expected behaviour. I just want to know how to disable that default behaviour so I can have the system the way I want it.

Well, I can’t really recommend anything other than those links as I use KDE. So my suggestions are based on Googling.

See if this can help :point_down:

Maybe that way you can set the PrtScr to open Flameshot… :man_shrugging:

Yeah. Didn’t mean to sound offensive.

I already configured everything. The PrtScr key is already set to flameshot gui to use the flameshot app to take the screenshot. But when I use the print key it opens the window and asks me to share the screenshot with the app before flameshot opens.

This is what happens when I try to take a Screenshot.

This is what happens when I decline to share.

And if I do decide to share, like I said, Flameshot opens and is working as intended.

Thank you for your help though :sweat_smile:

No offense taken, relax Bro.

I looked around some more, and maybe this’ll help:

Original website:

If you need or want to replace the PrtScr shortcut do the following:

  1. Release the PrtScr binding by this command
gsettings set screenshot '[]'
  1. Go to Settings → Devices → Keyboard and scroll to the end. Press + and you will create custom shortcut.

  2. Enter name: “flameshot”, command: /usr/bin/flameshot gui.

  3. Set shortcut to PrtScr (print).

That is it. Next time you push PrtScr flameshot will be launched.

Sadly it didn’t work. I even tried to search for other schemas that may contain any screenshot related keybinds (I think Wayland is the one causing this window to pop up) But I couldn’t find any bindings

I’m all out of ideas, sorry!


1 Like

Np. Thank you :smiley:

1 Like

Okay so I finally found the right wording to google and found a reddit thread that linked me to a github issue.
TL;DR => This window was introduced to prevent arbitrary code execution and there’s already a feature request to give possibilities to prevent the window from popping up every time u want to take a Screenshot.

The issue is not yet resolved but the mere existence of the github issue renders my request for help on this forum done. Thank you all for your help :wink:

1 Like

try setting shortcut command to flameshot gui -p path_to_desired_location. i tried this and didn’t got any pop up window :point_down:

Hmm. I just tried it and sadly it doesn’t work for me.

I’ve got the newest Manjaro (21.2.1) maybe your Manjaro doesn’t have that safety feature yet? :sweat_smile: And gnome.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.