I'm stuck in emergency boot but I can't tell exactly what's wrong with my system

I dual boot with Windows and recently I had been messing around with my system’s partitions in order to expand my OS space. However, while doing that I accidentally deleted my GRUB partition, so I had to go ahead and remake the partition and reinstall GRUB. A few problems remained afterwards (like having to install plymouth) and this caused me to go into emergency boot. I was able to Google most of the problems but my system still goes into emergency boot. I can’t seem to find what the critical errors are (I don’t think missing Anbox files issues are preventing proper booting, correct me if I’m wrong) and the logs even say “System startup complete.” However, what I notice is that in emergency boot, iwd and a lot of other network services don’t work.

The pastebin link below is the resulting output of
journalctl -xb -0:

I’ll gladly provide any additional info that’s required.

Hi @Kibbles, and welcome!


If you are working on a dual boot system (Windows + Linux), an auto-mounted partition (in Linux) might still be locked by Windows (even if it is not the Windows system partition!).

Saw this in your log:

May 25 12:52:58 balu systemd[1]: Received SIGRTMIN+21 from PID 187 (plymouthd).

…leading me to this and this page.

So basically, I’d say check your mounts:

Boot into a live environment, mount you drive, edit /etc/fstab and ensure everything’s good. Also, if you dual-boot, boot into Windows and make absolutely, :100: sure it’s shut down properly. Not hibernated, or suspended, or anything like that, but shut down.

Hope it helps!

Sorry I’m actually relatively inexperienced with Linux still as I haven’t touched it in years before this incident. I forgot what a “proper” fstab file should look like. I’ve made sure to shutdown Windows though and here’s the fstab file for your viewing:

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=82C2-1C22 /boot/efi vfat umask=0077 0 2
UUID=d5528f8d-5693-407e-8482-7bc8cbba3e01 / ext4 defaults,noatime 0 1
none /dev/binderfs binder nofail 0 0

Also I should have probably provided this earlier but here’s my partition arrangement:

  • p1 - Windows bootmgr
  • p2 - Microsoft reserved partition (idk exactly what it is but my friend thinks it could be swap space)
  • p3 - Windows OS
  • p4 - Where I installed GRUB (boot partition, mounted on /mnt/boot)
  • p5 - Manjaro OS (root partition, mounted on /mnt)
  • p6 - Windows Recovery partition

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

From your first log output it looks like you’re using plymouth. Now, I’ve never used it, so don’t have any experience with it, but I have seen multiple issues it causes here, so I’d recommend switching to Grub again. Of course, someone else might say differently and this is only my opinion, but there it is.

To me, the fstab looks fine, so I can’t comment on that. Please also provide the output for:




Please also see:

The reason I have plymouth is because I was getting an error before about plymouth not being found and therefore being unable to be executed. I thought it was a part of grub and therefore expected it to be installed along with the grub package. However it wasn’t which is why I installed the package manually.

As for the outputs of lsblk and fdisk here they are


loop0         7:0    0  67.8M  1 loop /run/miso/sfs/livefs
loop1         7:1    0   1.2G  1 loop /run/miso/sfs/mhwdfs
loop2         7:2    0   1.7G  1 loop /run/miso/sfs/desktopfs
loop3         7:3    0 680.9M  1 loop /run/miso/sfs/rootfs
sda           8:0    1  28.9G  0 disk 
├─sda1        8:1    1  28.9G  0 part 
│ └─ventoy  254:0    0   3.7G  1 dm   /run/miso/bootmnt
└─sda2        8:2    1    32M  0 part 
nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   260M  0 part 
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0   378G  0 part 
├─nvme0n1p4 259:4    0   501M  0 part /mnt/boot
├─nvme0n1p5 259:5    0  97.2G  0 part /mnt
└─nvme0n1p6 259:6    0  1000M  0 part 


Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SAMSUNG MZVLB512HBJQ-000L2              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 102B78B7-7DFB-4D05-98E5-42F88D63D7BE

Device             Start        End   Sectors  Size Type
/dev/nvme0n1p1      2048     534527    532480  260M EFI System
/dev/nvme0n1p2    534528     567295     32768   16M Microsoft reserved
/dev/nvme0n1p3    567296  793362431 792795136  378G Microsoft basic data
/dev/nvme0n1p4 793362432  794388479   1026048  501M Microsoft basic data
/dev/nvme0n1p5 794388480  998166527 203778048 97.2G Linux filesystem
/dev/nvme0n1p6 998166528 1000214527   2048000 1000M Windows recovery environment

Disk /dev/sda: 28.91 GiB, 31037849600 bytes, 60620800 sectors
Disk model: USB Flash Disk  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x5b864f01

Device     Boot    Start      End  Sectors  Size Id Type
/dev/sda1  *        2048 60555263 60553216 28.9G  7 HPFS/NTFS/exFAT
/dev/sda2       60555264 60620799    65536   32M ef EFI (FAT-12/16/32)

Disk /dev/mapper/ventoy: 3.65 GiB, 3919218688 bytes, 7654724 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device                   Boot   Start     End Sectors  Size Id Type
/dev/mapper/ventoy-part1 *         64 7646531 7646468  3.6G  0 Empty
/dev/mapper/ventoy-part2      7646532 7654723    8192    4M ef EFI (FAT-12/16/32)

Disk /dev/loop0: 67.81 MiB, 71106560 bytes, 138880 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 1.16 GiB, 1245741056 bytes, 2433088 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 1.68 GiB, 1803116544 bytes, 3521712 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 680.89 MiB, 713961472 bytes, 1394456 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Am I correct in saying your Windows and Manjaro is installed on the same nVME drive, just different partitions?

Anyways, nope, I can’t see anything…

Ensure that Safe boot in your BIOS/UEFI is turned off, as well as fast boot (if you have it.)

Your ESP/EFI partition is not mounting. You have defined it in /etc/fstab with UUID 82C2-1C22, but logs show that:

May 25 12:52:57 balu systemd[1]: Timed out waiting for device /dev/disk/by-uuid/82C2-1C22.

You have to change it in fstab. List UUIDs with blkid

1 Like

Yes, Windows and Manjaro are both installed in the nvme0n1 drive with them being on partitions 3 and 5 respectively.

Here is the output of blkid:

/dev/nvme0n1p5: UUID="d5528f8d-5693-407e-8482-7bc8cbba3e01" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="5420714d-5c4f-fa4b-a772-a79e76a5c16b"
/dev/nvme0n1p3: LABEL="Windows" BLOCK_SIZE="512" UUID="38AA50FDAA50B958" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="83e28653-031a-48ff-9307-cf9a80d7dd0b"
/dev/nvme0n1p1: LABEL="SYSTEM" UUID="3A4E-43F9" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="b7ef1d52-2815-45e5-8375-285404653797"
/dev/nvme0n1p6: LABEL="WinRE_DRV" BLOCK_SIZE="512" UUID="949451039450E8EE" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="91470dc3-6779-4811-8a64-851f649f90ee"
/dev/nvme0n1p4: UUID="5C78-0CA7" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="f1e61686-d363-c545-95e4-7d82fe1a6876"
/dev/loop0: TYPE="squashfs"
/dev/sda1: LABEL="Ventoy" UUID="4E21-0000" BLOCK_SIZE="512" TYPE="exfat" PTTYPE="dos" PARTUUID="5b864f01-01"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/mapper/ventoy: BLOCK_SIZE="2048" UUID="2023-05-18-20-31-34-00" LABEL="MANJARO_KDE_2212" TYPE="iso9660" PTTYPE="dos"
/dev/sda2: SEC_TYPE="msdos" LABEL_FATBOOT="VTOYEFI" LABEL="VTOYEFI" UUID="83A6-E98E" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="5b864f01-02"
/dev/loop3: TYPE="squashfs"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="932e378f-5d7f-4eb3-863f-fa54c9aff8aa"

Ok. So you have to replace the old UUID (82C2-1C22) of ESP in /etc/fstab with the new one, that seems to be 3A4E-43F9


The new partition was actually p4 for GRUB, not p1 which is the Windows Boot Manager (sorry for not making that clearer) but after changing the UUID I’m able to boot properly again! Thanks for everyone’s help!

However there’s still an issue and I think it might be related to this. For some reason the boot process completely skips the menu and boots straight into Manjaro. I’ve looked online but all I find is to change GRUB_TIMEOUT_STYLE=menu and GRUB_TIMEOUT=5 inside of /etc/default/grub, but I’ve done that and it still skips. When I press esc to halt the timeout, the menu only shows Manjaro and just one kernel at that (linux510) when I do advanced boot options. I’ve used os-prober to detect Windows and it’s even in the config file after I ran update-grub.



The thing is that your ESP/EFI partition is the partition number 1 (nvme01n1p1). Your UEFI firmware is going to use that partition, because is the one marked with the right type. From your fdisk:

/dev/nvme0n1p1      2048     534527    532480  260M EFI System

So my guess is that your system is actually booting from there, but if you are mounting partition 4 in /boot/efi, then your update-grub is going to be useless, because that’s not the partition the firmware is going to notice. That partition 4 seems to be (at least was) the recovery partition for Windows.

Sorry for the very long reply time (I kept screwing things up but now I have them fixed). Turns out you were right, p1 is actually where I’m supposed to install grub. Now everything’s working like normal. Also, I deleted the kernels I got from the aur and their respective images since yay was giving me problems while in chroot.

Thank you guys so much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.