Secondary HDD stopped mounting. No mount point

I just lost my secondary HDD after a reboot. Five days ago an external HDD stopped functioning. Something doesn’t smell right! When I looked at it in KDE Partition Manager, it says it has no mounting point. When I try to mount it, I get this error:

An error occurred while accessing ‘New Volume’, the system responded: The requested operation has failed: Error mounting /dev/sdb1 at /run/media/steellaptop1/New Volume: Unknown error when mounting /dev/sdb1

I tried to force mount with this:
sudo mkdir /mnt/harddrive
sudo mount /dev/sdb1 /mnt/harddrive

And got this:
   ~  sudo mount /dev/sdb1 /mnt/harddrive  32 ✘
$MFTMirr does not match $MFT (record 3).
Failed to mount ‘/dev/sdb1’: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it’s a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
for more details.

I desperately need my data on this drive. I have a SSD for my OS, and the rest I put on this drive. I find it really odd that five days ago one of my 8TB External HDD’s stopped mounting as well.

Need help!!!

Usually a file system error.

If this is a hardware error - you should immediately disconnect the device - and consult a data recovery expert.

The system has identified the filesystem as NTFS.

If that is correct → follow the advise of booting into Windows and fixing the error.

If you don’t have Windows - use a Windows recovery tool - e.g. Hiren’s bootcd or similar tool.

I have a list of possible tools at Tools Overview |

Hi @Michael_St,

First, a

Providing terminal output

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.


  • do you have dual boot?
  • Did you shutdown Windows properly last time you used it, it you do??

Unfortunately I do not have Windows on this laptop. Do you know what would cause such an error? Two drives in a few days out of the blue? Actually, come to think of it. I did have to force it to shut down. I am trying out the free version of Proton VPN and it is playing havoc with my computer sometimes. Does not wan to disengage, and this time wouldn’t let me do anything but hold the power button until it shut down.

That might be it. Or it might not. :man_shrugging:

But then why is the partition NTFS?

If you share the drive with another PC, said PC might not have been properly shut down, or the device stopped when using it last time…


Bad luck

Usually you get some warning signs - like ratling and clicking noises - slow access.

Spinning disks in enclosures are very sensitive to the impact from a fall.

If the disks is from the same batch - they usually fail at the same time.

I have tried a complete 5disk array failure due to the disks being from the same batch. The failure appeared after a clean shutdown due to a thunderstorm - when I booted the NAS the next day - it was dead.

The data on the disks was vital to my business at the time so I paid a recovery specialist - that didn’t come cheap.

Paid or free - it is the same software - it is your login which matters.

The reason your system stopped responding was not ProtonVPN but your disk failing. Of course I cannot be sure - but it is a likely scenario.

Disks - espcially spinning disks - don’t last forever.

I think I had Windows on it at first and kept it NTFS. It has worked this way just fine for years now.

Ouch! Unfortunately at this point in time I cannot afford even a cheap recovery expert.

This might help:

I’ve used it successfully in the past.

Very good rescue system - but of little use if the disk won’t mount …

I’d say your best shot for fixing a NTFS file system - be sure to check the homepage - the link is to the ISO

1 Like

That’s why I said might.

And yes, hiren might as well.

Well CRAP! I had most of my data back up on my external back up drive…you know…the one that failed first! :wink: Not my day, my month or even my year! Thank you guys for your help. I need to get some sleep and hope the future looks brighter in the morning. I needed this on top of everything else like I need a hole in my head!

Have a great night…or morning actually. Thanks again. I will start fresh tomorrow with more hope.

1 Like

This is a shot in the dark, but I would suggest trying the following:
Mount the disk with a Windows system (this may automatically repair the volume).

After that, I would suggest NOT to use an “old” filesystem that you don’t have native support for.

Use ext4 or even better, use btrfs :smiling_face_with_three_hearts:

You can find good Information about Btrfs in the wiki

and in

Make Backups:

(This is a standard)

but you may also look at:

If used with btrfs it is an easy way to good 1-2-3 backups of btrfs-snapper-snapshots

1 Like