Keyboard shortcuts / hotkeys for brightness and volume stopped working, also cannot install anything from pamac

OK, then I cannot help you any further as you seem to have a keyboard definition problem and I’m not running XFCE. (KDE here)

While waiting for an XFCE expert to tell you how to change the keyboard hardware layout on XFCE, you can use the above command to change the brightness:

  • 255: maximum
  • 0: off (don’t try this one or you’ll have a black screen and need to type blind!)

Somewhere in the middle should be good, depending on your environmental conditions.


Note: In KDE, changing the keyboard hardware is done by going to System SettingskeyboardKeyboard Model

Find something similar in XFCE and take the correct keyboard layout and stuff should start working again! :crossed_fingers: (reboot might be required…)

So it should work in a bash shell.

I’m using zsh. Is it different than bash shell?

Yes it is a different one. You need same kind of package but for zsh.

I have now installed the package zsh-completions but I still can’t find aur packages nor official packages by pressing tab. Instead it just lists the directories or files in my computer.

Here’s a screenshot:

(I can’t link nor can I add media items to my text, this is really counter-productive)

The wanted behaviour would be that pressing tab after typing “pacman -S s” it would list installable packages that start with the letter s.

Please read this:

Forgot to say: pacman is an Arch utility, thus created for experts, by experts.
Instead, use the standard Manjaro tool

pamac search

to find packages and have a look at pamac --help for other commands.

If you search for a package name, use pacman -Ss then some letters within the package name
pacman -S s
just one letter is a little too short for effective autocompletion, but I have no idea how the completion is implemented

1 Like

But I used to be able to search for packages by just typing in “pacman -S (start of the package name I’m looking for, like ‘chro’, if I’m searching for chromium)”: “pacman -S chro”, and it would list out all the packages starting with chro just like it lists out files normally.

It was so much simpler and easier to follow like that instead of typing in “pacman -Ss chro”, because it lists out a huge, non-responsive list from which I can’t find anything I’m looking for: (ss: imgur . com/iCEtSL9.png), compared to the previous functionality (imgur . com/0yzO4ks.png), example shows directories/files because obviously it doesn’t work anymore :smiley:

How did it work before? I tried messing around with some theming and such and might have touched the zsh configs but I don’t know what I’ve changed so that the autocompletion doesn’t work for the packages anymore.

So install the same kind of package, for ZSH. In the AUR the official repos. Search for it.

If that worked and now it doesn’t it could be because of your shell.
Perhaps you used to use Bash
and now you are using zsh.
If that’s the case and the reason …
Shell can be changed easily:
chsh -u

I previously used zsh as well.

I have installed the same package for zsh, zsh-autocomplete-git.

Just to show the extent of the problems of such a simple task as installing a package:
For one, I cannot install anything from the visual environment of pamac, because it gives me the error “authentication failed”.

I tried to install spotify-adkiller-git by pacman -S, but it gives me “error: target spotify-adkiller-git not found” and “warning: ‘spotify-adkiller-git’ is a file. Did you mean the command -U/–upgrade instead of the command -S/–sync?” (my translations)

I tried to previously install it with the commands in the github page:

git clone
cd spotify-adkiller-git
makepkg -si

, but I can’t launch it because it can’t find some file, which I checked is in the folder…

How could my linux be this damn broken?

To add, I can’t even launch the program anymore since I uninstalled at least one instance of it but it still gives me the error… this is ridiculous :smiley:

You appear to be unaware of the fact that there are the “normal” software repositories, which can be accessed and managed via pacman and pamac
and then there is the AUR.
The GUI frontend for the latter (but not the former!) is called pamac-manager.
pamac-manager as well as pamac (but not pacman!) can also be used to build and install software from the AUR.
Your ad-killer can be had there.
pamac and it’s GUI frontend are the standard way to install software in Manjaro.
pacman can also be used - but not to access the AUR

Your approach to the problem of installing what you want was simply … wrong.
Don’t blame the tools you do not know how to use …

If you have an issue with failed authentication while using either tool,
which you didn’t seem to have before …,
then you need to look into that.

Come on… are you ignoring me or something?

Open Pamac, click the search button, type zsh-completions and click install on the one from the Manjaro repositories, not the AUR.

I don’t know if by asking me if I’m ignoring you that I haven’t replied to you, because I have or at least it has been my purpose to. I’ve replied to you that I have installed the zsh-completions package.

Here’s a ss:
imgur . com/9TGbgLx.png

Viralliset pakettilähteet = official package sources
Poista = remove
Koonti = compiling

I don’t see what I’ve done different? I do not mean to be abnoxious or anything like that, I’m just genuinely a true noob here. Sorry if I appear that way.

OK but you didn’t talk about the same package I was talking about, and talked about your AUR or maual compilation issues, so how do I know?

So with zsh-completions from official repo it doesn’t work for you? I tried to change my shell in Konsole to zsh, and restarted my terminal, indeed by default it doesn’t work.
BUT when I started my terminal with this new shell, I had this message

This is the Z Shell configuration function for new users,
You are seeing this message because you have no zsh startup files
(the files .zshenv, .zprofile, .zshrc, .zlogin in the directory
~). This function can help you with a few settings that should
make your use of the shell easier.

You can:

(q) Quit and do nothing. The function will be run again next time.

(0) Exit, creating the file ~/.zshrc containing just a comment.
That will prevent this function being run again.

(1) Continue to the main menu.

— Type one of the keys in parentheses —

So I typed 1 to go to “main menu”, then followed the next menus to select this

(2) Configure the new completion system. (Recommended.)

(1) Turn on completion with the default options.

After that autocompletion was working in my Konsole/ZSH

So make a backup of you ~/.zshrc file somewhere safe if you want to restore it, then delete it, and start your terminal, you will be prompted with same initial configuration because it doesn’t find the config file.

For some reason that didn’t generate a proper .zshrc file, but anyway inside the file that it created the only uncommented lines were:

zstyle :compinstall filename '/home/aksu/.zshrc'

autoload -Uz compinit

Those were missing from the original .zshrc config, I added them in, and now the functionality is very close to what I want it to be, it might be exactly like it was before, not sure though. I would see this problem as fixed now, thanks.

Do you know what can I do about the “authentication failed” message when trying to install stuff from the pamac GUI? I assume it’s the pamac gui anyway, I access the downloading platform by searching for “add or remove programs” (my translation, might not be exact). It doesn’t give me the prompt to type in my password.

That means you don’t type your ADMINISTRATOR (sudo) password I guess. Make sure CAPS are not activated, and that you type the proper password if you don’t have same password for user and administrator.

It doesn’t ask me for the passwords, it just straight up says “authentication failed” before I’ve had the chance to try and authenticate.

Here’s how it goes:
I click to install an app I want, then it says “1 operation pending” (my translation), I can either cancel or accept. I click accept, and pops up a message that says “authentication failed”. Do you know how I fix this? :smiley: