Password sometimes wrong


I’m using XFCE, most things in default settings. My user-password is not working on some places:

  • Login after (cold-)reboot works
  • Login after afk-logout “password wrong” (same dialog, as after reboot oO)
  • In terminal changing my password via “passwd” works (changes no symptoms above)
  • Changing password in XFCE settings GUI doesn’t work

I’m using a pure ASCII password, I’m 100% sure: no misstyping, correct keyboard layout, no caps.

It looks strongly like a bug, why can I login with my pw but not re-login after afk?? (It’s severe, because I lose work-results)

I googled a bit but searching for “login fails” or “my password does not work”… you know… all the folks who forget pw… =)

Is some bug known in this direction?


Maybe because of the gtk-greeter? Please post that terminal output:

grep -Ev "^#" /etc/lightdm/lightdm.conf

I used the slick-greeter, just for testing…

:notebook: gtk-greeter → xubuntu | slick-greeter → linuxmint

There are here and there problems with the lock screen on lightdm. If I would ever experience it, I would report it upstream. :man_shrugging:

https:// imgur. com/0v265I1.png

But this would not explain, why I can’t even change my password in the settings ui.

https:// imgur. com/jFqrrZr.png

Any idea? (wtf, I can’t even add links to screenshots?!)

As always:

Your are TL0. Reach TL1 and you can do this. That is a spam prevention made by discourse.

Please don’t post screenshots of text or terminal outputs. There is a so called copy&paste function plus you can format it here as code in markdown.

No idea :man_shrugging: It just works for me.

We don’t want screenshots of a terminal. Post actual preformatted text.

Does running

faillock --reset

make a difference?

Sorry for (trying of) posting screenshots. In my business pictures are saying much more than words.

[~]$ grep -Ev "^#" /etc/lightdm/lightdm.conf



faillock --reset

Makes no difference, the password settings dialog still says “Wrong password!” to my correct password. (edit: while passwd in terminal just works)

  1. There is no greeter specified, so I assume it is the gtk greeter. This is mine:




You need also installing lightdm-slick-greeter for my greeter here.

  1. Where do change the password?

I would go: Settings → Manjaro Settings Manager → UserAccounts → Choose the Account on the left → Double click on the password field

OK, I changed the greeter. It seems to work now.
I tried to change my password via “start” → typing “password” → clicking on the first result named “Kontodetails” (may something like “account-details” in english) This still not works.
This dialog pop up:


Sorry, no idea. But it seems not to be an xfce4 dialog, but well you are on unstable? Guess there is something new then.

Does it still happen when you use only English-ascii characters?

The reason im asking is because you obviously are working in a German locale but your system or the greeter might still be configured or operating in the English locale by default :thinking:

  • Changing the greeter did not helped, I got afk-logged out again with no password working. It seems that only afk-logout provokes this. If I manually go to log-screen, my pw works.
  • Again: my password is ASCII only, I’m sure, no caps mismatch, no y or z in it. Same keys on US and GER layout.
  • This problem occures for atleast 2 month.

Then im out of suggestions for now :woman_shrugging:
Assuming you can’t even login on the console in text mode when that happens?