Resolution sometimes gets set to 1024x768

Hello everyone, first post for me, I guess.
I have newly installed Manjaro about 2 weeks ago from writing. In the first week everything ran ok, but after that the resolution had suddenly changed to 1280x720 from the usual 1920x1080. This was observable right at boot (the small text on the left-hand corner that usually appears at boot was larger).
There are two users on this computer, one is myself as the admin account, while the other is for my sister (normal account). The resolution change had spanned across both users and the greeter. I had tried a solution from the forum (could not find the link, but it was something about entering the “tty” and writing exec xfcedesktop).
After a shutdown, the resolution had changed back to normal. I thought that would be the end of it but the busted resolution decided to appear once again, and during the use of last week, the resolution changed back and forth inconsistently, always after a complete shutdown.

This is what it normally looks like from display settings:

And this is what it looks like on the broken resolution:

Both screenshots are at fullscreen.
Note that I could not change the resolution in the “broken res” times. I am still a bit new to Manjaro, so do keep it simple if you can.


System Info
  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=89d788bd-2090-45f0-94bc-9fa89e675e8c rw quiet apparmor=1
  security=apparmor resume=UUID=acb4d482-530d-426f-8779-7d711fc61053
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 8
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME A320M-E v: Rev X.0x
  serial: <filter> UEFI: American Megatrends v: 5602 date: 07/14/2020
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M280/320/275
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes
  status: Discharging
  RAM: total: 5.72 GiB used: 2.79 GiB (48.7%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64
  type: MCP arch: Zen family: 17 (23) model-id: 18 (24) stepping: 1
  microcode: 8108109 cache: L2: 2 MiB bogomips: 28762
  Speed: 1397 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz):
  1: 1397 2: 1323 3: 1414 4: 1368
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel
  bus-ID: 07:00.0 chip-ID: 1002:15d8 class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: ati,modesetting unloaded: radeon alternate: fbdev,vesa
  display-ID: :1.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
  s-diag: 583mm (23")
  Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6")
  diag: 546mm (21.5")
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.41.0
  5.13.19-2-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio
  vendor: ASUSTeK PRIME B450M-A driver: snd_hda_intel v: kernel
  bus-ID: 07:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK PRIME B450M-A
  driver: snd_hda_intel v: kernel bus-ID: 07:00.6 chip-ID: 1022:15e3
  class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: ASUSTeK PRIME B450M-A driver: r8168 v: 8.049.02-NAPI modules: r8169
  port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.13 TiB used: 11.35 GiB (1.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD240G
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 5A0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM010-2EP102
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 7200 serial: <filter> rev: CC46 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 128 GiB size: 124.93 GiB (97.60%) used: 9.48 GiB (7.6%)
  fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
  uuid: 89d788bd-2090-45f0-94bc-9fa89e675e8c
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
  uuid: 5B89-C921
  ID-3: /home raw-size: 91.28 GiB size: 89.28 GiB (97.82%)
  used: 1.87 GiB (2.1%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: N/A
  uuid: 32c9e49f-0b95-4950-b7b1-8d2a77ac2e1a
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: acb4d482-530d-426f-8779-7d711fc61053
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 9 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 3 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Logitech Unifying Receiver type: Mouse,HID
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 98mA chip-ID: 046d:c52f class-ID: 0300
  Device-2: 3-4:3 info: A4Tech KV-300H Isolation Keyboard type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
  power: 100mA chip-ID: 09da:0260 class-ID: 0300
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 6-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 48.6 C mobo: N/A gpu: amdgpu temp: 48.0 C
  Fan Speeds (RPM): N/A
  Processes: 326 Uptime: 3h 39m wakeups: 366 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 Packages: 1125 pacman: 1120 lib: 334
  flatpak: 5 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.08

Hi @bluebudgie, and welcome!

While I have absolutely no idea what could be the cause of this, anyone who can possibly identify the issue needs more information. To that end, please see How to provide good information and, if applicable, please see [HowTo] post screenshots and links.

Hope you get this sorted!

1 Like

Thanks for the info. I will be editing the original post with the appropriate things.

Try switching the computer on before you switch the monitor on.
I had the same problem and that worked for me.

Hello @bluebudgie,

what looks strange to me is the different naming of the monitor which is shown in the screenshots. Normaly this name comes from the monitor itself. And in the first screenshot the data your computer gets from monitor should be right. In the second screenshot your computer gets wrong or no data from your monitor. If you conected the same monitor both times while making the screenshot so your monitor or the cable is the problem.

So I advise to try another calbe first.

The “Do not use RTK” -monitor was yet in town befor: :grinning:

thanks for the answers, i’ll see which one of them works through the week.

I had a similar problem wayyyyyyy back with an old CRT tv connected with some converters to vga. Also with a yiynova digitizer (monitor to draw on)

What is happening I’m pretty sure is the same thing as what was happening to me back then, your monitor is not properly sending it’s EDID information to your PC (and so some kind of generic EDID is used instead, which doesn’t match your display), there are many possible reasons for this (one of which is that the cable or port with which the monitor is connected to the PC with has been damaged, or is somehow faulty)

My first advice is to try another cable and perhaps plugging the monitor into another port on your pc if one is available.

If that doesn’t work though, you can use a custom EDID, the ideal way would be to copy the EDID information from your monitor when it is correctly detected (like in your first pic) then force your display server to use that EDID.

It’s been a while so I don’t remember how exactly this is done, I’m pretty sure X can do it, not as sure about Wayland though.

Regardless of what solution you use though, it’d be a good idea to try to save your monitors EDID to a file when it is working correctly so that if the problem ever becomes permanent (i.e. ur monitor is never detected correctly anymore) you at least have the file saved to manually override it.

well, the system has probably auto-configured itself at this point, as those display issues had not cropped up yet. but do send me a message about the finding and setting of EDID info, as i may need to do that if such an issue ever comes up during my time of use.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.