Can't get past splash screen on live usb

New computer, Nvidia rtx 4090. I can’t get past the Manjaro splash screen with either proprietary or free drivers. With proprietary, I get stuck on the splash screen indefinitely and can’t get a tty. With the free drivers, eventually the splash screen seems to crash and I can then get into a tty. From there I tried to run startx which predictably failed with (EE) no screens found. But that also let me get some Xorg logs which might be useful?
<I’m apparently not allowed to embed images, I don’t know how else to get logs off the system right now>
Notably it seems to me like it’s an unsupported card (“devices detected but none match those in the config file”).

I can’t figure out how to proceed because without being able to get a desktop I can’t run the installer and I can’t do any of the stuff I’d normally try IE updating drivers. Any help appreciated, even if it just gets a desktop temporarily.

Did you check the hash of the iso you downloaded?

Hi and welcome to the forum :+1:

To help others help you better you need to provide more details about the steps you did before you hit your problem…
Start with:

  1. Which Operating system do you use normally,
  2. Which Manjaro image did you download,
    (Give the URL) [HowTo] Post screenshots and links
  3. Where did you store that Manjaro image,
    (USB-Stick / CD/DVD / Harddisk)
  4. Did you check the image using it’s checksum / hash files?
    Check a Downloaded ISO Image For Errors - Manjaro
  5. How do you start that Manjaro image.
    (Do you boot your computer with it or do you use a Virtual Machine)
  6. Do you have Secure Boot enabled in your UEFI-BIOS.

Thanks for the responses. I’ll just respond here since Jim only asked about the checksum.

  1. I basically put Manjaro on everything, I haven’t used other distros in a while.
  2. Manjaro KDE Plasma Lite, I can’t post a url because I’m a new user (I swear I used to have an account on this email, not sure what happened…)
  3. Stored on a usb-stick.
  4. I didn’t check the checksum, but I did just now. Looks ok.
  5. I am booting the USB.
  6. Secure boot is disabled.

it looks like manjaro didnt add this card to their mhwd tool yet…
you can try also booting the usb with this parameter:
heres a link where you put it during booting the usb…

Yes, that worked! The open source drivers still seemed to crash the same way, but with this setting the proprietary drivers eventually got to a desktop.

Thanks so much

you will also have to add this parameter in your installation, otherwise you will end up again with a black screen…
you can add it via chroot, or again during booting, and then make it permanent by adding it to grub conf

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.